diff mbox series

[meta-oe] brotli: upgrade 1.0.9 -> 1.1.0

Message ID 20231129184722.458288-1-alperyasinak1@gmail.com
State Under Review
Headers show
Series [meta-oe] brotli: upgrade 1.0.9 -> 1.1.0 | expand

Commit Message

Alper Ak Nov. 29, 2023, 6:47 p.m. UTC
- Removed patch because of fixed in the new version.

Changelog:

Added

    * decoder: BrotliDecoderAttachDictionary
    * decoder: BrotliDecoderOnFinish callback behind BROTLI_REPORTING
    * decoder: BrotliDecoderSetMetadataCallbacks
    * encoder: BrotliEncoderPrepareDictionary,
    * BrotliEncoderDestroyPreparedDictionary,
    * BrotliEncoderAttachPreparedDictionary
    * decoder: BrotliEncoderOnFinish callback behind BROTLI_REPORTING
    * common: BrotliSharedDictionaryCreateInstance,
    * BrotliSharedDictionaryDestroyInstance,
    * BrotliSharedDictionaryAttach
    * CLI: --dictionary option
    * java: encoder wrapper: Parameters.mode
    * java: Brotli{Input|Output}Stream.attachDictionary
    * java: wrapper: partial byte array input
    * typescript: decoder (transpiled from Java)

Removed

    * build: BROTLI_BUILD_PORTABLE option

Fixed

    * java: JNI decoder failed sometimes on power of 2 payloads

Improved

    * java / js: smaller decoder footprint
    * decoder: faster decoding
    * encoder: faster encoding
    * encoder: smaller stack frames

Signed-off-by: alperak <alperyasinak1@gmail.com>
---
 .../recipes-extended/brotli/brotli/838.patch  | 48 -------------------
 .../{brotli_1.0.9.bb => brotli_1.1.0.bb}      |  7 ++-
 2 files changed, 3 insertions(+), 52 deletions(-)
 delete mode 100644 meta-oe/recipes-extended/brotli/brotli/838.patch
 rename meta-oe/recipes-extended/brotli/{brotli_1.0.9.bb => brotli_1.1.0.bb} (87%)
diff mbox series

Patch

diff --git a/meta-oe/recipes-extended/brotli/brotli/838.patch b/meta-oe/recipes-extended/brotli/brotli/838.patch
deleted file mode 100644
index 98b888760..000000000
--- a/meta-oe/recipes-extended/brotli/brotli/838.patch
+++ /dev/null
@@ -1,48 +0,0 @@ 
-Upstream-Status: Backport [https://github.com/google/brotli/pull/838]
-From 092446fafb4bfb81738853b7c7f76b293cd92a80 Mon Sep 17 00:00:00 2001
-From: Evgenii Kliuchnikov <eustas.ru@gmail.com>
-Date: Wed, 2 Sep 2020 10:49:49 +0200
-Subject: [PATCH] Revert "Add runtime linker path to pkg-config files (#740)"
-
-This reverts commit 31754d4ffce14153b5c2addf7a11019ec23f51c1.
----
- scripts/libbrotlicommon.pc.in | 2 +-
- scripts/libbrotlidec.pc.in    | 2 +-
- scripts/libbrotlienc.pc.in    | 2 +-
- 3 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/scripts/libbrotlicommon.pc.in b/scripts/libbrotlicommon.pc.in
-index 10ca969e..2a8cf7a3 100644
---- a/scripts/libbrotlicommon.pc.in
-+++ b/scripts/libbrotlicommon.pc.in
-@@ -7,5 +7,5 @@ Name: libbrotlicommon
- URL: https://github.com/google/brotli
- Description: Brotli common dictionary library
- Version: @PACKAGE_VERSION@
--Libs: -L${libdir} -R${libdir} -lbrotlicommon
-+Libs: -L${libdir} -lbrotlicommon
- Cflags: -I${includedir}
-diff --git a/scripts/libbrotlidec.pc.in b/scripts/libbrotlidec.pc.in
-index e7c3124f..6f8ef2e4 100644
---- a/scripts/libbrotlidec.pc.in
-+++ b/scripts/libbrotlidec.pc.in
-@@ -7,6 +7,6 @@ Name: libbrotlidec
- URL: https://github.com/google/brotli
- Description: Brotli decoder library
- Version: @PACKAGE_VERSION@
--Libs: -L${libdir} -R${libdir} -lbrotlidec
-+Libs: -L${libdir} -lbrotlidec
- Requires.private: libbrotlicommon >= 1.0.2
- Cflags: -I${includedir}
-diff --git a/scripts/libbrotlienc.pc.in b/scripts/libbrotlienc.pc.in
-index 4dd0811b..2098afe2 100644
---- a/scripts/libbrotlienc.pc.in
-+++ b/scripts/libbrotlienc.pc.in
-@@ -7,6 +7,6 @@ Name: libbrotlienc
- URL: https://github.com/google/brotli
- Description: Brotli encoder library
- Version: @PACKAGE_VERSION@
--Libs: -L${libdir} -R${libdir} -lbrotlienc
-+Libs: -L${libdir} -lbrotlienc
- Requires.private: libbrotlicommon >= 1.0.2
- Cflags: -I${includedir}
diff --git a/meta-oe/recipes-extended/brotli/brotli_1.0.9.bb b/meta-oe/recipes-extended/brotli/brotli_1.1.0.bb
similarity index 87%
rename from meta-oe/recipes-extended/brotli/brotli_1.0.9.bb
rename to meta-oe/recipes-extended/brotli/brotli_1.1.0.bb
index 708c1c194..83f44833b 100644
--- a/meta-oe/recipes-extended/brotli/brotli_1.0.9.bb
+++ b/meta-oe/recipes-extended/brotli/brotli_1.1.0.bb
@@ -6,10 +6,9 @@  BUGTRACKER = "https://github.com/google/brotli/issues"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=941ee9cd1609382f946352712a319b4b"
 
-SRC_URI = "git://github.com/google/brotli.git;branch=master;protocol=https \
-           file://838.patch "
-# tag 1.0.9
-SRCREV= "e61745a6b7add50d380cfd7d3883dd6c62fc2c71"
+SRC_URI = "git://github.com/google/brotli.git;branch=master;protocol=https"
+SRCREV= "ed738e842d2fbdf2d6459e39267a633c4a9b2f5d"
+
 S = "${WORKDIR}/git"
 
 inherit cmake lib_package