diff mbox series

[meta-python] python3-pydantic: upgrade 2.5.1 -> 2.5.2

Message ID 1701160714-28412-1-git-send-email-wangmy@fujitsu.com
State Accepted
Headers show
Series [meta-python] python3-pydantic: upgrade 2.5.1 -> 2.5.2 | expand

Commit Message

Mingyu Wang (Fujitsu) Nov. 28, 2023, 8:38 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
==========
-uprev pydantic-core to 2.14.5
-Add ConfigDict.ser_json_inf_nan
-Fix validation of Literal from JSON keys when used as dict key
-Fix bug re custom_init on members of Union
-Fix JsonValue bool serialization
-Fix handling of unhashable inputs with Literal in Unions

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{python3-pydantic_2.5.1.bb => python3-pydantic_2.5.2.bb}    | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-pydantic_2.5.1.bb => python3-pydantic_2.5.2.bb} (86%)

Comments

Khem Raj Nov. 28, 2023, 11:55 p.m. UTC | #1
On Tue, 28 Nov 2023 16:38:34 +0800, wangmy@fujitsu.com wrote:
> Changelog:
> ==========
> -uprev pydantic-core to 2.14.5
> -Add ConfigDict.ser_json_inf_nan
> -Fix validation of Literal from JSON keys when used as dict key
> -Fix bug re custom_init on members of Union
> -Fix JsonValue bool serialization
> -Fix handling of unhashable inputs with Literal in Unions
> 
> [...]

Applied, thanks!

[1/1] python3-pydantic: upgrade 2.5.1 -> 2.5.2
      commit: 0260e1498e475899d1c13c05f928c5a886d151c4

Best regards,
Tim Orling Nov. 29, 2023, 4:43 a.m. UTC | #2
FWIW, this is not run-time useful because of the missing
python3-pydantic-core dependency (which requires 'maturin' backend).
Since
https://github.com/pydantic/pydantic/commit/594effa279668bd955e98f1cd5c036b37d3bbd40

Sadly, the build does not report any issues and this has been lurking
quietly for quite some time. There is no reason to skip this
particular update. The issue crept in quite a while ago.

This will be corrected in the coming days as python3-maturin and a
python_maturin.bbclass are added to oe-core to enable
building the python3-pydantic-core package. Backporting will have to be
done in a mixin layer.

On Tue, Nov 28, 2023 at 3:55 PM Khem Raj <raj.khem@gmail.com> wrote:

>
> On Tue, 28 Nov 2023 16:38:34 +0800, wangmy@fujitsu.com wrote:
> > Changelog:
> > ==========
> > -uprev pydantic-core to 2.14.5
> > -Add ConfigDict.ser_json_inf_nan
> > -Fix validation of Literal from JSON keys when used as dict key
> > -Fix bug re custom_init on members of Union
> > -Fix JsonValue bool serialization
> > -Fix handling of unhashable inputs with Literal in Unions
> >
> > [...]
>
> Applied, thanks!
>
> [1/1] python3-pydantic: upgrade 2.5.1 -> 2.5.2
>       commit: 0260e1498e475899d1c13c05f928c5a886d151c4
>
> Best regards,
> --
> Khem Raj <raj.khem@gmail.com>
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#107117):
> https://lists.openembedded.org/g/openembedded-devel/message/107117
> Mute This Topic: https://lists.openembedded.org/mt/102847338/924729
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> ticotimo@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Khem Raj Nov. 29, 2023, 5:31 a.m. UTC | #3
On Tue, Nov 28, 2023 at 8:43 PM Tim Orling <ticotimo@gmail.com> wrote:
>
> FWIW, this is not run-time useful because of the missing python3-pydantic-core dependency (which requires 'maturin' backend).
> Since https://github.com/pydantic/pydantic/commit/594effa279668bd955e98f1cd5c036b37d3bbd40
>

Adding ptests might be good to catch runtime errors. Perhaps after
maturin backend. There is no easy way otherwise to check runtime
validity.

> Sadly, the build does not report any issues and this has been lurking quietly for quite some time. There is no reason to skip this
> particular update. The issue crept in quite a while ago.
>

> This will be corrected in the coming days as python3-maturin and a python_maturin.bbclass are added to oe-core to enable
> building the python3-pydantic-core package. Backporting will have to be done in a mixin layer.
>
> On Tue, Nov 28, 2023 at 3:55 PM Khem Raj <raj.khem@gmail.com> wrote:
>>
>>
>> On Tue, 28 Nov 2023 16:38:34 +0800, wangmy@fujitsu.com wrote:
>> > Changelog:
>> > ==========
>> > -uprev pydantic-core to 2.14.5
>> > -Add ConfigDict.ser_json_inf_nan
>> > -Fix validation of Literal from JSON keys when used as dict key
>> > -Fix bug re custom_init on members of Union
>> > -Fix JsonValue bool serialization
>> > -Fix handling of unhashable inputs with Literal in Unions
>> >
>> > [...]
>>
>> Applied, thanks!
>>
>> [1/1] python3-pydantic: upgrade 2.5.1 -> 2.5.2
>>       commit: 0260e1498e475899d1c13c05f928c5a886d151c4
>>
>> Best regards,
>> --
>> Khem Raj <raj.khem@gmail.com>
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#107117): https://lists.openembedded.org/g/openembedded-devel/message/107117
>> Mute This Topic: https://lists.openembedded.org/mt/102847338/924729
>> Group Owner: openembedded-devel+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [ticotimo@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pydantic_2.5.1.bb b/meta-python/recipes-devtools/python/python3-pydantic_2.5.2.bb
similarity index 86%
rename from meta-python/recipes-devtools/python/python3-pydantic_2.5.1.bb
rename to meta-python/recipes-devtools/python/python3-pydantic_2.5.2.bb
index 609411fe1..3750d49a9 100644
--- a/meta-python/recipes-devtools/python/python3-pydantic_2.5.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pydantic_2.5.2.bb
@@ -5,7 +5,7 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=09280955509d1c4ca14bae02f21d49a6"
 
 inherit pypi python_hatchling
 
-SRC_URI[sha256sum] = "0b8be5413c06aadfbe56f6dc1d45c9ed25fd43264414c571135c97dd77c2bedb"
+SRC_URI[sha256sum] = "ff177ba64c6faf73d7afa2e8cad38fd456c0dbe01c9954e71038001cd15a6edd"
 
 DEPENDS += "python3-hatch-fancy-pypi-readme-native"