diff mbox series

[meta-python] python3-pexpect: upgrade 4.8.0 -> 4.9.0

Message ID 1701160603-28318-1-git-send-email-wangmy@fujitsu.com
State Accepted
Headers show
Series [meta-python] python3-pexpect: upgrade 4.8.0 -> 4.9.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Nov. 28, 2023, 8:36 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
==========
-Add support for Python 3.12
-Clean up temporary files after UnicodeTests
-Add Python 3.5, 3.6 and 3.12.0-rc.1 to test matrix
-Set prompt correctly for zsh
-Add zsh convenience function to replwrap module
-Rework async unittests to rely on unittest.IsolatedAsyncioTestCase
-Make test_expect.py work on POSIX systems that are not Linux based
-Add support for socket, which allows sockets to be used crossplatform
-Update async to work on newer versions of python
-Remove deprecated RSAAuthentication option (SSHv1)
-Multiple CI fixes
-Use Github Actions for CI
-Remove pytest-capturelog from testing requirements
-Fix usage for Solaris
-Fix threading for new versions of python
-Fix documentation builds for use with Sphinx 3
-Use sys.executable for tests and wrapper, allowing the calling python executable to be used instead
-Update documentation about Wexpect
-Added project urls to setup.py
-Provide examples for how to use Pexpect and Pyte
-Coerce compiled regex patterns type according to spawn encoding
-Several doc updates

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{python3-pexpect_4.8.0.bb => python3-pexpect_4.9.0.bb}     | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-pexpect_4.8.0.bb => python3-pexpect_4.9.0.bb} (80%)

Comments

Khem Raj Nov. 28, 2023, 11:55 p.m. UTC | #1
On Tue, 28 Nov 2023 16:36:43 +0800, wangmy@fujitsu.com wrote:
> Changelog:
> ==========
> -Add support for Python 3.12
> -Clean up temporary files after UnicodeTests
> -Add Python 3.5, 3.6 and 3.12.0-rc.1 to test matrix
> -Set prompt correctly for zsh
> -Add zsh convenience function to replwrap module
> -Rework async unittests to rely on unittest.IsolatedAsyncioTestCase
> -Make test_expect.py work on POSIX systems that are not Linux based
> -Add support for socket, which allows sockets to be used crossplatform
> -Update async to work on newer versions of python
> -Remove deprecated RSAAuthentication option (SSHv1)
> -Multiple CI fixes
> -Use Github Actions for CI
> -Remove pytest-capturelog from testing requirements
> -Fix usage for Solaris
> -Fix threading for new versions of python
> -Fix documentation builds for use with Sphinx 3
> -Use sys.executable for tests and wrapper, allowing the calling python executable to be used instead
> -Update documentation about Wexpect
> -Added project urls to setup.py
> -Provide examples for how to use Pexpect and Pyte
> -Coerce compiled regex patterns type according to spawn encoding
> -Several doc updates
> 
> [...]

Applied, thanks!

[1/1] python3-pexpect: upgrade 4.8.0 -> 4.9.0
      commit: 42907a1786ed53e96c0fcc50ffc69253f51e5c94

Best regards,
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pexpect_4.8.0.bb b/meta-python/recipes-devtools/python/python3-pexpect_4.9.0.bb
similarity index 80%
rename from meta-python/recipes-devtools/python/python3-pexpect_4.8.0.bb
rename to meta-python/recipes-devtools/python/python3-pexpect_4.9.0.bb
index ed2540608..6ee5b25bd 100644
--- a/meta-python/recipes-devtools/python/python3-pexpect_4.8.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pexpect_4.9.0.bb
@@ -6,8 +6,7 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=1c7a725251880af8c6a148181665385b"
 
 SRC_URI += "file://0001-FSM.py-change-shebang-from-python-to-python3.patch"
 
-SRC_URI[md5sum] = "153eb25184249d6a85fde9acf4804085"
-SRC_URI[sha256sum] = "fc65a43959d153d0114afe13997d439c22823a27cefceb5ff35c2178c6784c0c"
+SRC_URI[sha256sum] = "ee7d41123f3c9911050ea2c2dac107568dc43b2d3b0c7557a33212c398ead30f"
 
 inherit pypi setuptools3