diff mbox series

pciutils: add packageconfigs for options

Message ID 20231123113452.1697802-1-f_l_k@t-online.de
State New
Headers show
Series pciutils: add packageconfigs for options | expand

Commit Message

Markus Volk Nov. 23, 2023, 11:34 a.m. UTC
My motivation for this is to get zlib support selectable, because
libosinfo requires the pci.ids file uncompressed. Add packageconfigs for
the other options as well to avoid autoselect.

Configuration stays the same besides zlib is deselected by default.

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 meta/recipes-bsp/pciutils/pciutils_3.10.0.bb | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

Comments

Khem Raj Nov. 27, 2023, 1:18 a.m. UTC | #1
I am seeing configure failures

   8923  | /mnt/b/yoe/master/build/tmp/work/cortexa72-cortexa53-crypto-yoe-linux/pciutils/3.10.0/temp/run.do_configure.1786381:
line 149: DNS=yes: command not found

On Thu, Nov 23, 2023 at 3:34 AM Markus Volk <f_l_k@t-online.de> wrote:
>
> My motivation for this is to get zlib support selectable, because
> libosinfo requires the pci.ids file uncompressed. Add packageconfigs for
> the other options as well to avoid autoselect.
>
> Configuration stays the same besides zlib is deselected by default.
>
> Signed-off-by: Markus Volk <f_l_k@t-online.de>
> ---
>  meta/recipes-bsp/pciutils/pciutils_3.10.0.bb | 11 ++++++-----
>  1 file changed, 6 insertions(+), 5 deletions(-)
>
> diff --git a/meta/recipes-bsp/pciutils/pciutils_3.10.0.bb b/meta/recipes-bsp/pciutils/pciutils_3.10.0.bb
> index e27cfd4ced..4bde090169 100644
> --- a/meta/recipes-bsp/pciutils/pciutils_3.10.0.bb
> +++ b/meta/recipes-bsp/pciutils/pciutils_3.10.0.bb
> @@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
>  # Can drop make-native when all systems have make 4.3
>  # https://git.savannah.gnu.org/cgit/make.git/commit/?id=b90fabc8d6f34fb37d428dc0fb1b8b1951a9fbed
>  # causes space issues in lib/libpci.pc
> -DEPENDS = "zlib kmod make-native"
> +DEPENDS = "make-native"
>
>  SRC_URI = "${KERNELORG_MIRROR}/software/utils/pciutils/pciutils-${PV}.tar.xz \
>             file://configure.patch"
> @@ -18,10 +18,11 @@ SRC_URI[sha256sum] = "238a2e27166730e53a17fe07bfad229e07fa39b618117e5944b6d7eda9
>
>  inherit multilib_header pkgconfig update-alternatives
>
> -PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'hwdb', '', d)}"
> +PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'hwdb', '', d)} dns kmod"
>  PACKAGECONFIG[hwdb] = "HWDB=yes,HWDB=no,udev"
> -
> -PCI_CONF_FLAG = "ZLIB=yes DNS=yes SHARED=yes STRIP= LIBDIR=${libdir}"
> +PACKAGECONFIG[zlib] = "ZLIB=yes,ZLIB=no,zlib"
> +PACKAGECONFIG[kmod] = "LIBKMOD=yes,LIBKMOD=no,kmod"
> +PACKAGECONFIG[dns] = "DNS=yes,DNS=no"
>
>  # see configure.patch
>  do_configure () {
> @@ -38,7 +39,7 @@ export SBINDIR = "${sbindir}"
>  export SHAREDIR = "${datadir}"
>  export MANDIR = "${mandir}"
>
> -EXTRA_OEMAKE = "-e MAKEFLAGS= ${PCI_CONF_FLAG}"
> +EXTRA_OEMAKE = "-e MAKEFLAGS= SHARED=yes STRIP= LIBDIR=${libdir}"
>
>  ASNEEDED = ""
>
> --
> 2.42.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#191142): https://lists.openembedded.org/g/openembedded-core/message/191142
> Mute This Topic: https://lists.openembedded.org/mt/102765276/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Markus Volk Nov. 27, 2023, 7:03 a.m. UTC | #2
On Sun, Nov 26 2023 at 05:18:16 PM -08:00:00, Khem Raj 
<raj.khem@gmail.com> wrote:
> I am seeing configure failures

-e MAKEFLAGS= needs to be last in EXTRA_OEMAKE

Sorry, not sure why I didn't catch this
diff mbox series

Patch

diff --git a/meta/recipes-bsp/pciutils/pciutils_3.10.0.bb b/meta/recipes-bsp/pciutils/pciutils_3.10.0.bb
index e27cfd4ced..4bde090169 100644
--- a/meta/recipes-bsp/pciutils/pciutils_3.10.0.bb
+++ b/meta/recipes-bsp/pciutils/pciutils_3.10.0.bb
@@ -9,7 +9,7 @@  LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
 # Can drop make-native when all systems have make 4.3
 # https://git.savannah.gnu.org/cgit/make.git/commit/?id=b90fabc8d6f34fb37d428dc0fb1b8b1951a9fbed
 # causes space issues in lib/libpci.pc
-DEPENDS = "zlib kmod make-native"
+DEPENDS = "make-native"
 
 SRC_URI = "${KERNELORG_MIRROR}/software/utils/pciutils/pciutils-${PV}.tar.xz \
            file://configure.patch"
@@ -18,10 +18,11 @@  SRC_URI[sha256sum] = "238a2e27166730e53a17fe07bfad229e07fa39b618117e5944b6d7eda9
 
 inherit multilib_header pkgconfig update-alternatives
 
-PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'hwdb', '', d)}"
+PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'hwdb', '', d)} dns kmod"
 PACKAGECONFIG[hwdb] = "HWDB=yes,HWDB=no,udev"
-
-PCI_CONF_FLAG = "ZLIB=yes DNS=yes SHARED=yes STRIP= LIBDIR=${libdir}"
+PACKAGECONFIG[zlib] = "ZLIB=yes,ZLIB=no,zlib"
+PACKAGECONFIG[kmod] = "LIBKMOD=yes,LIBKMOD=no,kmod"
+PACKAGECONFIG[dns] = "DNS=yes,DNS=no"
 
 # see configure.patch
 do_configure () {
@@ -38,7 +39,7 @@  export SBINDIR = "${sbindir}"
 export SHAREDIR = "${datadir}"
 export MANDIR = "${mandir}"
 
-EXTRA_OEMAKE = "-e MAKEFLAGS= ${PCI_CONF_FLAG}"
+EXTRA_OEMAKE = "-e MAKEFLAGS= SHARED=yes STRIP= LIBDIR=${libdir}"
 
 ASNEEDED = ""