diff mbox series

[hardknott,1/2] libtirpc: add support for configuring and building with --enable-gssapi

Message ID 20231120212436.27604-1-stefan.ghinea@windriver.com
State New
Headers show
Series [hardknott,1/2] libtirpc: add support for configuring and building with --enable-gssapi | expand

Commit Message

Stefan Ghinea Nov. 20, 2023, 9:24 p.m. UTC
nfs-utils with gss and svcgss has libtirpc configured with gssapi option
as a dependency.

Signed-off-by: Stefan Ghinea <stefan.ghinea@windriver.com>
---
 meta/recipes-extended/libtirpc/libtirpc_1.3.1.bb | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

Comments

Mittal, Anuj Nov. 21, 2023, 8:53 a.m. UTC | #1
Is this for hardknott? That release isn't maintained anymore.

Thanks,

Anuj

On Mon, 2023-11-20 at 23:24 +0200, Stefan Ghinea via
lists.openembedded.org wrote:
> nfs-utils with gss and svcgss has libtirpc configured with gssapi
> option
> as a dependency.
> 
> Signed-off-by: Stefan Ghinea <stefan.ghinea@windriver.com>
> ---
>  meta/recipes-extended/libtirpc/libtirpc_1.3.1.bb | 6 +++++-
>  1 file changed, 5 insertions(+), 1 deletion(-)
> 
> diff --git a/meta/recipes-extended/libtirpc/libtirpc_1.3.1.bb
> b/meta/recipes-extended/libtirpc/libtirpc_1.3.1.bb
> index 32fb651130..5ae91b6df3 100644
> --- a/meta/recipes-extended/libtirpc/libtirpc_1.3.1.bb
> +++ b/meta/recipes-extended/libtirpc/libtirpc_1.3.1.bb
> @@ -18,7 +18,11 @@ SRC_URI[sha256sum] =
> "245895caf066bec5e3d4375942c8cb4366adad184c29c618d97f724ea3
>  
>  inherit autotools pkgconfig
>  
> -EXTRA_OECONF = "--disable-gssapi"
> +PACKAGECONFIG ??= "\
> +    ${@bb.utils.filter('DISTRO_FEATURES', 'krb5', d)} \
> +"
> +# krb5 is available in meta-oe
> +PACKAGECONFIG[krb5] = "--enable-gssapi,--disable-gssapi,krb5"
>  
>  do_install_append() {
>         chown root:root ${D}${sysconfdir}/netconfig
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#190931):
> https://lists.openembedded.org/g/openembedded-core/message/190931
> Mute This Topic: https://lists.openembedded.org/mt/102716185/3616702
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe:
> https://lists.openembedded.org/g/openembedded-core/unsub [
> anuj.mittal@intel.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-extended/libtirpc/libtirpc_1.3.1.bb b/meta/recipes-extended/libtirpc/libtirpc_1.3.1.bb
index 32fb651130..5ae91b6df3 100644
--- a/meta/recipes-extended/libtirpc/libtirpc_1.3.1.bb
+++ b/meta/recipes-extended/libtirpc/libtirpc_1.3.1.bb
@@ -18,7 +18,11 @@  SRC_URI[sha256sum] = "245895caf066bec5e3d4375942c8cb4366adad184c29c618d97f724ea3
 
 inherit autotools pkgconfig
 
-EXTRA_OECONF = "--disable-gssapi"
+PACKAGECONFIG ??= "\
+    ${@bb.utils.filter('DISTRO_FEATURES', 'krb5', d)} \
+"
+# krb5 is available in meta-oe
+PACKAGECONFIG[krb5] = "--enable-gssapi,--disable-gssapi,krb5"
 
 do_install_append() {
 	chown root:root ${D}${sysconfdir}/netconfig