diff mbox series

[meta-ti,kirkstone] ti-gc320-driver: fix stdarg header file compilation issues

Message ID 20231115105842.4629-1-sinthu.raja@ti.com
State Rejected
Delegated to: Ryan Eatmon
Headers show
Series [meta-ti,kirkstone] ti-gc320-driver: fix stdarg header file compilation issues | expand

Commit Message

Sinthu Raja M Nov. 15, 2023, 10:58 a.m. UTC
From: Sinthu Raja <sinthu.raja@ti.com>

The stdarg header file location is changed to linux/stdarg.h. Add patch
to fix the compilation issue and also add fix to import DMA_BUF namspace
to load the dma_buf modules

Signed-off-by: Sinthu Raja <sinthu.raja@ti.com>
---
 ...tdarg-header-file-compilation-issues.patch | 43 +++++++++++++++++++
 ...F-namespace-to-load-the-dma_buf-modu.patch | 28 ++++++++++++
 .../ti-gc320-driver_5.0.11.p7.bb              |  4 +-
 3 files changed, 74 insertions(+), 1 deletion(-)
 create mode 100644 meta-ti-bsp/recipes-bsp/gc320-drivers/files/0001-km-Fix-stdarg-header-file-compilation-issues.patch
 create mode 100644 meta-ti-bsp/recipes-bsp/gc320-drivers/files/0002-km-import-DMA_BUF-namespace-to-load-the-dma_buf-modu.patch

Comments

Bajjuri, Praneeth Nov. 15, 2023, 5:39 p.m. UTC | #1
updating denys email id

On 11/15/2023 4:58 AM, Sinthu Raja M via lists.yoctoproject.org wrote:
> From: Sinthu Raja <sinthu.raja@ti.com>
> 
> The stdarg header file location is changed to linux/stdarg.h. Add patch
> to fix the compilation issue and also add fix to import DMA_BUF namspace
> to load the dma_buf modules
> 
> Signed-off-by: Sinthu Raja <sinthu.raja@ti.com>
> ---
>   ...tdarg-header-file-compilation-issues.patch | 43 +++++++++++++++++++
>   ...F-namespace-to-load-the-dma_buf-modu.patch | 28 ++++++++++++
>   .../ti-gc320-driver_5.0.11.p7.bb              |  4 +-

Why not patch it at
https://git.ti.com/cgit/graphics/ti-gc320-driver/

and have a branch ti-5.0.11.p7-k6.1 ?

and only do SRCREV update and rename the bb recipe?


>   3 files changed, 74 insertions(+), 1 deletion(-)
>   create mode 100644 meta-ti-bsp/recipes-bsp/gc320-drivers/files/0001-km-Fix-stdarg-header-file-compilation-issues.patch
>   create mode 100644 meta-ti-bsp/recipes-bsp/gc320-drivers/files/0002-km-import-DMA_BUF-namespace-to-load-the-dma_buf-modu.patch
> 
> diff --git a/meta-ti-bsp/recipes-bsp/gc320-drivers/files/0001-km-Fix-stdarg-header-file-compilation-issues.patch b/meta-ti-bsp/recipes-bsp/gc320-drivers/files/0001-km-Fix-stdarg-header-file-compilation-issues.patch
> new file mode 100644
> index 00000000..9262fe6a
> --- /dev/null
> +++ b/meta-ti-bsp/recipes-bsp/gc320-drivers/files/0001-km-Fix-stdarg-header-file-compilation-issues.patch
> @@ -0,0 +1,43 @@
> +From 466a0f62d4ca9fd8eeea3fc060f4f1a9584f4af5 Mon Sep 17 00:00:00 2001
> +From: Sinthu Raja <sinthu.raja@ti.com>
> +Date: Tue, 14 Nov 2023 12:45:29 +0530
> +Subject: [PATCH 1/2] km: Fix stdarg header file compilation issues
> +
> +The location of the stdarg.h is changed to linux/stdarg.h. Fix the same
> +by updating the stdarg header location.
> +
> +Signed-off-by: Sinthu Raja <sinthu.raja@ti.com>
> +---
> + hal/os/linux/kernel/gc_hal_kernel_debug.h   | 2 +-
> + hal/os/linux/kernel/gc_hal_kernel_debugfs.h | 2 +-
> + 2 files changed, 2 insertions(+), 2 deletions(-)
> +
> +diff --git a/hal/os/linux/kernel/gc_hal_kernel_debug.h b/hal/os/linux/kernel/gc_hal_kernel_debug.h
> +index 54782fd..cac5528 100755
> +--- a/hal/os/linux/kernel/gc_hal_kernel_debug.h
> ++++ b/hal/os/linux/kernel/gc_hal_kernel_debug.h
> +@@ -59,7 +59,7 @@
> + #include <gc_hal_kernel_linux.h>
> + #include <linux/spinlock.h>
> + #include <linux/time.h>
> +-#include <stdarg.h>
> ++#include <linux/stdarg.h>
> +
> + #ifdef __cplusplus
> + extern "C" {
> +diff --git a/hal/os/linux/kernel/gc_hal_kernel_debugfs.h b/hal/os/linux/kernel/gc_hal_kernel_debugfs.h
> +index 9a15d77..a960272 100755
> +--- a/hal/os/linux/kernel/gc_hal_kernel_debugfs.h
> ++++ b/hal/os/linux/kernel/gc_hal_kernel_debugfs.h
> +@@ -53,7 +53,7 @@
> + *****************************************************************************/
> +
> +
> +-#include <stdarg.h>
> ++#include <linux/stdarg.h>
> +
> + #ifndef __gc_hal_kernel_debugfs_h_
> + #define __gc_hal_kernel_debugfs_h_
> +--
> +2.36.1
> +
> diff --git a/meta-ti-bsp/recipes-bsp/gc320-drivers/files/0002-km-import-DMA_BUF-namespace-to-load-the-dma_buf-modu.patch b/meta-ti-bsp/recipes-bsp/gc320-drivers/files/0002-km-import-DMA_BUF-namespace-to-load-the-dma_buf-modu.patch
> new file mode 100644
> index 00000000..f95599ef
> --- /dev/null
> +++ b/meta-ti-bsp/recipes-bsp/gc320-drivers/files/0002-km-import-DMA_BUF-namespace-to-load-the-dma_buf-modu.patch
> @@ -0,0 +1,28 @@
> +From e7d20324dcfed1b57e09d9e1498fad666e91665e Mon Sep 17 00:00:00 2001
> +From: Sinthu Raja <sinthu.raja@ti.com>
> +Date: Tue, 14 Nov 2023 12:53:00 +0530
> +Subject: [PATCH 2/2] km: import DMA_BUF namespace to load the dma_buf modules
> +
> +The DMA BUF module is added to the namespace. To load the graphics
> +driver with dma_buf module import the DAM_BUF namespace
> +
> +Signed-off-by: Sinthu Raja <sinthu.raja@ti.com>
> +---
> + hal/os/linux/kernel/gc_hal_kernel_probe.c | 1 +
> + 1 file changed, 1 insertion(+)
> +
> +diff --git a/hal/os/linux/kernel/gc_hal_kernel_probe.c b/hal/os/linux/kernel/gc_hal_kernel_probe.c
> +index 877b5a2..430c67e 100755
> +--- a/hal/os/linux/kernel/gc_hal_kernel_probe.c
> ++++ b/hal/os/linux/kernel/gc_hal_kernel_probe.c
> +@@ -73,6 +73,7 @@
> + #define _GC_OBJ_ZONE    gcvZONE_DRIVER
> +
> + MODULE_DESCRIPTION("Vivante Graphics Driver");
> ++MODULE_IMPORT_NS(DMA_BUF);
> + MODULE_LICENSE("GPL");
> +
> + static struct class* gpuClass;
> +--
> +2.36.1
> +
> diff --git a/meta-ti-bsp/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb b/meta-ti-bsp/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb
> index a56810d4..e38d9f49 100644
> --- a/meta-ti-bsp/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb
> +++ b/meta-ti-bsp/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb
> @@ -15,7 +15,9 @@ BRANCH = "ti-${PV}-k5.10"
>   
>   SRCREV = "e2a10f31e255a65ec30a6e10b890e77d7e9cb107"
>   
> -SRC_URI = "git://git.ti.com/git/graphics/ti-gc320-driver.git;protocol=https;branch=${BRANCH}"
> +SRC_URI = "git://git.ti.com/git/graphics/ti-gc320-driver.git;protocol=https;branch=${BRANCH} \
> +	   file://0001-km-Fix-stdarg-header-file-compilation-issues.patch \
> +	   file://0002-km-import-DMA_BUF-namespace-to-load-the-dma_buf-modu.patch"
>   
>   S = "${WORKDIR}/git/src"
>   
> 
> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#17299): https://lists.yoctoproject.org/g/meta-ti/message/17299
> Mute This Topic: https://lists.yoctoproject.org/mt/102602692/2167429
> Group Owner: meta-ti+owner@lists.yoctoproject.org
> Unsubscribe: https://lists.yoctoproject.org/g/meta-ti/unsub [praneeth@ti.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Ryan Eatmon Nov. 15, 2023, 6:53 p.m. UTC | #2
On 11/15/2023 11:39 AM, Bajjuri, Praneeth wrote:
> updating denys email id
> 
> On 11/15/2023 4:58 AM, Sinthu Raja M via lists.yoctoproject.org wrote:
>> From: Sinthu Raja <sinthu.raja@ti.com>
>>
>> The stdarg header file location is changed to linux/stdarg.h. Add patch
>> to fix the compilation issue and also add fix to import DMA_BUF namspace
>> to load the dma_buf modules
>>
>> Signed-off-by: Sinthu Raja <sinthu.raja@ti.com>
>> ---
>>   ...tdarg-header-file-compilation-issues.patch | 43 +++++++++++++++++++
>>   ...F-namespace-to-load-the-dma_buf-modu.patch | 28 ++++++++++++
>>   .../ti-gc320-driver_5.0.11.p7.bb              |  4 +-
> 
> Why not patch it at
> https://git.ti.com/cgit/graphics/ti-gc320-driver/
> 
> and have a branch ti-5.0.11.p7-k6.1 ?
> 
> and only do SRCREV update and rename the bb recipe?


Agreed.  This is the better way of doing it.  We do not want to carry 
any more patches in meta-ti that are not yocto build requirements 
specific.  This patch should go into the upstream repo on a new branch 
like Praneeth said.


> 
>>   3 files changed, 74 insertions(+), 1 deletion(-)
>>   create mode 100644 
>> meta-ti-bsp/recipes-bsp/gc320-drivers/files/0001-km-Fix-stdarg-header-file-compilation-issues.patch
>>   create mode 100644 
>> meta-ti-bsp/recipes-bsp/gc320-drivers/files/0002-km-import-DMA_BUF-namespace-to-load-the-dma_buf-modu.patch
>>
>> diff --git 
>> a/meta-ti-bsp/recipes-bsp/gc320-drivers/files/0001-km-Fix-stdarg-header-file-compilation-issues.patch b/meta-ti-bsp/recipes-bsp/gc320-drivers/files/0001-km-Fix-stdarg-header-file-compilation-issues.patch
>> new file mode 100644
>> index 00000000..9262fe6a
>> --- /dev/null
>> +++ 
>> b/meta-ti-bsp/recipes-bsp/gc320-drivers/files/0001-km-Fix-stdarg-header-file-compilation-issues.patch
>> @@ -0,0 +1,43 @@
>> +From 466a0f62d4ca9fd8eeea3fc060f4f1a9584f4af5 Mon Sep 17 00:00:00 2001
>> +From: Sinthu Raja <sinthu.raja@ti.com>
>> +Date: Tue, 14 Nov 2023 12:45:29 +0530
>> +Subject: [PATCH 1/2] km: Fix stdarg header file compilation issues
>> +
>> +The location of the stdarg.h is changed to linux/stdarg.h. Fix the same
>> +by updating the stdarg header location.
>> +
>> +Signed-off-by: Sinthu Raja <sinthu.raja@ti.com>
>> +---
>> + hal/os/linux/kernel/gc_hal_kernel_debug.h   | 2 +-
>> + hal/os/linux/kernel/gc_hal_kernel_debugfs.h | 2 +-
>> + 2 files changed, 2 insertions(+), 2 deletions(-)
>> +
>> +diff --git a/hal/os/linux/kernel/gc_hal_kernel_debug.h 
>> b/hal/os/linux/kernel/gc_hal_kernel_debug.h
>> +index 54782fd..cac5528 100755
>> +--- a/hal/os/linux/kernel/gc_hal_kernel_debug.h
>> ++++ b/hal/os/linux/kernel/gc_hal_kernel_debug.h
>> +@@ -59,7 +59,7 @@
>> + #include <gc_hal_kernel_linux.h>
>> + #include <linux/spinlock.h>
>> + #include <linux/time.h>
>> +-#include <stdarg.h>
>> ++#include <linux/stdarg.h>
>> +
>> + #ifdef __cplusplus
>> + extern "C" {
>> +diff --git a/hal/os/linux/kernel/gc_hal_kernel_debugfs.h 
>> b/hal/os/linux/kernel/gc_hal_kernel_debugfs.h
>> +index 9a15d77..a960272 100755
>> +--- a/hal/os/linux/kernel/gc_hal_kernel_debugfs.h
>> ++++ b/hal/os/linux/kernel/gc_hal_kernel_debugfs.h
>> +@@ -53,7 +53,7 @@
>> + 
>> *****************************************************************************/
>> +
>> +
>> +-#include <stdarg.h>
>> ++#include <linux/stdarg.h>
>> +
>> + #ifndef __gc_hal_kernel_debugfs_h_
>> + #define __gc_hal_kernel_debugfs_h_
>> +--
>> +2.36.1
>> +
>> diff --git 
>> a/meta-ti-bsp/recipes-bsp/gc320-drivers/files/0002-km-import-DMA_BUF-namespace-to-load-the-dma_buf-modu.patch b/meta-ti-bsp/recipes-bsp/gc320-drivers/files/0002-km-import-DMA_BUF-namespace-to-load-the-dma_buf-modu.patch
>> new file mode 100644
>> index 00000000..f95599ef
>> --- /dev/null
>> +++ 
>> b/meta-ti-bsp/recipes-bsp/gc320-drivers/files/0002-km-import-DMA_BUF-namespace-to-load-the-dma_buf-modu.patch
>> @@ -0,0 +1,28 @@
>> +From e7d20324dcfed1b57e09d9e1498fad666e91665e Mon Sep 17 00:00:00 2001
>> +From: Sinthu Raja <sinthu.raja@ti.com>
>> +Date: Tue, 14 Nov 2023 12:53:00 +0530
>> +Subject: [PATCH 2/2] km: import DMA_BUF namespace to load the dma_buf 
>> modules
>> +
>> +The DMA BUF module is added to the namespace. To load the graphics
>> +driver with dma_buf module import the DAM_BUF namespace
>> +
>> +Signed-off-by: Sinthu Raja <sinthu.raja@ti.com>
>> +---
>> + hal/os/linux/kernel/gc_hal_kernel_probe.c | 1 +
>> + 1 file changed, 1 insertion(+)
>> +
>> +diff --git a/hal/os/linux/kernel/gc_hal_kernel_probe.c 
>> b/hal/os/linux/kernel/gc_hal_kernel_probe.c
>> +index 877b5a2..430c67e 100755
>> +--- a/hal/os/linux/kernel/gc_hal_kernel_probe.c
>> ++++ b/hal/os/linux/kernel/gc_hal_kernel_probe.c
>> +@@ -73,6 +73,7 @@
>> + #define _GC_OBJ_ZONE    gcvZONE_DRIVER
>> +
>> + MODULE_DESCRIPTION("Vivante Graphics Driver");
>> ++MODULE_IMPORT_NS(DMA_BUF);
>> + MODULE_LICENSE("GPL");
>> +
>> + static struct class* gpuClass;
>> +--
>> +2.36.1
>> +
>> diff --git 
>> a/meta-ti-bsp/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb 
>> b/meta-ti-bsp/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb
>> index a56810d4..e38d9f49 100644
>> --- a/meta-ti-bsp/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb
>> +++ b/meta-ti-bsp/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb
>> @@ -15,7 +15,9 @@ BRANCH = "ti-${PV}-k5.10"
>>   SRCREV = "e2a10f31e255a65ec30a6e10b890e77d7e9cb107"
>> -SRC_URI = 
>> "git://git.ti.com/git/graphics/ti-gc320-driver.git;protocol=https;branch=${BRANCH}"
>> +SRC_URI = 
>> "git://git.ti.com/git/graphics/ti-gc320-driver.git;protocol=https;branch=${BRANCH} \
>> +       file://0001-km-Fix-stdarg-header-file-compilation-issues.patch \
>> +       
>> file://0002-km-import-DMA_BUF-namespace-to-load-the-dma_buf-modu.patch"
>>   S = "${WORKDIR}/git/src"
>>
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#17299): 
>> https://lists.yoctoproject.org/g/meta-ti/message/17299
>> Mute This Topic: https://lists.yoctoproject.org/mt/102602692/2167429
>> Group Owner: meta-ti+owner@lists.yoctoproject.org
>> Unsubscribe: https://lists.yoctoproject.org/g/meta-ti/unsub 
>> [praneeth@ti.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
Sinthu Raja M Nov. 16, 2023, 5:12 a.m. UTC | #3
On Thu, Nov 16, 2023 at 12:23 AM Ryan Eatmon <reatmon@ti.com> wrote:
>
>
>
> On 11/15/2023 11:39 AM, Bajjuri, Praneeth wrote:
> > updating denys email id
> >
> > On 11/15/2023 4:58 AM, Sinthu Raja M via lists.yoctoproject.org wrote:
> >> From: Sinthu Raja <sinthu.raja@ti.com>
> >>
> >> The stdarg header file location is changed to linux/stdarg.h. Add patch
> >> to fix the compilation issue and also add fix to import DMA_BUF namspace
> >> to load the dma_buf modules
> >>
> >> Signed-off-by: Sinthu Raja <sinthu.raja@ti.com>
> >> ---
> >>   ...tdarg-header-file-compilation-issues.patch | 43 +++++++++++++++++++
> >>   ...F-namespace-to-load-the-dma_buf-modu.patch | 28 ++++++++++++
> >>   .../ti-gc320-driver_5.0.11.p7.bb              |  4 +-
> >
> > Why not patch it at
> > https://git.ti.com/cgit/graphics/ti-gc320-driver/
> >
> > and have a branch ti-5.0.11.p7-k6.1 ?
> >
> > and only do SRCREV update and rename the bb recipe?
>
>
> Agreed.  This is the better way of doing it.  We do not want to carry
> any more patches in meta-ti that are not yocto build requirements
> specific.  This patch should go into the upstream repo on a new branch
> like Praneeth said.

Agreed, will make the changes as suggested.
>
>
> >
> >>   3 files changed, 74 insertions(+), 1 deletion(-)
> >>   create mode 100644
> >> meta-ti-bsp/recipes-bsp/gc320-drivers/files/0001-km-Fix-stdarg-header-file-compilation-issues.patch
> >>   create mode 100644
> >> meta-ti-bsp/recipes-bsp/gc320-drivers/files/0002-km-import-DMA_BUF-namespace-to-load-the-dma_buf-modu.patch
> >>
> >> diff --git
> >> a/meta-ti-bsp/recipes-bsp/gc320-drivers/files/0001-km-Fix-stdarg-header-file-compilation-issues.patch b/meta-ti-bsp/recipes-bsp/gc320-drivers/files/0001-km-Fix-stdarg-header-file-compilation-issues.patch
> >> new file mode 100644
> >> index 00000000..9262fe6a
> >> --- /dev/null
> >> +++
> >> b/meta-ti-bsp/recipes-bsp/gc320-drivers/files/0001-km-Fix-stdarg-header-file-compilation-issues.patch
> >> @@ -0,0 +1,43 @@
> >> +From 466a0f62d4ca9fd8eeea3fc060f4f1a9584f4af5 Mon Sep 17 00:00:00 2001
> >> +From: Sinthu Raja <sinthu.raja@ti.com>
> >> +Date: Tue, 14 Nov 2023 12:45:29 +0530
> >> +Subject: [PATCH 1/2] km: Fix stdarg header file compilation issues
> >> +
> >> +The location of the stdarg.h is changed to linux/stdarg.h. Fix the same
> >> +by updating the stdarg header location.
> >> +
> >> +Signed-off-by: Sinthu Raja <sinthu.raja@ti.com>
> >> +---
> >> + hal/os/linux/kernel/gc_hal_kernel_debug.h   | 2 +-
> >> + hal/os/linux/kernel/gc_hal_kernel_debugfs.h | 2 +-
> >> + 2 files changed, 2 insertions(+), 2 deletions(-)
> >> +
> >> +diff --git a/hal/os/linux/kernel/gc_hal_kernel_debug.h
> >> b/hal/os/linux/kernel/gc_hal_kernel_debug.h
> >> +index 54782fd..cac5528 100755
> >> +--- a/hal/os/linux/kernel/gc_hal_kernel_debug.h
> >> ++++ b/hal/os/linux/kernel/gc_hal_kernel_debug.h
> >> +@@ -59,7 +59,7 @@
> >> + #include <gc_hal_kernel_linux.h>
> >> + #include <linux/spinlock.h>
> >> + #include <linux/time.h>
> >> +-#include <stdarg.h>
> >> ++#include <linux/stdarg.h>
> >> +
> >> + #ifdef __cplusplus
> >> + extern "C" {
> >> +diff --git a/hal/os/linux/kernel/gc_hal_kernel_debugfs.h
> >> b/hal/os/linux/kernel/gc_hal_kernel_debugfs.h
> >> +index 9a15d77..a960272 100755
> >> +--- a/hal/os/linux/kernel/gc_hal_kernel_debugfs.h
> >> ++++ b/hal/os/linux/kernel/gc_hal_kernel_debugfs.h
> >> +@@ -53,7 +53,7 @@
> >> +
> >> *****************************************************************************/
> >> +
> >> +
> >> +-#include <stdarg.h>
> >> ++#include <linux/stdarg.h>
> >> +
> >> + #ifndef __gc_hal_kernel_debugfs_h_
> >> + #define __gc_hal_kernel_debugfs_h_
> >> +--
> >> +2.36.1
> >> +
> >> diff --git
> >> a/meta-ti-bsp/recipes-bsp/gc320-drivers/files/0002-km-import-DMA_BUF-namespace-to-load-the-dma_buf-modu.patch b/meta-ti-bsp/recipes-bsp/gc320-drivers/files/0002-km-import-DMA_BUF-namespace-to-load-the-dma_buf-modu.patch
> >> new file mode 100644
> >> index 00000000..f95599ef
> >> --- /dev/null
> >> +++
> >> b/meta-ti-bsp/recipes-bsp/gc320-drivers/files/0002-km-import-DMA_BUF-namespace-to-load-the-dma_buf-modu.patch
> >> @@ -0,0 +1,28 @@
> >> +From e7d20324dcfed1b57e09d9e1498fad666e91665e Mon Sep 17 00:00:00 2001
> >> +From: Sinthu Raja <sinthu.raja@ti.com>
> >> +Date: Tue, 14 Nov 2023 12:53:00 +0530
> >> +Subject: [PATCH 2/2] km: import DMA_BUF namespace to load the dma_buf
> >> modules
> >> +
> >> +The DMA BUF module is added to the namespace. To load the graphics
> >> +driver with dma_buf module import the DAM_BUF namespace
> >> +
> >> +Signed-off-by: Sinthu Raja <sinthu.raja@ti.com>
> >> +---
> >> + hal/os/linux/kernel/gc_hal_kernel_probe.c | 1 +
> >> + 1 file changed, 1 insertion(+)
> >> +
> >> +diff --git a/hal/os/linux/kernel/gc_hal_kernel_probe.c
> >> b/hal/os/linux/kernel/gc_hal_kernel_probe.c
> >> +index 877b5a2..430c67e 100755
> >> +--- a/hal/os/linux/kernel/gc_hal_kernel_probe.c
> >> ++++ b/hal/os/linux/kernel/gc_hal_kernel_probe.c
> >> +@@ -73,6 +73,7 @@
> >> + #define _GC_OBJ_ZONE    gcvZONE_DRIVER
> >> +
> >> + MODULE_DESCRIPTION("Vivante Graphics Driver");
> >> ++MODULE_IMPORT_NS(DMA_BUF);
> >> + MODULE_LICENSE("GPL");
> >> +
> >> + static struct class* gpuClass;
> >> +--
> >> +2.36.1
> >> +
> >> diff --git
> >> a/meta-ti-bsp/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb
> >> b/meta-ti-bsp/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb
> >> index a56810d4..e38d9f49 100644
> >> --- a/meta-ti-bsp/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb
> >> +++ b/meta-ti-bsp/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb
> >> @@ -15,7 +15,9 @@ BRANCH = "ti-${PV}-k5.10"
> >>   SRCREV = "e2a10f31e255a65ec30a6e10b890e77d7e9cb107"
> >> -SRC_URI =
> >> "git://git.ti.com/git/graphics/ti-gc320-driver.git;protocol=https;branch=${BRANCH}"
> >> +SRC_URI =
> >> "git://git.ti.com/git/graphics/ti-gc320-driver.git;protocol=https;branch=${BRANCH} \
> >> +       file://0001-km-Fix-stdarg-header-file-compilation-issues.patch \
> >> +
> >> file://0002-km-import-DMA_BUF-namespace-to-load-the-dma_buf-modu.patch"
> >>   S = "${WORKDIR}/git/src"
> >>
> >>
> >>
> >> -=-=-=-=-=-=-=-=-=-=-=-
> >> Links: You receive all messages sent to this group.
> >> View/Reply Online (#17299):
> >> https://lists.yoctoproject.org/g/meta-ti/message/17299
> >> Mute This Topic: https://lists.yoctoproject.org/mt/102602692/2167429
> >> Group Owner: meta-ti+owner@lists.yoctoproject.org
> >> Unsubscribe: https://lists.yoctoproject.org/g/meta-ti/unsub
> >> [praneeth@ti.com]
> >> -=-=-=-=-=-=-=-=-=-=-=-
> >>
>
> --
> Ryan Eatmon                reatmon@ti.com
> -----------------------------------------
> Texas Instruments, Inc.  -  LCPD  -  MGTS
diff mbox series

Patch

diff --git a/meta-ti-bsp/recipes-bsp/gc320-drivers/files/0001-km-Fix-stdarg-header-file-compilation-issues.patch b/meta-ti-bsp/recipes-bsp/gc320-drivers/files/0001-km-Fix-stdarg-header-file-compilation-issues.patch
new file mode 100644
index 00000000..9262fe6a
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/gc320-drivers/files/0001-km-Fix-stdarg-header-file-compilation-issues.patch
@@ -0,0 +1,43 @@ 
+From 466a0f62d4ca9fd8eeea3fc060f4f1a9584f4af5 Mon Sep 17 00:00:00 2001
+From: Sinthu Raja <sinthu.raja@ti.com>
+Date: Tue, 14 Nov 2023 12:45:29 +0530
+Subject: [PATCH 1/2] km: Fix stdarg header file compilation issues
+
+The location of the stdarg.h is changed to linux/stdarg.h. Fix the same
+by updating the stdarg header location.
+
+Signed-off-by: Sinthu Raja <sinthu.raja@ti.com>
+---
+ hal/os/linux/kernel/gc_hal_kernel_debug.h   | 2 +-
+ hal/os/linux/kernel/gc_hal_kernel_debugfs.h | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/hal/os/linux/kernel/gc_hal_kernel_debug.h b/hal/os/linux/kernel/gc_hal_kernel_debug.h
+index 54782fd..cac5528 100755
+--- a/hal/os/linux/kernel/gc_hal_kernel_debug.h
++++ b/hal/os/linux/kernel/gc_hal_kernel_debug.h
+@@ -59,7 +59,7 @@
+ #include <gc_hal_kernel_linux.h>
+ #include <linux/spinlock.h>
+ #include <linux/time.h>
+-#include <stdarg.h>
++#include <linux/stdarg.h>
+ 
+ #ifdef __cplusplus
+ extern "C" {
+diff --git a/hal/os/linux/kernel/gc_hal_kernel_debugfs.h b/hal/os/linux/kernel/gc_hal_kernel_debugfs.h
+index 9a15d77..a960272 100755
+--- a/hal/os/linux/kernel/gc_hal_kernel_debugfs.h
++++ b/hal/os/linux/kernel/gc_hal_kernel_debugfs.h
+@@ -53,7 +53,7 @@
+ *****************************************************************************/
+ 
+ 
+-#include <stdarg.h>
++#include <linux/stdarg.h>
+ 
+ #ifndef __gc_hal_kernel_debugfs_h_
+ #define __gc_hal_kernel_debugfs_h_
+-- 
+2.36.1
+
diff --git a/meta-ti-bsp/recipes-bsp/gc320-drivers/files/0002-km-import-DMA_BUF-namespace-to-load-the-dma_buf-modu.patch b/meta-ti-bsp/recipes-bsp/gc320-drivers/files/0002-km-import-DMA_BUF-namespace-to-load-the-dma_buf-modu.patch
new file mode 100644
index 00000000..f95599ef
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/gc320-drivers/files/0002-km-import-DMA_BUF-namespace-to-load-the-dma_buf-modu.patch
@@ -0,0 +1,28 @@ 
+From e7d20324dcfed1b57e09d9e1498fad666e91665e Mon Sep 17 00:00:00 2001
+From: Sinthu Raja <sinthu.raja@ti.com>
+Date: Tue, 14 Nov 2023 12:53:00 +0530
+Subject: [PATCH 2/2] km: import DMA_BUF namespace to load the dma_buf modules
+
+The DMA BUF module is added to the namespace. To load the graphics
+driver with dma_buf module import the DAM_BUF namespace
+
+Signed-off-by: Sinthu Raja <sinthu.raja@ti.com>
+---
+ hal/os/linux/kernel/gc_hal_kernel_probe.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/hal/os/linux/kernel/gc_hal_kernel_probe.c b/hal/os/linux/kernel/gc_hal_kernel_probe.c
+index 877b5a2..430c67e 100755
+--- a/hal/os/linux/kernel/gc_hal_kernel_probe.c
++++ b/hal/os/linux/kernel/gc_hal_kernel_probe.c
+@@ -73,6 +73,7 @@
+ #define _GC_OBJ_ZONE    gcvZONE_DRIVER
+ 
+ MODULE_DESCRIPTION("Vivante Graphics Driver");
++MODULE_IMPORT_NS(DMA_BUF);
+ MODULE_LICENSE("GPL");
+ 
+ static struct class* gpuClass;
+-- 
+2.36.1
+
diff --git a/meta-ti-bsp/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb b/meta-ti-bsp/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb
index a56810d4..e38d9f49 100644
--- a/meta-ti-bsp/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb
+++ b/meta-ti-bsp/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb
@@ -15,7 +15,9 @@  BRANCH = "ti-${PV}-k5.10"
 
 SRCREV = "e2a10f31e255a65ec30a6e10b890e77d7e9cb107"
 
-SRC_URI = "git://git.ti.com/git/graphics/ti-gc320-driver.git;protocol=https;branch=${BRANCH}"
+SRC_URI = "git://git.ti.com/git/graphics/ti-gc320-driver.git;protocol=https;branch=${BRANCH} \
+	   file://0001-km-Fix-stdarg-header-file-compilation-issues.patch \
+	   file://0002-km-import-DMA_BUF-namespace-to-load-the-dma_buf-modu.patch"
 
 S = "${WORKDIR}/git/src"