diff mbox series

gawk: upgrade 5.2.2 -> 5.3.0

Message ID 1700035829-1053-1-git-send-email-wangmy@fujitsu.com
State New
Headers show
Series gawk: upgrade 5.2.2 -> 5.3.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Nov. 15, 2023, 8:10 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
===========
1. Infrastructure changes: Removed the use of libsigsegv. The
   value-add was never very much and it caused problems in some
   environments.
2. In keeping with new features in BWK awk, gawk now has built-in
   CSV file parsing. The behavior is intended to be identical to
   that of the "One True AWK" when --csv is applied. See the
   manual for details.
3. Also in keeping with BWK awk, gawk now supports a new \u escape
   sequence. This should be followed by 1-8 hexadecimal digits. The
   given code point is converted to its corresponding multibyte encoding
   for storage inside gawk. See the manual.
4. If PROCINFO["BUFFERPIPE"] exists, then pipe output is buffered.
   You can also use PROCINFO["command", "BUFFERPIPE"]. See the manual
   for details.
5. Because of the additional `do_csv' variable in the API, which breaks
   binary compatibility, the API major version was updated to 4 and
   the minor version was reset to zero.  The API remains source code
   compatible; that is, existing extensions should only require recompilation.
6. The manual now requires Texinfo 7.1 and its texinfo.tex for formatting.
   As a result, we no longer need to pre-process it, removing the need
   for gawktexi.in and leaving just gawk.texi.
7. And of course, there have been several minor code cleanups and bug fixes.
   See the ChangeLog for details.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 meta/recipes-extended/gawk/{gawk_5.2.2.bb => gawk_5.3.0.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta/recipes-extended/gawk/{gawk_5.2.2.bb => gawk_5.3.0.bb} (97%)

Comments

Alexandre Belloni Nov. 16, 2023, 4:06 p.m. UTC | #1
New ptest failure:

https://autobuilder.yoctoproject.org/typhoon/#/builders/82/builds/5720/steps/13/logs/stdio
https://autobuilder.yoctoproject.org/typhoon/#/builders/81/builds/5902/steps/13/logs/stdio

od: invalid option -- 'A'
BusyBox v1.36.1 () multi-call binary.

Usage: od [-aBbcDdeFfHhIiLlOovXx] [FILE]
od: invalid option -- 'A'
BusyBox v1.36.1 () multi-call binary.

Usage: od [-aBbcDdeFfHhIiLlOovXx] [FILE]
od: invalid option -- 'A'
BusyBox v1.36.1 () multi-call binary.

Usage: od [-aBbcDdeFfHhIiLlOovXx] [FILE]
od: invalid option -- 'A'
BusyBox v1.36.1 () multi-call binary.

Usage: od [-aBbcDdeFfHhIiLlOovXx] [FILE]
od: invalid option -- 'A'
BusyBox v1.36.1 () multi-call binary.

Usage: od [-aBbcDdeFfHhIiLlOovXx] [FILE]
od: invalid option -- 'A'
BusyBox v1.36.1 () multi-call binary.

Usage: od [-aBbcDdeFfHhIiLlOovXx] [FILE]
od: invalid option -- 'A'
BusyBox v1.36.1 () multi-call binary.

Usage: od [-aBbcDdeFfHhIiLlOovXx] [FILE]
gawk: cmd. line:2: warning: invalid `\u' escape sequence
gawk: cmd. line:3: warning: invalid `\u' escape sequence
gawk: cmd. line:2: warning: invalid `\u' escape sequence
right: literal ? is literal
gawk: cmd. line:2: warning: invalid `\u' escape sequence
gawk: cmd. line:5: warning: invalid `\u' escape sequence
gawk: cmd. line:8: warning: invalid `\u' escape sequence
1 == 1
gawk: cmd. line:3: warning: invalid `\u' escape sequence
1 == 1
0 == 0
gawk: cmd. line:6: warning: invalid `\u' escape sequence
0 == 0
0 == 0
gawk: cmd. line:9: warning: invalid `\u' escape sequence
0 == 0
FAIL: cmdlinefsbacknl2


On 15/11/2023 16:10:29+0800, wangmy wrote:
> From: Wang Mingyu <wangmy@fujitsu.com>
> 
> Changelog:
> ===========
> 1. Infrastructure changes: Removed the use of libsigsegv. The
>    value-add was never very much and it caused problems in some
>    environments.
> 2. In keeping with new features in BWK awk, gawk now has built-in
>    CSV file parsing. The behavior is intended to be identical to
>    that of the "One True AWK" when --csv is applied. See the
>    manual for details.
> 3. Also in keeping with BWK awk, gawk now supports a new \u escape
>    sequence. This should be followed by 1-8 hexadecimal digits. The
>    given code point is converted to its corresponding multibyte encoding
>    for storage inside gawk. See the manual.
> 4. If PROCINFO["BUFFERPIPE"] exists, then pipe output is buffered.
>    You can also use PROCINFO["command", "BUFFERPIPE"]. See the manual
>    for details.
> 5. Because of the additional `do_csv' variable in the API, which breaks
>    binary compatibility, the API major version was updated to 4 and
>    the minor version was reset to zero.  The API remains source code
>    compatible; that is, existing extensions should only require recompilation.
> 6. The manual now requires Texinfo 7.1 and its texinfo.tex for formatting.
>    As a result, we no longer need to pre-process it, removing the need
>    for gawktexi.in and leaving just gawk.texi.
> 7. And of course, there have been several minor code cleanups and bug fixes.
>    See the ChangeLog for details.
> 
> Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
> ---
>  meta/recipes-extended/gawk/{gawk_5.2.2.bb => gawk_5.3.0.bb} | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>  rename meta/recipes-extended/gawk/{gawk_5.2.2.bb => gawk_5.3.0.bb} (97%)
> 
> diff --git a/meta/recipes-extended/gawk/gawk_5.2.2.bb b/meta/recipes-extended/gawk/gawk_5.3.0.bb
> similarity index 97%
> rename from meta/recipes-extended/gawk/gawk_5.2.2.bb
> rename to meta/recipes-extended/gawk/gawk_5.3.0.bb
> index 3c18b6911a..3d652da6e5 100644
> --- a/meta/recipes-extended/gawk/gawk_5.2.2.bb
> +++ b/meta/recipes-extended/gawk/gawk_5.3.0.bb
> @@ -19,7 +19,7 @@ SRC_URI = "${GNU_MIRROR}/gawk/gawk-${PV}.tar.gz \
>             file://run-ptest \
>             "
>  
> -SRC_URI[sha256sum] = "945aef7ccff101f20b22a10802bc005e994ab2b8ea3e724cc1a197c62f41f650"
> +SRC_URI[sha256sum] = "378f8864ec21cfceaa048f7e1869ac9b4597b449087caf1eb55e440d30273336"
>  
>  inherit autotools gettext texinfo update-alternatives
>  
> -- 
> 2.34.1
> 

> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#190561): https://lists.openembedded.org/g/openembedded-core/message/190561
> Mute This Topic: https://lists.openembedded.org/mt/102601410/3617179
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-extended/gawk/gawk_5.2.2.bb b/meta/recipes-extended/gawk/gawk_5.3.0.bb
similarity index 97%
rename from meta/recipes-extended/gawk/gawk_5.2.2.bb
rename to meta/recipes-extended/gawk/gawk_5.3.0.bb
index 3c18b6911a..3d652da6e5 100644
--- a/meta/recipes-extended/gawk/gawk_5.2.2.bb
+++ b/meta/recipes-extended/gawk/gawk_5.3.0.bb
@@ -19,7 +19,7 @@  SRC_URI = "${GNU_MIRROR}/gawk/gawk-${PV}.tar.gz \
            file://run-ptest \
            "
 
-SRC_URI[sha256sum] = "945aef7ccff101f20b22a10802bc005e994ab2b8ea3e724cc1a197c62f41f650"
+SRC_URI[sha256sum] = "378f8864ec21cfceaa048f7e1869ac9b4597b449087caf1eb55e440d30273336"
 
 inherit autotools gettext texinfo update-alternatives