diff mbox series

[meta-oe] cups-filters: Try to fix possible Makefile race condition

Message ID 20231114234246.326099-1-f_l_k@t-online.de
State New
Headers show
Series [meta-oe] cups-filters: Try to fix possible Makefile race condition | expand

Commit Message

Markus Volk Nov. 14, 2023, 11:42 p.m. UTC
Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 meta-oe/recipes-printing/cups/cups-filters_2.0.0.bb | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Khem Raj Nov. 14, 2023, 11:59 p.m. UTC | #1
On Tue, Nov 14, 2023 at 3:42 PM Markus Volk <f_l_k@t-online.de> wrote:
>
> Signed-off-by: Markus Volk <f_l_k@t-online.de>
> ---
>  meta-oe/recipes-printing/cups/cups-filters_2.0.0.bb | 4 ++++
>  1 file changed, 4 insertions(+)
>
> diff --git a/meta-oe/recipes-printing/cups/cups-filters_2.0.0.bb b/meta-oe/recipes-printing/cups/cups-filters_2.0.0.bb
> index 0370ae79d..4dfb5f612 100644
> --- a/meta-oe/recipes-printing/cups/cups-filters_2.0.0.bb
> +++ b/meta-oe/recipes-printing/cups/cups-filters_2.0.0.bb
> @@ -20,6 +20,10 @@ EXTRA_OECONF += " \
>  PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'zeroconf', 'avahi', '', d)}"
>  PACKAGECONFIG[avahi] = "--enable-avahi,--disable-avahi,avahi"
>
> +do_compile() {
> +       oe_runmake -j1

to disable parallelism we should do
PARALLEL_MAKE = ""

However, I was hoping to find the root cause for the problem.

> +}
> +
>  FILES:${PN} += "${datadir}"
>  FILES:${PN}-dev += "${datadir}/ppdc"
>
> --
> 2.42.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#106727): https://lists.openembedded.org/g/openembedded-devel/message/106727
> Mute This Topic: https://lists.openembedded.org/mt/102595472/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-oe/recipes-printing/cups/cups-filters_2.0.0.bb b/meta-oe/recipes-printing/cups/cups-filters_2.0.0.bb
index 0370ae79d..4dfb5f612 100644
--- a/meta-oe/recipes-printing/cups/cups-filters_2.0.0.bb
+++ b/meta-oe/recipes-printing/cups/cups-filters_2.0.0.bb
@@ -20,6 +20,10 @@  EXTRA_OECONF += " \
 PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'zeroconf', 'avahi', '', d)}"
 PACKAGECONFIG[avahi] = "--enable-avahi,--disable-avahi,avahi"
 
+do_compile() {
+	oe_runmake -j1
+}
+
 FILES:${PN} += "${datadir}"
 FILES:${PN}-dev += "${datadir}/ppdc"