diff mbox series

[meta-oe,1/2] ghex: backport patch to fix build for clang

Message ID 20231113011336.2843244-1-f_l_k@t-online.de
State Accepted
Headers show
Series [meta-oe,1/2] ghex: backport patch to fix build for clang | expand

Commit Message

Markus Volk Nov. 13, 2023, 1:13 a.m. UTC
Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 ...iables-in-switch-statement-should-be.patch | 50 +++++++++++++++++++
 meta-gnome/recipes-gnome/ghex/ghex_45.0.bb    |  1 +
 2 files changed, 51 insertions(+)
 create mode 100644 meta-gnome/recipes-gnome/ghex/ghex/0001-gtkhex-Local-variables-in-switch-statement-should-be.patch

Comments

Khem Raj Nov. 13, 2023, 6:34 p.m. UTC | #1
On Mon, 13 Nov 2023 02:13:35 +0100, Markus Volk wrote:
> 


Applied, thanks!

[1/2] ghex: backport patch to fix build for clang
      commit: dba4071b696df1d399f9320fb40eb8b6eeae266c
[2/2] qpdf: cleanup
      commit: f1109887083d97365e3e0c292a76cb0195af269d

Best regards,
diff mbox series

Patch

diff --git a/meta-gnome/recipes-gnome/ghex/ghex/0001-gtkhex-Local-variables-in-switch-statement-should-be.patch b/meta-gnome/recipes-gnome/ghex/ghex/0001-gtkhex-Local-variables-in-switch-statement-should-be.patch
new file mode 100644
index 000000000..61cd3b180
--- /dev/null
+++ b/meta-gnome/recipes-gnome/ghex/ghex/0001-gtkhex-Local-variables-in-switch-statement-should-be.patch
@@ -0,0 +1,50 @@ 
+From b00b8332ab19e41c75ce143f45ab4585502c020b Mon Sep 17 00:00:00 2001
+From: Logan Rathbone <poprocks@gmail.com>
+Date: Tue, 24 Oct 2023 14:06:04 -0400
+Subject: [PATCH] gtkhex: Local variables in switch statement should be in own
+ scope
+
+Fixes: #74
+
+Thanks to: David C. Manuelda
+
+Upstream-Status: Backport [https://gitlab.gnome.org/GNOME/ghex/-/commit/b00b8332ab19e41c75ce143f45ab4585502c020b]
+---
+ src/gtkhex.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/gtkhex.c b/src/gtkhex.c
+index b401cd9..18e0433 100644
+--- a/src/gtkhex.c
++++ b/src/gtkhex.c
+@@ -1941,6 +1941,7 @@ key_press_cb (GtkEventControllerKey *controller,
+ 			break;
+ 
+ 		case GDK_KEY_Home:
++		{
+ 			gint64 line_beg = self->cursor_pos;
+ 
+ 			while (line_beg % self->cpl != 0)
+@@ -1948,9 +1949,11 @@ key_press_cb (GtkEventControllerKey *controller,
+ 
+ 			hex_widget_set_cursor (self, line_beg);
+ 			ret = GDK_EVENT_STOP;
++		}
+ 			break;
+ 
+ 		case GDK_KEY_End:
++		{
+ 			gint64 line_end = self->cursor_pos;
+ 
+ 			while (line_end % self->cpl != self->cpl - 1)
+@@ -1958,6 +1961,7 @@ key_press_cb (GtkEventControllerKey *controller,
+ 
+ 			hex_widget_set_cursor (self, MIN (line_end, payload_size));
+ 			ret = GDK_EVENT_STOP;
++		}
+ 			break;
+ 
+ 		default:
+-- 
+2.42.0
+
diff --git a/meta-gnome/recipes-gnome/ghex/ghex_45.0.bb b/meta-gnome/recipes-gnome/ghex/ghex_45.0.bb
index 6d3e9b978..42c53471b 100644
--- a/meta-gnome/recipes-gnome/ghex/ghex_45.0.bb
+++ b/meta-gnome/recipes-gnome/ghex/ghex_45.0.bb
@@ -15,6 +15,7 @@  GIR_MESON_DISABLE_FLAG = 'disabled'
 
 inherit gnomebase gsettings gtk-icon-cache gnome-help gettext gobject-introspection vala gi-docgen
 
+SRC_URI += "file://0001-gtkhex-Local-variables-in-switch-statement-should-be.patch"
 SRC_URI[archive.sha256sum] = "05cecc4561ca40b257c5db31da9f68d696133efc0ae427ed82fb985a986e840e"
 
 FILES:${PN} += "${libdir} ${datadir}/metainfo"