diff mbox series

[meta-filesystems] unionfs-fuse: upgrade 2.2 --> 3.4

Message ID 20231111111739.13432-1-alperyasinak1@gmail.com
State Under Review
Headers show
Series [meta-filesystems] unionfs-fuse: upgrade 2.2 --> 3.4 | expand

Commit Message

alperak Nov. 11, 2023, 11:17 a.m. UTC
- DEPENDS fuse --> fuse3 because CMake throwing "No package 'fuse3' found" error.

- Updated patch because CMakeLists.txt path has been changed.

- Bash added to RDEPENDS, accordingly this error --> ERROR: unionfs-fuse-3.4-r0 do_package_qa: QA Issue: /usr/sbin/mount.unionfs contained in package unionfs-fuse requires /bin/bash, but no providers found in RDEPENDS:unionfs-fuse? [file-rdeps]

Changelog:

3.4
- default to fuse2 api on macos when compiling

3.3
- fixed fortified compilation
- disabled logging to file since it had some unresolved locking issues
- add support for direct_io

3.2
- various nfs fixes
- various race condition fixes

3.1
- just fixes version mess (in manual file, cmake, etc.)

3.0
- libfuse3 support (and use is as new default)
- add branch-preserving logic
- make it compile under MacOS again
- minor fixes

Signed-off-by: Alper Ak <alperyasinak1@gmail.com>
---
 .../files/0001-support-cross-compiling.patch  | 33 +++++++++----------
 ...nionfs-fuse_2.2.bb => unionfs-fuse_3.4.bb} |  5 +--
 2 files changed, 18 insertions(+), 20 deletions(-)
 rename meta-filesystems/recipes-filesystems/unionfs-fuse/{unionfs-fuse_2.2.bb => unionfs-fuse_3.4.bb} (84%)
diff mbox series

Patch

diff --git a/meta-filesystems/recipes-filesystems/unionfs-fuse/files/0001-support-cross-compiling.patch b/meta-filesystems/recipes-filesystems/unionfs-fuse/files/0001-support-cross-compiling.patch
index bf363ca1b..13e782fa7 100644
--- a/meta-filesystems/recipes-filesystems/unionfs-fuse/files/0001-support-cross-compiling.patch
+++ b/meta-filesystems/recipes-filesystems/unionfs-fuse/files/0001-support-cross-compiling.patch
@@ -1,32 +1,29 @@ 
-From 449cec34c123b86b792627553c6ec7471d2ee7ed Mon Sep 17 00:00:00 2001
-From: Hongxu Jia <hongxu.jia@windriver.com>
-Date: Fri, 30 Jun 2017 14:46:51 +0800
+From 6e794a36564a2639a07d8720260e33d7c9435aa4 Mon Sep 17 00:00:00 2001
+From: Alper Ak <alperyasinak1@gmail.com>
+Date: Fri, 10 Nov 2023 20:50:48 +0300
 Subject: [PATCH] support cross compiling
 
 Do not override OE CMAKE variables
 
-Upstream-Status: Pending
-
 Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+Signed-off-by: Alper Ak <alperyasinak1@gmail.com>
 ---
- CMakeLists.txt | 4 ++--
+ src/CMakeLists.txt | 4 ++--
  1 file changed, 2 insertions(+), 2 deletions(-)
 
-diff --git a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -10,9 +10,9 @@ IF(NOT CMAKE_CONFIGURATION_TYPES AND NOT CMAKE_BUILD_TYPE)
- ENDIF(NOT CMAKE_CONFIGURATION_TYPES AND NOT CMAKE_BUILD_TYPE)
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index f549496..ab71fb2 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -4,9 +4,9 @@ set(UNIONFS_SRCS unionfs.c opts.c debug.c findbranch.c readdir.c
+     fuse_ops.c)
+ set(UNIONFSCTL_SRCS unionfsctl.c)
  
- # Select flags.
--SET(CMAKE_C_FLAGS "-pipe -W -Wall -DFORTIFY_SOURCE=2")
-+SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -pipe -W -Wall -DFORTIFY_SOURCE=2")
+-SET(CMAKE_C_FLAGS "-pipe -W -Wall -D_FORTIFY_SOURCE=2")
++SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -pipe -W -Wall -D_FORTIFY_SOURCE=2")
  SET(CMAKE_C_FLAGS_RELWITHDEBINFO "-O2 -g")
 -SET(CMAKE_C_FLAGS_RELEASE "-O2")
 +SET(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -O2")
  SET(CMAKE_C_FLAGS_DEBUG "-O0 -g -DDEBUG")
  
- if (UNIX AND APPLE)
--- 
-2.8.1
-
+ add_executable(unionfs ${UNIONFS_SRCS} ${HASHTABLE_SRCS})
diff --git a/meta-filesystems/recipes-filesystems/unionfs-fuse/unionfs-fuse_2.2.bb b/meta-filesystems/recipes-filesystems/unionfs-fuse/unionfs-fuse_3.4.bb
similarity index 84%
rename from meta-filesystems/recipes-filesystems/unionfs-fuse/unionfs-fuse_2.2.bb
rename to meta-filesystems/recipes-filesystems/unionfs-fuse/unionfs-fuse_3.4.bb
index 03ae418a4..e8fda0536 100644
--- a/meta-filesystems/recipes-filesystems/unionfs-fuse/unionfs-fuse_2.2.bb
+++ b/meta-filesystems/recipes-filesystems/unionfs-fuse/unionfs-fuse_3.4.bb
@@ -9,9 +9,10 @@  LIC_FILES_CHKSUM = "file://src/unionfs.c;beginline=3;endline=8;md5=30fa8de70fd8a
 SRC_URI = "git://github.com/rpodgorny/${BPN}.git;branch=master;protocol=https \
            file://0001-support-cross-compiling.patch \
            "
-SRCREV = "b0e3805d3d84d44ddf3e4e5238ae0332145d8157"
+SRCREV = "773f1853b043eeb64b7459f903a2c65bd096f9d9"
 
-DEPENDS = "fuse"
+DEPENDS = "fuse3"
+RDEPENDS:${PN} = "bash"
 
 S = "${WORKDIR}/git"