diff mbox series

[meta-oe,PATCHv2] qpdf: Update 10.6.3 -> 11.6.3

Message ID 20231109123748.3161295-1-leon.anavi@konsulko.com
State Under Review
Headers show
Series [meta-oe,PATCHv2] qpdf: Update 10.6.3 -> 11.6.3 | expand

Commit Message

Leon Anavi Nov. 9, 2023, 12:37 p.m. UTC
Update to version 11.6.3:

- Fix a bug in which qpdf could potentially discard a character
  in a binary string if that character was preceded by an octal
  escaped string with fewer than three digits. This bug was
  introduced in the 11.0.0 release. The bug would not apply to
  content streams with default settings.
- The linearization specification precludes linearized files that
  require offets past the 4 GB mark. A bug in qpdf was preventing
  it from working when offsets had to pass the 2 GB mark. This has
  been corrected.

Switch to cmake. Use /dev/random to perform encryption securely.
Change the fully defined path on the target to fix buildpaths
QA issues with libqpdfTargets.cmake. Add openssl and gnutls as
dependencies. Tested with usermerge distro feature and clang.

This work was sponsored by GOVCERT.LU.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../qpdf/{qpdf_10.6.3.bb => qpdf_11.6.3.bb}         | 13 ++++++++++---
 1 file changed, 10 insertions(+), 3 deletions(-)
 rename meta-oe/recipes-printing/qpdf/{qpdf_10.6.3.bb => qpdf_11.6.3.bb} (67%)
diff mbox series

Patch

diff --git a/meta-oe/recipes-printing/qpdf/qpdf_10.6.3.bb b/meta-oe/recipes-printing/qpdf/qpdf_11.6.3.bb
similarity index 67%
rename from meta-oe/recipes-printing/qpdf/qpdf_10.6.3.bb
rename to meta-oe/recipes-printing/qpdf/qpdf_11.6.3.bb
index fa33daf52..b56f8a822 100644
--- a/meta-oe/recipes-printing/qpdf/qpdf_10.6.3.bb
+++ b/meta-oe/recipes-printing/qpdf/qpdf_11.6.3.bb
@@ -2,14 +2,14 @@  DESCRIPTION = "PDF transformation/inspection software"
 HOMEPAGE = "http://qpdf.sourceforge.net"
 LICENSE = "Artistic-2.0"
 SECTION = "libs"
-DEPENDS = "libpcre zlib libjpeg-turbo"
+DEPENDS = "libpcre zlib libjpeg-turbo openssl gnutls"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/qpdf/qpdf-${PV}.tar.gz"
-SRC_URI[sha256sum] = "e8fc23b2a584ea68c963a897515d3eb3129186741dd19d13c86d31fa33493811"
+SRC_URI[sha256sum] = "c394b1b0cff4cd9d13b0f5e16bdf3cf54da424dc434f9d40264b7fe67acd90bc"
 
 LIC_FILES_CHKSUM = "file://Artistic-2.0;md5=7806296b9fae874361e6fb10072b7ee3"
 
-inherit autotools-brokensep gettext
+inherit cmake gettext
 
 # disable random file detection for cross-compile
 EXTRA_OECONF = "--without-random \
@@ -17,11 +17,18 @@  EXTRA_OECONF = "--without-random \
                 --disable-check-autofiles \
                 "
 
+EXTRA_OECMAKE = '-DRANDOM_DEVICE="/dev/random"'
+
 LDFLAGS:append:mipsarch = " -latomic"
 LDFLAGS:append:riscv32 = " -latomic"
 
 S="${WORKDIR}/${BPN}-${PV}"
 
+do_install:append() {
+    # Change the fully defined path on the target
+    sed -i -e 's|${STAGING_LIBDIR}|${libdir}|g' ${D}${libdir}/cmake/${BPN}/libqpdfTargets.cmake
+}
+
 # avoid Makefile returning error on 'make clean' before configure was run
 CLEANBROKEN = "1"