diff mbox series

[meta-oe,1/3] imlib2: Upgrade 1.7.1 -> 1.12.1

Message ID 20231107152239.2219002-1-leon.anavi@konsulko.com
State New
Headers show
Series [meta-oe,1/3] imlib2: Upgrade 1.7.1 -> 1.12.1 | expand

Commit Message

Leon Anavi Nov. 7, 2023, 3:22 p.m. UTC
Upgrade to version 1.12.1:

- Fix some clang complaints
- scaling: MMX asm scaling causes segv, disable for now
- loading: Call module exit function also when not dlclosing
  module on unload
- loaders: Fix build with -m32 --enable-debug
- RAW loader: Don't unload loader
- imlib2_grab, imlib2_view: Unset context colormap
- x11_grab: Use correct depth when grabbing

Remove bzip2 from PACKAGECONFIG because for this version it is an
unrecognised option.

This work was sponsored by GOVCERT.LU.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 meta-oe/recipes-graphics/imlib2/imlib2_git.bb | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/meta-oe/recipes-graphics/imlib2/imlib2_git.bb b/meta-oe/recipes-graphics/imlib2/imlib2_git.bb
index 9b8849b58..ceb14301e 100644
--- a/meta-oe/recipes-graphics/imlib2/imlib2_git.bb
+++ b/meta-oe/recipes-graphics/imlib2/imlib2_git.bb
@@ -7,8 +7,8 @@  LIC_FILES_CHKSUM = "file://COPYING;md5=344895f253c32f38e182dcaf30fe8a35"
 
 DEPENDS = "freetype "
 PROVIDES = "virtual/imlib2"
-PV = "1.7.1"
-SRCREV = "01424487e360383a039dc123bc2a345fe7ea2535"
+PV = "1.12.1"
+SRCREV = "9198db25369f04db069ce61a661c3c47b2622655"
 
 inherit autotools pkgconfig lib_package
 
@@ -28,7 +28,6 @@  PACKAGECONFIG[png] = "--with-png,--without-png,libpng"
 PACKAGECONFIG[tiff] = "--with-tiff,--without-tiff,tiff"
 PACKAGECONFIG[webp] = "--with-webp,--without-webp,libwebp"
 
-PACKAGECONFIG[bzip2] = "--with-bzip2,--without-bzip2,bzip2"
 PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib"
 
 PACKAGECONFIG[id3] = "--with-id3,--without-id3,libid3tag"