diff mbox series

[meta-python,2/4] python3-pdm-backend: add recipe

Message ID 20231107110848.1610779-2-leon.anavi@konsulko.com
State New
Headers show
Series [meta-python,1/4] python3-wand: add recipe | expand

Commit Message

Leon Anavi Nov. 7, 2023, 11:08 a.m. UTC
Add pdm-backend, the build backend used by PDM that supports latest
packaging standards. Version 2.1.7 provides:

- Rename tag-pattern to tag_regex in the docs
- Copytree handle existing dirs
- Normalize the dist info name in the wheel

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../python/python3-pdm-backend_2.1.7.bb             | 13 +++++++++++++
 1 file changed, 13 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-pdm-backend_2.1.7.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pdm-backend_2.1.7.bb b/meta-python/recipes-devtools/python/python3-pdm-backend_2.1.7.bb
new file mode 100644
index 000000000..679ecb0d4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pdm-backend_2.1.7.bb
@@ -0,0 +1,13 @@ 
+SUMMARY = "The build backend used by PDM that supports latest packaging standards"
+HOMEPAGE = "https://github.com/pdm-project/pdm-backend"
+LICENSE = "MIT"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4a564297b3c5b629a528b92fd8ff61ea"
+
+SRC_URI[sha256sum] = "d3b50ab6374557c1edc348135e0da5decef228ddf8c973a58e40f437cf3595ba"
+
+inherit pypi python_setuptools_build_meta
+
+PYPI_PACKAGE= "pdm_backend"
+
+BBCLASSEXTEND = "native nativesdk"