diff mbox series

[v1,1/1] Brotli: fix build failed if the path includes "-static"

Message ID 20231103052919.3649613-1-jamin_lin@aspeedtech.com
State Under Review
Headers show
Series [v1,1/1] Brotli: fix build failed if the path includes "-static" | expand

Commit Message

Jamin Lin Nov. 3, 2023, 5:29 a.m. UTC
It would like to remove "-static" in the name of statice library
at the do_install task. For example: replace libbrotlicommon-static.a
with ibbrotlicommon-static.a However, if the patch of
this statice library includes "-static", it would build failed.
(ex: set my build directory "build-static")
Change to remove "-static" in the base name of static library
to fix this build failed.

Signed-off-by: Jamin Lin <jamin_lin@aspeedtech.com>
---
 meta-oe/recipes-extended/brotli/brotli_1.0.9.bb | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Khem Raj Nov. 3, 2023, 4:29 p.m. UTC | #1
On Fri, Nov 3, 2023 at 4:37 AM Jamin Lin via lists.openembedded.org
<jamin_lin=aspeedtech.com@lists.openembedded.org> wrote:
>
> It would like to remove "-static" in the name of statice library
> at the do_install task. For example: replace libbrotlicommon-static.a
> with ibbrotlicommon-static.a However, if the patch of
> this statice library includes "-static", it would build failed.
> (ex: set my build directory "build-static")
> Change to remove "-static" in the base name of static library
> to fix this build failed.
>
> Signed-off-by: Jamin Lin <jamin_lin@aspeedtech.com>
> ---
>  meta-oe/recipes-extended/brotli/brotli_1.0.9.bb | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/meta-oe/recipes-extended/brotli/brotli_1.0.9.bb b/meta-oe/recipes-extended/brotli/brotli_1.0.9.bb
> index 4e2813dde..6492b1943 100644
> --- a/meta-oe/recipes-extended/brotli/brotli_1.0.9.bb
> +++ b/meta-oe/recipes-extended/brotli/brotli_1.0.9.bb
> @@ -16,7 +16,8 @@ inherit cmake lib_package
>
>  do_install:append () {
>         for lib in $(ls ${D}${libdir}/*-static.a); do
> -               mv -v "${lib}" "$(echo ${lib} | sed s/-static//)"
> +               basename=$(basename ${lib})
> +               mv -v "${lib}" "${D}${libdir}$(echo ${basename} | sed s/-static//)"

This results in path without a sepator.

ERROR: brotli-1.0.9-r0 do_package: QA Issue: brotli: Files/directories
were installed but not shipped in any package:
  /usr/liblibbrotlienc.a
  /usr/liblibbrotlicommon.a
  /usr/liblibbrotlidec.a

>         done
>  }
>
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#105854): https://lists.openembedded.org/g/openembedded-devel/message/105854
> Mute This Topic: https://lists.openembedded.org/mt/102360862/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Jamin Lin Nov. 6, 2023, 8:18 a.m. UTC | #2
Thanks review.
Will fix
Jamin Lin Nov. 6, 2023, 8:24 a.m. UTC | #3
Thanks for your review.
Will fix it


From: Khem Raj <raj.khem@gmail.com> 
Sent: Saturday, November 4, 2023 12:29 AM
To: Jamin Lin <jamin_lin@aspeedtech.com>
Cc: openembedded-devel@lists.openembedded.org
Subject: Re: [oe] [PATCH v1 1/1] Brotli: fix build failed if the path includes "-static"

On Fri, Nov 3, 2023 at 4:37 AM Jamin Lin via lists.openembedded.org <jamin_lin=aspeedtech.com@lists.openembedded.org> wrote:
>
> It would like to remove "-static" in the name of statice library at 
> the do_install task. For example: replace libbrotlicommon-static.a 
> with ibbrotlicommon-static.a However, if the patch of this statice 
> library includes "-static", it would build failed.
> (ex: set my build directory "build-static") Change to remove "-static" 
> in the base name of static library to fix this build failed.
>
> Signed-off-by: Jamin Lin <jamin_lin@aspeedtech.com>
> ---
>  meta-oe/recipes-extended/brotli/brotli_1.0.9.bb | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/meta-oe/recipes-extended/brotli/brotli_1.0.9.bb 
> b/meta-oe/recipes-extended/brotli/brotli_1.0.9.bb
> index 4e2813dde..6492b1943 100644
> --- a/meta-oe/recipes-extended/brotli/brotli_1.0.9.bb
> +++ b/meta-oe/recipes-extended/brotli/brotli_1.0.9.bb
> @@ -16,7 +16,8 @@ inherit cmake lib_package
>
>  do_install:append () {
>         for lib in $(ls ${D}${libdir}/*-static.a); do
> -               mv -v "${lib}" "$(echo ${lib} | sed s/-static//)"
> +               basename=$(basename ${lib})
> +               mv -v "${lib}" "${D}${libdir}$(echo ${basename} | sed s/-static//)"

This results in path without a sepator.

ERROR: brotli-1.0.9-r0 do_package: QA Issue: brotli: Files/directories were installed but not shipped in any package:
  /usr/liblibbrotlienc.a
  /usr/liblibbrotlicommon.a
  /usr/liblibbrotlidec.a

>         done
>  }
>
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#105854): 
> https://lists.openembedded.org/g/openembedded-devel/message/105854
> Mute This Topic: https://lists.openembedded.org/mt/102360862/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub 
> [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-oe/recipes-extended/brotli/brotli_1.0.9.bb b/meta-oe/recipes-extended/brotli/brotli_1.0.9.bb
index 4e2813dde..6492b1943 100644
--- a/meta-oe/recipes-extended/brotli/brotli_1.0.9.bb
+++ b/meta-oe/recipes-extended/brotli/brotli_1.0.9.bb
@@ -16,7 +16,8 @@  inherit cmake lib_package
 
 do_install:append () {
 	for lib in $(ls ${D}${libdir}/*-static.a); do
-		mv -v "${lib}" "$(echo ${lib} | sed s/-static//)"
+		basename=$(basename ${lib})
+		mv -v "${lib}" "${D}${libdir}$(echo ${basename} | sed s/-static//)"
 	done
 }