diff mbox series

[meta-python] python3-rarfile: add recipe

Message ID 20231031175133.2902962-1-leon.anavi@konsulko.com
State Under Review
Headers show
Series [meta-python] python3-rarfile: add recipe | expand

Commit Message

Leon Anavi Oct. 31, 2023, 5:51 p.m. UTC
Add rarfile, a Python module for RAR archive reading. Version 4.1
brings:

- Support 7zip/p7zip as decompression backend
- RAR5: check password before trying to read file
- Make get_rar_version a public function
- New option: part_only for RarFile, to read only single file and
  allow it to be middle-part of multi-volume archive
- Add RarFile.printdir, use it in dumprar. Needed to examine
  FILE_COPY or HARD_LINK entries that do not contain data

Add run-time dependencies on p7zip as it is one of the supported
backend as well as to other required Python libraries.

This work was sponsored by GOVCERT.LU.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../python/python3-rarfile_4.1.bb             | 23 +++++++++++++++++++
 1 file changed, 23 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-rarfile_4.1.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-rarfile_4.1.bb b/meta-python/recipes-devtools/python/python3-rarfile_4.1.bb
new file mode 100644
index 000000000..ece92ee3b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-rarfile_4.1.bb
@@ -0,0 +1,23 @@ 
+SUMMARY = "RAR archive reader for Python"
+HOMEPAGE = "https://github.com/markokr/rarfile"
+LICENSE = "ISC"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2f31e224cbf0c29cb6c55f2bae0e165f"
+
+inherit setuptools3
+
+SRC_URI[sha256sum] = "db60b3b5bc1c4bdeb941427d50b606d51df677353385255583847639473eda48"
+
+inherit pypi
+
+PYPI_PACKAGE="rarfile"
+
+RDEPENDS:${PN} += "\
+    p7zip \
+    ${PYTHON_PN}-core \
+    ${PYTHON_PN}-datetime \
+    ${PYTHON_PN}-crypt \
+    ${PYTHON_PN}-io \
+"
+
+BBCLASSEXTEND = "native nativesdk"