[honister,16/17] core-image-sato-sdk: allocate more memory when in qemu

Message ID 593a10c37f7928ce4714dd16bd26dc0cb56446e9.1643983711.git.anuj.mittal@intel.com
State Accepted, archived
Commit 593a10c37f7928ce4714dd16bd26dc0cb56446e9
Headers show
Series [honister,01/17] kernel: introduce python3-dtschema-wrapper | expand

Commit Message

Mittal, Anuj Feb. 4, 2022, 2:12 p.m. UTC
From: Ross Burton <ross@burtonini.com>

Compiling code is memory-intensive, especially kernel modules like the
SystemTap probes, so give the VM 768MB of RAM.  Using 1GB appears to
cause PCI error, interestingly.

Hopefully this solves the intermittent failures caused by OOMs during
the SystemTap test.

[ YOCTO #14673 ]

Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 50ff1f018a670c963e1979dee76ebd696153b4c1)
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
---
 meta/recipes-sato/images/core-image-sato-sdk.bb | 3 +++
 1 file changed, 3 insertions(+)

Patch

diff --git a/meta/recipes-sato/images/core-image-sato-sdk.bb b/meta/recipes-sato/images/core-image-sato-sdk.bb
index b52de0def0..afab473b52 100644
--- a/meta/recipes-sato/images/core-image-sato-sdk.bb
+++ b/meta/recipes-sato/images/core-image-sato-sdk.bb
@@ -10,3 +10,6 @@  IMAGE_FEATURES += "dev-pkgs tools-sdk \
 
 IMAGE_INSTALL += "kernel-devsrc"
 
+# Compiling stuff, specifically SystemTap probes, can require lots of memory
+# See https://bugzilla.yoctoproject.org/show_bug.cgi?id=14673
+QB_MEM = "-m 768"