diff mbox series

[meta-networking,2/2] networkmanager-openvpn,networkmanager: Update the patch to work with musl + bfd linker

Message ID 20231027050421.969572-2-raj.khem@gmail.com
State New
Headers show
Series [meta-gnome,1/2] network-manager-applet: Update the patch to work with musl + bfd linker | expand

Commit Message

Khem Raj Oct. 27, 2023, 5:04 a.m. UTC
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 ...-script-Do-not-export-_IO_stdin_used.patch | 40 ++++++++-----------
 ...scripts-Do-not-export-_IO_stdin_used.patch | 33 ++++-----------
 2 files changed, 25 insertions(+), 48 deletions(-)
diff mbox series

Patch

diff --git a/meta-networking/recipes-connectivity/networkmanager/networkmanager-openvpn/0001-linker-script-Do-not-export-_IO_stdin_used.patch b/meta-networking/recipes-connectivity/networkmanager/networkmanager-openvpn/0001-linker-script-Do-not-export-_IO_stdin_used.patch
index eafd497ae2..f9d78e69b0 100644
--- a/meta-networking/recipes-connectivity/networkmanager/networkmanager-openvpn/0001-linker-script-Do-not-export-_IO_stdin_used.patch
+++ b/meta-networking/recipes-connectivity/networkmanager/networkmanager-openvpn/0001-linker-script-Do-not-export-_IO_stdin_used.patch
@@ -1,30 +1,24 @@ 
-From e09ba80e342b3b24bb2a46e11dae1c30cc61c75c Mon Sep 17 00:00:00 2001
+From 3ee6967689b3da30cc4551885d8bcdd44a7a9b52 Mon Sep 17 00:00:00 2001
 From: Khem Raj <raj.khem@gmail.com>
-Date: Sun, 3 Sep 2023 08:48:42 -0700
-Subject: [PATCH] linker-script: Do not export _IO_stdin_used
+Date: Thu, 31 Aug 2023 21:16:55 -0700
+Subject: [PATCH] linker-scripts: Do not export _IO_stdin_used
 
-This is glibc specific toolhain issue, it should have been handled in
-toolchain instead of exposing to applications. This was done to fix
-
-https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=835550
+This is glibc specific and it is not needed with musl.
+See https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=835550
 
 Upstream-Status: Pending
 Signed-off-by: Khem Raj <raj.khem@gmail.com>
 ---
- linker-script-binary.ver | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/linker-script-binary.ver b/linker-script-binary.ver
-index a2780c0..f030d35 100644
---- a/linker-script-binary.ver
-+++ b/linker-script-binary.ver
-@@ -1,6 +1,5 @@
- {
- global:
--	_IO_stdin_used;
- local:
- 	*;
- };
--- 
-2.42.0
+ tools/create-exports-NetworkManager.sh | 1 -
+ 2 files changed, 2 deletions(-)
 
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1896,7 +1896,6 @@ src_libnm_core_impl_gen_metadata_nm_sett
+ 	$(NULL)
+ 
+ src_libnm_core_impl_gen_metadata_nm_settings_libnm_core_LDFLAGS = \
+-	-Wl,--version-script="$(srcdir)/linker-script-binary.ver" \
+ 	$(SANITIZER_EXEC_LDFLAGS) \
+ 	$(NULL)
+ 
diff --git a/meta-networking/recipes-connectivity/networkmanager/networkmanager/0001-linker-scripts-Do-not-export-_IO_stdin_used.patch b/meta-networking/recipes-connectivity/networkmanager/networkmanager/0001-linker-scripts-Do-not-export-_IO_stdin_used.patch
index 71ad01f51c..f9d78e69b0 100644
--- a/meta-networking/recipes-connectivity/networkmanager/networkmanager/0001-linker-scripts-Do-not-export-_IO_stdin_used.patch
+++ b/meta-networking/recipes-connectivity/networkmanager/networkmanager/0001-linker-scripts-Do-not-export-_IO_stdin_used.patch
@@ -9,33 +9,16 @@  See https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=835550
 Upstream-Status: Pending
 Signed-off-by: Khem Raj <raj.khem@gmail.com>
 ---
- linker-script-binary.ver               | 1 -
  tools/create-exports-NetworkManager.sh | 1 -
  2 files changed, 2 deletions(-)
 
-diff --git a/linker-script-binary.ver b/linker-script-binary.ver
-index a2780c0..f030d35 100644
---- a/linker-script-binary.ver
-+++ b/linker-script-binary.ver
-@@ -1,6 +1,5 @@
- {
- global:
--	_IO_stdin_used;
- local:
- 	*;
- };
-diff --git a/tools/create-exports-NetworkManager.sh b/tools/create-exports-NetworkManager.sh
-index ef4b381..60865ad 100755
---- a/tools/create-exports-NetworkManager.sh
-+++ b/tools/create-exports-NetworkManager.sh
-@@ -54,7 +54,6 @@ get_symbols_nm () {
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1896,7 +1896,6 @@ src_libnm_core_impl_gen_metadata_nm_sett
+ 	$(NULL)
  
- get_symbols_explicit() {
-     cat <<EOF | _sort
--_IO_stdin_used
- EOF
- }
+ src_libnm_core_impl_gen_metadata_nm_settings_libnm_core_LDFLAGS = \
+-	-Wl,--version-script="$(srcdir)/linker-script-binary.ver" \
+ 	$(SANITIZER_EXEC_LDFLAGS) \
+ 	$(NULL)
  
--- 
-2.42.0
-