diff mbox series

[meta-python] python3-prompt-toolkit: upgrade 3.0.36 -> 3.0.39

Message ID 1698051176-26057-1-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-python] python3-prompt-toolkit: upgrade 3.0.36 -> 3.0.39 | expand

Commit Message

Mingyu Wang (Fujitsu) Oct. 23, 2023, 8:52 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
===========
Fixes:
- Fix 'RuntimeError' when '__breakpointhook__' is called from another thread.
- Fix memory leak in filters usage.
- Ensure that key bindings are handled in the right context (when using
  contextvars).
- Fix regression in filters. (Use of 'WeakValueDictionary' caused filters to
  not be cached).
- Fix 'currentThread()' deprecation warning.
- Fix memory leak in filters.
- Make VERSION tuple numeric.

New features:
- Accept 'in_thread' keyword in 'prompt_toolkit.shortcuts.prompt()'.
- Support the 'NO_COLOR' environment variable.
- Use 24-bit true color now by default on Windows 10/11.
- Add '.run()' method in 'TelnetServer'. (To be used instead of
  '.start()/.stop()'.

Breaking changes:
- Subclasses of 'Filter' have to call 'super()' in their '__init__'.
- Drop support for Python 3.6:
  * This includes code cleanup for Python 3.6 compatibility.
  * Use 'get_running_loop()' instead of 'get_event_loop()'.
  * Use 'asyncio.run()' instead of 'asyncio.run_until_complete()'.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 ...rompt-toolkit_3.0.36.bb => python3-prompt-toolkit_3.0.39.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-prompt-toolkit_3.0.36.bb => python3-prompt-toolkit_3.0.39.bb} (87%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.36.bb b/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.39.bb
similarity index 87%
rename from meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.36.bb
rename to meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.39.bb
index a5299318b3..05ff41e7a9 100644
--- a/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.36.bb
+++ b/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.39.bb
@@ -3,7 +3,7 @@  HOMEPAGE = "https://python-prompt-toolkit.readthedocs.io/"
 LICENSE = "BSD-3-Clause"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=b2cde7da89f0c1f3e49bf968d00d554f"
 
-SRC_URI[sha256sum] = "3e163f254bef5a03b146397d7c1963bd3e2812f0964bb9a24e6ec761fd28db63"
+SRC_URI[sha256sum] = "04505ade687dc26dc4284b1ad19a83be2f2afe83e7a828ace0c72f3a1df72aac"
 
 inherit pypi setuptools3