diff mbox series

linux-yocto/6.5: serial: core: integrate upstream fixes

Message ID 20231019150849.2323667-1-bruce.ashfield@gmail.com
State Accepted, archived
Commit 7dc07d204651e326fdba802a1ac2a69f976437a4
Headers show
Series linux-yocto/6.5: serial: core: integrate upstream fixes | expand

Commit Message

Bruce Ashfield Oct. 19, 2023, 3:08 p.m. UTC
From: Bruce Ashfield <bruce.ashfield@gmail.com>

Integrating the following commit(s) to linux-yocto/6.5:

    14f83e409308 serial: core: test for -EINPROGRESS during tx power management validation
    1b5b735f311f serial: core: Fix checks for tx runtime PM state
    dee98a75d75c Revert "serial-core: disable power managment for serial tx"

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
---
 .../linux/linux-yocto-rt_6.5.bb               |  2 +-
 .../linux/linux-yocto-tiny_6.5.bb             |  2 +-
 meta/recipes-kernel/linux/linux-yocto_6.5.bb  | 22 +++++++++----------
 3 files changed, 13 insertions(+), 13 deletions(-)

Comments

Richard Purdie Oct. 19, 2023, 3:39 p.m. UTC | #1
On Thu, 2023-10-19 at 11:08 -0400, bruce.ashfield@gmail.com wrote:
> From: Bruce Ashfield <bruce.ashfield@gmail.com>
> 
> Integrating the following commit(s) to linux-yocto/6.5:
> 
>     14f83e409308 serial: core: test for -EINPROGRESS during tx power management validation
>     1b5b735f311f serial: core: Fix checks for tx runtime PM state
>     dee98a75d75c Revert "serial-core: disable power managment for serial tx"

Thanks, these changes look good.

> 
> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
> ---
>  .../linux/linux-yocto-rt_6.5.bb               |  2 +-
>  .../linux/linux-yocto-tiny_6.5.bb             |  2 +-
>  meta/recipes-kernel/linux/linux-yocto_6.5.bb  | 22 +++++++++----------
>  3 files changed, 13 insertions(+), 13 deletions(-)
> 
> diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_6.5.bb b/meta/recipes-kernel/linux/linux-yocto-rt_6.5.bb
> index 985490e5e5..598280c5b6 100644
> --- a/meta/recipes-kernel/linux/linux-yocto-rt_6.5.bb
> +++ b/meta/recipes-kernel/linux/linux-yocto-rt_6.5.bb
> @@ -14,7 +14,7 @@ python () {
>          raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
>  }
>  
> -SRCREV_machine ?= "541ff832e9f2a168145f96ff41857a6cf1c74289"
> +SRCREV_machine ?= "2aa14dbb8520e59358778a80b32d7ccf6dd6c2ac"
>  SRCREV_meta ?= "9af846da534077c91e3c42242fceba7aef8dd784"
>  

The patch doesn't want to apply unfortunately, locally (and on master)
I have:

SRCREV_machine ?= "541ff832e9f2a168145f96ff41857a6cf1c74289"
SRCREV_meta ?= "7686d2c442df26daa77f91098f7fac8fdf5b35d7"

for the rt recipe for example so the meta revisions are different. Did
I miss a patch?

Cheers,

Richard
diff mbox series

Patch

diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_6.5.bb b/meta/recipes-kernel/linux/linux-yocto-rt_6.5.bb
index 985490e5e5..598280c5b6 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_6.5.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_6.5.bb
@@ -14,7 +14,7 @@  python () {
         raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
 }
 
-SRCREV_machine ?= "541ff832e9f2a168145f96ff41857a6cf1c74289"
+SRCREV_machine ?= "2aa14dbb8520e59358778a80b32d7ccf6dd6c2ac"
 SRCREV_meta ?= "9af846da534077c91e3c42242fceba7aef8dd784"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine;protocol=https \
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_6.5.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_6.5.bb
index e2214851ab..b047ab340b 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_6.5.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_6.5.bb
@@ -17,7 +17,7 @@  DEPENDS += "openssl-native util-linux-native"
 KMETA = "kernel-meta"
 KCONF_BSP_AUDIT_LEVEL = "2"
 
-SRCREV_machine ?= "8ad515e79001700d5e3d36e6ffe37ebdae2b5cd4"
+SRCREV_machine ?= "dfe7f47645429e162819c3d5690d8f5052f5b5a3"
 SRCREV_meta ?= "9af846da534077c91e3c42242fceba7aef8dd784"
 
 PV = "${LINUX_VERSION}+git"
diff --git a/meta/recipes-kernel/linux/linux-yocto_6.5.bb b/meta/recipes-kernel/linux/linux-yocto_6.5.bb
index bd99b54bce..516605c587 100644
--- a/meta/recipes-kernel/linux/linux-yocto_6.5.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_6.5.bb
@@ -18,17 +18,17 @@  KBRANCH:qemux86-64 ?= "v6.5/standard/base"
 KBRANCH:qemuloongarch64  ?= "v6.5/standard/base"
 KBRANCH:qemumips64 ?= "v6.5/standard/mti-malta64"
 
-SRCREV_machine:qemuarm ?= "e3bd53c181eb362535991bb0e0c15bf7b8b8e86f"
-SRCREV_machine:qemuarm64 ?= "cd01efb6992e0af5dfef251420291d5984898a9c"
-SRCREV_machine:qemuloongarch64 ?= "79a314e29b53062b4dfd316569d5480ee0d19249"
-SRCREV_machine:qemumips ?= "76f1c7370493dd6068f6733eb7d6ff9da6e7fae8"
-SRCREV_machine:qemuppc ?= "a3ac3f52f2352476f0fb1b0b4fe7b1c2339f9b18"
-SRCREV_machine:qemuriscv64 ?= "79a314e29b53062b4dfd316569d5480ee0d19249"
-SRCREV_machine:qemuriscv32 ?= "79a314e29b53062b4dfd316569d5480ee0d19249"
-SRCREV_machine:qemux86 ?= "79a314e29b53062b4dfd316569d5480ee0d19249"
-SRCREV_machine:qemux86-64 ?= "79a314e29b53062b4dfd316569d5480ee0d19249"
-SRCREV_machine:qemumips64 ?= "59ac3aaf836bd355d0f9f734e7bcca3dde44573a"
-SRCREV_machine ?= "79a314e29b53062b4dfd316569d5480ee0d19249"
+SRCREV_machine:qemuarm ?= "04942abac8568705f1fae34066db171b6e2669bd"
+SRCREV_machine:qemuarm64 ?= "ea4b620f18f882b3d882a53ffa33d8125ab27c83"
+SRCREV_machine:qemuloongarch64 ?= "14f83e40930806c3f5c61988e69a3ca1820a1b8f"
+SRCREV_machine:qemumips ?= "3348b580e3c47da56ce97a8297a574c2e37bc410"
+SRCREV_machine:qemuppc ?= "2fd47e07960edcd21455548ac6a25b19babe5c10"
+SRCREV_machine:qemuriscv64 ?= "14f83e40930806c3f5c61988e69a3ca1820a1b8f"
+SRCREV_machine:qemuriscv32 ?= "14f83e40930806c3f5c61988e69a3ca1820a1b8f"
+SRCREV_machine:qemux86 ?= "14f83e40930806c3f5c61988e69a3ca1820a1b8f"
+SRCREV_machine:qemux86-64 ?= "14f83e40930806c3f5c61988e69a3ca1820a1b8f"
+SRCREV_machine:qemumips64 ?= "6706327d870a0f246df8ed20c6a7f51ef46db1d6"
+SRCREV_machine ?= "14f83e40930806c3f5c61988e69a3ca1820a1b8f"
 SRCREV_meta ?= "9af846da534077c91e3c42242fceba7aef8dd784"
 
 # set your preferred provider of linux-yocto to 'linux-yocto-upstream', and you'll