[meta-oe] pcp: Disable parallel compile

Message ID 20220203194833.3698685-1-raj.khem@gmail.com
State New
Headers show
Series [meta-oe] pcp: Disable parallel compile | expand

Commit Message

Khem Raj Feb. 3, 2022, 7:48 p.m. UTC
This fails often with
| chkacc1.c:8:10: fatal error: localconfig.h: No such file or directory
|     8 | #include "localconfig.h"
|       |          ^~~~~~~~~~~~~~~

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-oe/recipes-support/pcp/pcp-native_5.3.5.bb | 4 ++++
 meta-oe/recipes-support/pcp/pcp_5.3.5.bb        | 4 ++++
 2 files changed, 8 insertions(+)

Patch

diff --git a/meta-oe/recipes-support/pcp/pcp-native_5.3.5.bb b/meta-oe/recipes-support/pcp/pcp-native_5.3.5.bb
index 029a47531b..5f3c9b6f00 100644
--- a/meta-oe/recipes-support/pcp/pcp-native_5.3.5.bb
+++ b/meta-oe/recipes-support/pcp/pcp-native_5.3.5.bb
@@ -46,4 +46,8 @@  do_install () {
     PCP_MAN_DIR=${D}/${mandir} \
     PCP_DOC_DIR=${D}/${docdir} 
 }
+#| chkacc1.c:8:10: fatal error: localconfig.h: No such file or directory
+#|     8 | #include "localconfig.h"
+#|       |          ^~~~~~~~~~~~~~~
+PARALLEL_MAKE = ""
 
diff --git a/meta-oe/recipes-support/pcp/pcp_5.3.5.bb b/meta-oe/recipes-support/pcp/pcp_5.3.5.bb
index 290dbaaf4b..bd09985af3 100644
--- a/meta-oe/recipes-support/pcp/pcp_5.3.5.bb
+++ b/meta-oe/recipes-support/pcp/pcp_5.3.5.bb
@@ -219,3 +219,7 @@  FILES:${PN}-dev += " \
         ${datadir}/man/man3/pms* \
         ${datadir}/man/man3/pmt* \
 "
+#| chkacc1.c:8:10: fatal error: localconfig.h: No such file or directory
+#|     8 | #include "localconfig.h"
+#|       |          ^~~~~~~~~~~~~~~
+PARALLEL_MAKE = ""