[1/1] arm-bsp/psa-arch-tests: corstone1000: fetching linux-trusted-services repo

Message ID 20220203123839.33950-2-emekcan.aras@arm.com
State New
Headers show
Series arm-bsp/psa-arch-tests: corstone1000: fetching linux-trusted-services repo | expand

Commit Message

Emekcan Aras Feb. 3, 2022, 12:38 p.m. UTC
From: Abdellatif El Khlifi <abdellatif.elkhlifi@arm.com>

Fetching the repo at fetch task level. This makes sure CMake
does not fetch the code by its own.

Signed-off-by: Emekcan Aras <emekcan.aras@arm.com>
Signed-off-by: Abdellatif El Khlifi <abdellatif.elkhlifi@arm.com>
---
 .../trusted-services/psa-arch-tests-corstone1000.inc     | 9 +++++++++
 1 file changed, 9 insertions(+)

Comments

Ross Burton Feb. 3, 2022, 4:30 p.m. UTC | #1
This fails for me locally:

| CMake Error at
mbedtls-subbuild/mbedtls-populate-prefix/tmp/mbedtls-populate-gitclone.cmake:31
(message):
|   Failed to clone repository: 'https://github.com/ARMmbed/mbedtls.git'

Can someone suggest that maybe trusted-services should use git submodules?

Ross

On Thu, 3 Feb 2022 at 12:38, <emekcan.aras@arm.com> wrote:
>
> From: Abdellatif El Khlifi <abdellatif.elkhlifi@arm.com>
>
> Fetching the repo at fetch task level. This makes sure CMake
> does not fetch the code by its own.
>
> Signed-off-by: Emekcan Aras <emekcan.aras@arm.com>
> Signed-off-by: Abdellatif El Khlifi <abdellatif.elkhlifi@arm.com>
> ---
>  .../trusted-services/psa-arch-tests-corstone1000.inc     | 9 +++++++++
>  1 file changed, 9 insertions(+)
>
> diff --git a/meta-arm-bsp/recipes-security/trusted-services/psa-arch-tests-corstone1000.inc b/meta-arm-bsp/recipes-security/trusted-services/psa-arch-tests-corstone1000.inc
> index da619d4..46bcda0 100644
> --- a/meta-arm-bsp/recipes-security/trusted-services/psa-arch-tests-corstone1000.inc
> +++ b/meta-arm-bsp/recipes-security/trusted-services/psa-arch-tests-corstone1000.inc
> @@ -7,17 +7,26 @@ CMAKE_BUILD_PARALLEL_LEVEL = "${@oe.utils.parallel_make(d, True)}"
>
>  COMPATIBLE_MACHINE = "corstone1000"
>
> +SRC_URI:append = " git://git.gitlab.arm.com/linux-arm/linux-trusted-services.git;protocol=https;branch=main;name=linuxffauser;destsuffix=git/linux_ffa_user "
> +
>  SRC_URI:append = "\
>      file://0001-psa-arch-test-sysroot_compiler_flags_fix.patch \
>      file://0002-arm-bsp-psa-arch-test-Fixing-psa-arch-tests-cmake.patch \
>      file://0003-corstone1000-port-crypto-config.patch;patchdir=../psa-arch-tests \
>      "
>
> +LIC_FILES_CHKSUM:append = " file://../linux_ffa_user/Makefile;md5=a786a5cc7a7e0f02b6071ddc23d29111"
> +
> +# v2.1.0
> +SRCREV_linuxffauser = "77967912d033144aff2695cecbd52d3be450deaa"
> +
>  FILES:${PN} += "${libdir}/libts.so*  ${libdir}/deployments  ${bindir}/psa-*"
>  FILES:${PN}-dev = "${includedir}/deployments/psa-api-test/"
>
>  INSANE_SKIP:${PN} += "rpaths"
>
> +export LINUX_FFA_USER_SHIM_DIR = "${S}/../linux_ffa_user"
> +
>  do_configure() {
>      for PSA_API_TEST in ${PSA_API_TESTS}; do
>          cmake \
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#2943): https://lists.yoctoproject.org/g/meta-arm/message/2943
> Mute This Topic: https://lists.yoctoproject.org/mt/88881480/1676615
> Group Owner: meta-arm+owner@lists.yoctoproject.org
> Unsubscribe: https://lists.yoctoproject.org/g/meta-arm/unsub [ross@burtonini.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>

Patch

diff --git a/meta-arm-bsp/recipes-security/trusted-services/psa-arch-tests-corstone1000.inc b/meta-arm-bsp/recipes-security/trusted-services/psa-arch-tests-corstone1000.inc
index da619d4..46bcda0 100644
--- a/meta-arm-bsp/recipes-security/trusted-services/psa-arch-tests-corstone1000.inc
+++ b/meta-arm-bsp/recipes-security/trusted-services/psa-arch-tests-corstone1000.inc
@@ -7,17 +7,26 @@  CMAKE_BUILD_PARALLEL_LEVEL = "${@oe.utils.parallel_make(d, True)}"
 
 COMPATIBLE_MACHINE = "corstone1000"
 
+SRC_URI:append = " git://git.gitlab.arm.com/linux-arm/linux-trusted-services.git;protocol=https;branch=main;name=linuxffauser;destsuffix=git/linux_ffa_user "
+
 SRC_URI:append = "\
     file://0001-psa-arch-test-sysroot_compiler_flags_fix.patch \
     file://0002-arm-bsp-psa-arch-test-Fixing-psa-arch-tests-cmake.patch \
     file://0003-corstone1000-port-crypto-config.patch;patchdir=../psa-arch-tests \
     "
 
+LIC_FILES_CHKSUM:append = " file://../linux_ffa_user/Makefile;md5=a786a5cc7a7e0f02b6071ddc23d29111"
+
+# v2.1.0
+SRCREV_linuxffauser = "77967912d033144aff2695cecbd52d3be450deaa"
+
 FILES:${PN} += "${libdir}/libts.so*  ${libdir}/deployments  ${bindir}/psa-*"
 FILES:${PN}-dev = "${includedir}/deployments/psa-api-test/"
 
 INSANE_SKIP:${PN} += "rpaths"
 
+export LINUX_FFA_USER_SHIM_DIR = "${S}/../linux_ffa_user"
+
 do_configure() {
     for PSA_API_TEST in ${PSA_API_TESTS}; do
         cmake \