diff mbox series

[meta-python,1/4] python-git-pw: add from meta-patchtest

Message ID 20231013170801.3966008-1-tgamblin@baylibre.com
State Under Review
Headers show
Series [meta-python,1/4] python-git-pw: add from meta-patchtest | expand

Commit Message

Trevor Gamblin Oct. 13, 2023, 5:07 p.m. UTC
git-pw is a tool for integrating Git with Patchwork instances.  Add it
to meta-python from meta-patchtest so that more workflows can take
advantage of it.

Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
 .../python/python3-git-pw_2.5.0.bb            | 20 +++++++++++++++++++
 1 file changed, 20 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-git-pw_2.5.0.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-git-pw_2.5.0.bb b/meta-python/recipes-devtools/python/python3-git-pw_2.5.0.bb
new file mode 100644
index 0000000000..d060a922b7
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-git-pw_2.5.0.bb
@@ -0,0 +1,20 @@ 
+SUMMARY = "A tool for integrating Git with Patchwork"
+HOMEPAGE = "https://github.com/getpatchwork/git-pw"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=26e1a171d943c64f00c51f90c256b9d4"
+
+SRC_URI[sha256sum] = "c60169f9566bd6710f9c0985a005a0c326460b739d3f2b5c5c71e85211584590"
+
+inherit pypi python_setuptools_build_meta
+
+DEPENDS += " \
+    python3-pbr-native \
+"
+
+RDEPENDS:${PN} += " \
+    python3-arrow \
+    python3-click \
+    python3-pyyaml \
+    python3-requests \
+    python3-tabulate \
+"