diff mbox series

[meta-perl] libtext: add ptest

Message ID 20231013153951.2166008-1-david.pierret@smile.fr
State Under Review
Headers show
Series [meta-perl] libtext: add ptest | expand

Commit Message

David Pierret Oct. 13, 2023, 3:39 p.m. UTC
Signed-off-by: David Pierret <david.pierret@smile.fr>
Reviewed-by: Yoann Congal <yoann.congal@smile.fr>
---
 .../libtext/libtext-diff-perl/run-ptest       | 19 +++++++++++++++++++
 .../libtext/libtext-diff-perl_1.41.bb         | 11 +++++++++--
 2 files changed, 28 insertions(+), 2 deletions(-)
 create mode 100644 meta-perl/recipes-perl/libtext/libtext-diff-perl/run-ptest

Comments

Khem Raj Oct. 13, 2023, 4:11 p.m. UTC | #1
it will be good to also make it part of PTESTS_FAST_META_PERL or
PTESTS_SLOW_META_PERL
in meta-perl/conf/include/ptest-packagelists-meta-perl.inc

so we can run it as part of ptest image in CI

On Fri, Oct 13, 2023 at 8:49 AM David Pierret <david.pierret@smile.fr> wrote:
>
> Signed-off-by: David Pierret <david.pierret@smile.fr>
> Reviewed-by: Yoann Congal <yoann.congal@smile.fr>
> ---
>  .../libtext/libtext-diff-perl/run-ptest       | 19 +++++++++++++++++++
>  .../libtext/libtext-diff-perl_1.41.bb         | 11 +++++++++--
>  2 files changed, 28 insertions(+), 2 deletions(-)
>  create mode 100644 meta-perl/recipes-perl/libtext/libtext-diff-perl/run-ptest
>
> diff --git a/meta-perl/recipes-perl/libtext/libtext-diff-perl/run-ptest b/meta-perl/recipes-perl/libtext/libtext-diff-perl/run-ptest
> new file mode 100644
> index 000000000..c65b6cf8e
> --- /dev/null
> +++ b/meta-perl/recipes-perl/libtext/libtext-diff-perl/run-ptest
> @@ -0,0 +1,19 @@
> +#!/bin/sh
> +
> +for case in `find t -type f -name '*.t'`; do
> +    perl $case >$case.output 2>&1
> +    ret=$?
> +    cat $case.output
> +    if [ $ret -ne 0 ]; then
> +        echo "FAIL: ${case%.t}"
> +    elif grep -i 'SKIP' $case.output; then
> +        echo "SKIP: ${case%.t}"
> +    else
> +        echo "PASS: ${case%.t}"
> +    fi
> +
> +    rm -f $case.output
> +done
> +
> +
> +
> diff --git a/meta-perl/recipes-perl/libtext/libtext-diff-perl_1.41.bb b/meta-perl/recipes-perl/libtext/libtext-diff-perl_1.41.bb
> index afdf63ede..9dfadde8e 100644
> --- a/meta-perl/recipes-perl/libtext/libtext-diff-perl_1.41.bb
> +++ b/meta-perl/recipes-perl/libtext/libtext-diff-perl_1.41.bb
> @@ -11,17 +11,24 @@ HOMEPAGE = "http://search.cpan.org/~ovid/Text-Diff/"
>  LICENSE = "Artistic-1.0 | GPL-2.0-or-later"
>  LIC_FILES_CHKSUM = "file://LICENSE;md5=385c55653886acac3821999a3ccd17b3"
>
> -SRC_URI = "${CPAN_MIRROR}/authors/id/O/OV/OVID/Text-Diff-${PV}.tar.gz"
> +SRC_URI = "${CPAN_MIRROR}/authors/id/O/OV/OVID/Text-Diff-${PV}.tar.gz \
> +           file://run-ptest \
> +          "
>  SRC_URI[md5sum] = "30d56e6dd5551ca16b8e16cc7299dc21"
>  SRC_URI[sha256sum] = "a67f50a48e313c1680cc662109ce5f913ea71454db355d0cf4db87ac89d2d2fa"
>
>  S = "${WORKDIR}/Text-Diff-${PV}"
>
> -inherit cpan
> +inherit cpan ptest
> +RDEPENDS:${PN}-ptest += "perl-module-test perl-module-test-more"
>
>  RDEPENDS:${PN} = " libalgorithm-diff-perl \
>                     perl-module-extutils-makemaker \
>                     perl-module-exporter \
>  "
>
> +do_install_ptest () {
> +    cp -r ${B}/t ${D}${PTEST_PATH}
> +}
> +
>  BBCLASSEXTEND = "native"
> --
> 2.39.2
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#105478): https://lists.openembedded.org/g/openembedded-devel/message/105478
> Mute This Topic: https://lists.openembedded.org/mt/101942826/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-perl/recipes-perl/libtext/libtext-diff-perl/run-ptest b/meta-perl/recipes-perl/libtext/libtext-diff-perl/run-ptest
new file mode 100644
index 000000000..c65b6cf8e
--- /dev/null
+++ b/meta-perl/recipes-perl/libtext/libtext-diff-perl/run-ptest
@@ -0,0 +1,19 @@ 
+#!/bin/sh
+
+for case in `find t -type f -name '*.t'`; do
+    perl $case >$case.output 2>&1
+    ret=$?
+    cat $case.output
+    if [ $ret -ne 0 ]; then
+        echo "FAIL: ${case%.t}"
+    elif grep -i 'SKIP' $case.output; then
+        echo "SKIP: ${case%.t}"
+    else
+        echo "PASS: ${case%.t}"
+    fi
+
+    rm -f $case.output
+done
+
+
+
diff --git a/meta-perl/recipes-perl/libtext/libtext-diff-perl_1.41.bb b/meta-perl/recipes-perl/libtext/libtext-diff-perl_1.41.bb
index afdf63ede..9dfadde8e 100644
--- a/meta-perl/recipes-perl/libtext/libtext-diff-perl_1.41.bb
+++ b/meta-perl/recipes-perl/libtext/libtext-diff-perl_1.41.bb
@@ -11,17 +11,24 @@  HOMEPAGE = "http://search.cpan.org/~ovid/Text-Diff/"
 LICENSE = "Artistic-1.0 | GPL-2.0-or-later"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=385c55653886acac3821999a3ccd17b3"
 
-SRC_URI = "${CPAN_MIRROR}/authors/id/O/OV/OVID/Text-Diff-${PV}.tar.gz"
+SRC_URI = "${CPAN_MIRROR}/authors/id/O/OV/OVID/Text-Diff-${PV}.tar.gz \
+           file://run-ptest \
+          "
 SRC_URI[md5sum] = "30d56e6dd5551ca16b8e16cc7299dc21"
 SRC_URI[sha256sum] = "a67f50a48e313c1680cc662109ce5f913ea71454db355d0cf4db87ac89d2d2fa"
 
 S = "${WORKDIR}/Text-Diff-${PV}"
 
-inherit cpan
+inherit cpan ptest
+RDEPENDS:${PN}-ptest += "perl-module-test perl-module-test-more"
 
 RDEPENDS:${PN} = " libalgorithm-diff-perl \
                    perl-module-extutils-makemaker \
                    perl-module-exporter \
 "
 
+do_install_ptest () {
+    cp -r ${B}/t ${D}${PTEST_PATH}
+}
+
 BBCLASSEXTEND = "native"