diff mbox series

kmod: upgrade 30 -> 31

Message ID 1697187492-4113-1-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit 15baf1183c1551ec7204abc679bd973ffb39770f
Headers show
Series kmod: upgrade 30 -> 31 | expand

Commit Message

Mingyu Wang (Fujitsu) Oct. 13, 2023, 8:58 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
===========
- Improvements

  - Allow passing a path to modprobe so the module is loaded from
    anywhere from the filesystem, but still handling the module
    dependencies recorded in the indexes.
  - Use in-kernel decompression if available.
  - Make modprobe fallback to syslog when stderr is not available, as was
    documented in the man page, but not implemented
  - Better explaing `modprobe -r` and how it differentiates from rmmod
  - depmod learned a `-o <dir>` option to allow using a separate output
    directory.
  - Add compat with glibc >= 2.32.9000 that dropped __xstat
  - Improve testsuite to stop skipping tests when sysconfdir is something
    other than /etc
  - Build system improvements and updates
  - Change a few return codes from -ENOENT to -ENODATA to avoid confusing output
    in depmod when the module itself lacks a particular ELF section due to e.g.
    CONFIG_MODVERSIONS=n in the kernel.

- Bug Fixes

  - Fix testsuite using uninitialized memory when testing module removal
    with --wait
  - Fix testsuite not correctly overriding the stat syscall on 32-bit
    platforms. For most architectures this was harmless, but for MIPS it
    was causing some tests to fail.
  - Fix handling unknown signature algorithm
  - Fix linking with a static liblzma, libzstd or zlib
  - Fix memory leak when removing module holders
  - Fix out-of-bounds access when using very long paths as argument to rmmod
  - Fix warnings reported by UBSan

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 meta/recipes-kernel/kmod/{kmod_30.bb => kmod_31.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta/recipes-kernel/kmod/{kmod_30.bb => kmod_31.bb} (98%)
diff mbox series

Patch

diff --git a/meta/recipes-kernel/kmod/kmod_30.bb b/meta/recipes-kernel/kmod/kmod_31.bb
similarity index 98%
rename from meta/recipes-kernel/kmod/kmod_30.bb
rename to meta/recipes-kernel/kmod/kmod_31.bb
index 6fc9da9c82..934a678a06 100644
--- a/meta/recipes-kernel/kmod/kmod_30.bb
+++ b/meta/recipes-kernel/kmod/kmod_31.bb
@@ -15,7 +15,7 @@  LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
                    "
 inherit autotools bash-completion gtk-doc pkgconfig manpages update-alternatives
 
-SRCREV = "5d46434a63ae0160150a0efdde1914873697e273"
+SRCREV = "aff617ea871d0568cc491bd116c0be1e857463bb"
 
 SRC_URI = "git://git.kernel.org/pub/scm/utils/kernel/kmod/kmod.git;branch=master;protocol=https \
            file://depmod-search.conf \