diff mbox series

[meta-multimedia] wireplumber: Upgrade 0.4.14 -> 0.4.15

Message ID 20231012175101.23379-1-f_l_k@t-online.de
State Under Review
Headers show
Series [meta-multimedia] wireplumber: Upgrade 0.4.14 -> 0.4.15 | expand

Commit Message

Markus Volk Oct. 12, 2023, 5:51 p.m. UTC
Additions:

  - A new "DSP policy" module has been added; its purpose is to automatically
    load a filter-chain when a certain hardware device is present, so that
    audio always goes through this software DSP before reaching the device.
    This is mainly to support Apple M1/M2 devices, which require a software
    DSP to be always present

  - WpImplModule now supports loading module arguments directly from a SPA-JSON
    config file; this is mainly to support DSP configuration for Apple M1/M2
    and will likely be reworked for 0.5

  - Added support for automatically combining Bluetooth LE Audio device sets
    (e.g. pairs of earbuds) (!500)

  - Added command line options in ``wpctl`` to display device/node names and
    nicknames instead of descriptions

  - Added zsh completions file for ``wpctl``

  - The device profile selection policy now respects the ``device.profile``
    property if it is set on the device; this is useful to hand-pick a profile
    based on static configuration rules (alsa_monitor.rules)

Changes/Fixes:

  - Linking policy now sends an error to the client before destroying the node,
    if it determines that the node cannot be linked to any target; this fixes
    error reporting on the client side

  - Fixed a crash in suspend-node that could happen when destroying virtual
    sinks that were loaded from another process such as pw-loopback (#467)

  - Virtual machine default period size has been bumped to 1024 (#507)

  - Updated bluez5 default configuration, using ``bluez5.roles`` instead of
    ``bluez5.headset-roles`` now (!498)

  - Disabled Bluetooth autoconnect by default (!514)

  - Removed ``RestrictNamespaces`` option from the systemd services in order to
    allow libcamera to load sandboxed IPA modules (#466)

  - Fixed a JSON encoding bug with empty strings (#471)

  - Lua code can now parse strings without quotes from SPA-JSON

  - Added some missing `\since` annotations and made them show up in the
    generated gobject-introspection file, to help bindings generators

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 .../{wireplumber_0.4.14.bb => wireplumber_0.4.15.bb}          | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
 rename meta-multimedia/recipes-multimedia/wireplumber/{wireplumber_0.4.14.bb => wireplumber_0.4.15.bb} (98%)
diff mbox series

Patch

diff --git a/meta-multimedia/recipes-multimedia/wireplumber/wireplumber_0.4.14.bb b/meta-multimedia/recipes-multimedia/wireplumber/wireplumber_0.4.15.bb
similarity index 98%
rename from meta-multimedia/recipes-multimedia/wireplumber/wireplumber_0.4.14.bb
rename to meta-multimedia/recipes-multimedia/wireplumber/wireplumber_0.4.15.bb
index 6f93b443d..679921922 100644
--- a/meta-multimedia/recipes-multimedia/wireplumber/wireplumber_0.4.14.bb
+++ b/meta-multimedia/recipes-multimedia/wireplumber/wireplumber_0.4.15.bb
@@ -11,7 +11,7 @@  DEPENDS = "glib-2.0 glib-2.0-native lua pipewire \
     ${@bb.utils.contains("DISTRO_FEATURES", "gobject-introspection-data", "python3-native python3-lxml-native doxygen-native", "", d)} \
 "
 
-SRCREV = "6d0c7f7b7f484b3cd2aaf2e2b3cc902c095b4946"
+SRCREV = "d67b48e595cb4612fd7fd47f97df6b8883ef7f60"
 SRC_URI = " \
     git://gitlab.freedesktop.org/pipewire/wireplumber.git;branch=master;protocol=https \
     file://90-OE-disable-session-dbus-dependent-features.lua \
@@ -133,7 +133,7 @@  CONFFILES:${PN} += " \
 # itself to become a daemon, in practice, the PipeWire daemon is used.
 RRECOMMENDS:${PN} += "pipewire ${PN}-scripts ${PN}-modules-meta"
 
-FILES:${PN} += "${systemd_user_unitdir} ${systemd_system_unitdir}"
+FILES:${PN} += "${systemd_user_unitdir} ${systemd_system_unitdir} ${datadir}/zsh"
 
 FILES:libwireplumber = " \
     ${libdir}/libwireplumber-*.so.* \