diff mbox series

Fix find_bbfiles string endswith call

Message ID 20231011094429.987944-1-bhstalel@gmail.com
State Accepted, archived
Commit 5f742591b251b6a5302ab07fe6b809c2863c3c70
Headers show
Series Fix find_bbfiles string endswith call | expand

Commit Message

Talel BELHADJ SALEM Oct. 11, 2023, 9:44 a.m. UTC
Signed-off-by: Talel BELHAJSALEM <bhstalel@gmail.com>
---
 bitbake/lib/bb/cooker.py | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/bitbake/lib/bb/cooker.py b/bitbake/lib/bb/cooker.py
index 599c7ddaa2..9a3e32ac1b 100644
--- a/bitbake/lib/bb/cooker.py
+++ b/bitbake/lib/bb/cooker.py
@@ -1787,7 +1787,7 @@  class CookerCollectFiles(object):
             for ignored in ('SCCS', 'CVS', '.svn'):
                 if ignored in dirs:
                     dirs.remove(ignored)
-            found += [os.path.join(dir, f) for f in files if (f.endswith(['.bb', '.bbappend']))]
+            found += [os.path.join(dir, f) for f in files if (f.endswith(('.bb', '.bbappend')))]
 
         return found