diff mbox series

[mickledore,04/20] linux-yocto/6.1: update to v6.1.52

Message ID 3dc84243cfb11df1e483568093b2214d15f99e5d.1696982312.git.steve@sakoman.com
State New
Headers show
Series [mickledore,01/20] gstreamer: upgrade 1.22.5 -> 1.22.6 | expand

Commit Message

Steve Sakoman Oct. 11, 2023, 12:01 a.m. UTC
From: Bruce Ashfield <bruce.ashfield@gmail.com>

Updating  to the latest korg -stable release that comprises
the following commits:

    59b13c2b647e Linux 6.1.52
    4a6284a2fc63 pinctrl: amd: Don't show `Invalid config param` errors
    7bec12fa9813 usb: typec: tcpci: clear the fault status bit
    4da07e958bfd nilfs2: fix WARNING in mark_buffer_dirty due to discarded buffer reuse
    fdbfc54d5399 nilfs2: fix general protection fault in nilfs_lookup_dirty_data_buffers()
    689561db6869 dt-bindings: sc16is7xx: Add property to change GPIO function
    dca7c9965141 tcpm: Avoid soft reset when partner does not support get_status
    a1fc0096921c fsi: master-ast-cf: Add MODULE_FIRMWARE macro
    b5c7bc370e03 firmware: stratix10-svc: Fix an NULL vs IS_ERR() bug in probe
    b7366429626e serial: sc16is7xx: fix bug when first setting GPIO direction
    682f9b944374 serial: sc16is7xx: fix broken port 0 uart init
    4b3de7d2f869 serial: qcom-geni: fix opp vote on shutdown
    1cd102aaedb2 wifi: mt76: mt7921: fix skb leak by txs missing in AMSDU
    74ceef6e6925 wifi: mt76: mt7921: do not support one stream on secondary antenna only
    179c65828593 Bluetooth: btsdio: fix use after free bug in btsdio_remove due to race condition
    86b818e2495d staging: rtl8712: fix race condition
    bd69537c1a2c HID: wacom: remove the battery when the EKR is off
    48729a1d2a7a usb: chipidea: imx: improve logic if samsung,picophy-* parameter is 0
    c564d4f91a0c usb: dwc3: meson-g12a: do post init to fix broken usb after resumption
    bfc4ccc0bcae ALSA: usb-audio: Fix init call orders for UAC1
    69d9330f2eff USB: serial: option: add FOXCONN T99W368/T99W373 product
    34f396f7abd0 USB: serial: option: add Quectel EM05G variant (0x030e)
    5d0fe30be4e2 modules: only allow symbol_get of EXPORT_SYMBOL_GPL modules
    36231e2c4ebd rtc: ds1685: use EXPORT_SYMBOL_GPL for ds1685_rtc_poweroff
    915219699da1 net: enetc: use EXPORT_SYMBOL_GPL for enetc_phc_index
    4dab89cccd8c mmc: au1xmmc: force non-modular build and remove symbol_get usage
    ac6fa0e04be0 ARM: pxa: remove use of symbol_get()
    cf859267e639 ksmbd: reduce descriptor size if remaining bytes is less than request size
    d070c4dd2a5b ksmbd: replace one-element array with flex-array member in struct smb2_ea_info
    30fd6521b2fb ksmbd: fix slub overflow in ksmbd_decode_ntlmssp_auth_blob()
    7d8855fd849d ksmbd: fix wrong DataOffset validation of create context
    1ce9ebc96eda erofs: ensure that the post-EOF tails are all zeroed

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 9be500bb695d0c6f863397d2f4b17d505427001a)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
---
 .../linux/linux-yocto-rt_6.1.bb               |  6 ++--
 .../linux/linux-yocto-tiny_6.1.bb             |  6 ++--
 meta/recipes-kernel/linux/linux-yocto_6.1.bb  | 28 +++++++++----------
 3 files changed, 20 insertions(+), 20 deletions(-)
diff mbox series

Patch

diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb b/meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb
index a391e3b0e6..503732c1c6 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb
@@ -14,13 +14,13 @@  python () {
         raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
 }
 
-SRCREV_machine ?= "ad7c05a03b8d70ee30ecce783a861cb96ea258cf"
-SRCREV_meta ?= "f845a7f37d7114230d6609e2bd630070f2f6cd9b"
+SRCREV_machine ?= "7327e7ab3b5508182380405a51f2657f5bf669b4"
+SRCREV_meta ?= "9e389e7f44a22bc637328f15e106f6d60631780e"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine;protocol=https \
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-6.1;destsuffix=${KMETA};protocol=https"
 
-LINUX_VERSION ?= "6.1.51"
+LINUX_VERSION ?= "6.1.52"
 
 LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
 
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_6.1.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_6.1.bb
index e90e92ccbc..61175d5c6f 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_6.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_6.1.bb
@@ -8,7 +8,7 @@  require recipes-kernel/linux/linux-yocto.inc
 # CVE exclusions
 include recipes-kernel/linux/cve-exclusion_6.1.inc
 
-LINUX_VERSION ?= "6.1.51"
+LINUX_VERSION ?= "6.1.52"
 LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
 
 DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
@@ -17,8 +17,8 @@  DEPENDS += "openssl-native util-linux-native"
 KMETA = "kernel-meta"
 KCONF_BSP_AUDIT_LEVEL = "2"
 
-SRCREV_machine ?= "526b5bf2f74f881356bce8b44840dc86785fb7bf"
-SRCREV_meta ?= "f845a7f37d7114230d6609e2bd630070f2f6cd9b"
+SRCREV_machine ?= "b3879adf00e338e66e92431a434fa2549ac88b83"
+SRCREV_meta ?= "9e389e7f44a22bc637328f15e106f6d60631780e"
 
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
diff --git a/meta/recipes-kernel/linux/linux-yocto_6.1.bb b/meta/recipes-kernel/linux/linux-yocto_6.1.bb
index c55d411784..e95848ff76 100644
--- a/meta/recipes-kernel/linux/linux-yocto_6.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_6.1.bb
@@ -17,25 +17,25 @@  KBRANCH:qemux86-64 ?= "v6.1/standard/base"
 KBRANCH:qemuloongarch64  ?= "v6.1/standard/base"
 KBRANCH:qemumips64 ?= "v6.1/standard/mti-malta64"
 
-SRCREV_machine:qemuarm ?= "8c81de99a4b9f69345873b06077f9d4e1321298e"
-SRCREV_machine:qemuarm64 ?= "526b5bf2f74f881356bce8b44840dc86785fb7bf"
-SRCREV_machine:qemuloongarch64 ?= "526b5bf2f74f881356bce8b44840dc86785fb7bf"
-SRCREV_machine:qemumips ?= "733cb5842aeac106f5606df4da7c64a180f0c500"
-SRCREV_machine:qemuppc ?= "526b5bf2f74f881356bce8b44840dc86785fb7bf"
-SRCREV_machine:qemuriscv64 ?= "526b5bf2f74f881356bce8b44840dc86785fb7bf"
-SRCREV_machine:qemuriscv32 ?= "526b5bf2f74f881356bce8b44840dc86785fb7bf"
-SRCREV_machine:qemux86 ?= "526b5bf2f74f881356bce8b44840dc86785fb7bf"
-SRCREV_machine:qemux86-64 ?= "526b5bf2f74f881356bce8b44840dc86785fb7bf"
-SRCREV_machine:qemumips64 ?= "1c11fe963667e9380725bef0650aeaea8544ea8b"
-SRCREV_machine ?= "526b5bf2f74f881356bce8b44840dc86785fb7bf"
-SRCREV_meta ?= "f845a7f37d7114230d6609e2bd630070f2f6cd9b"
+SRCREV_machine:qemuarm ?= "3028542fe5ece9dd32c8e3b9b14b2c9f4c9cafac"
+SRCREV_machine:qemuarm64 ?= "b3879adf00e338e66e92431a434fa2549ac88b83"
+SRCREV_machine:qemuloongarch64 ?= "b3879adf00e338e66e92431a434fa2549ac88b83"
+SRCREV_machine:qemumips ?= "33c0b5a0c1af6abb4dee11ffa5ece66ffd01d3c8"
+SRCREV_machine:qemuppc ?= "b3879adf00e338e66e92431a434fa2549ac88b83"
+SRCREV_machine:qemuriscv64 ?= "b3879adf00e338e66e92431a434fa2549ac88b83"
+SRCREV_machine:qemuriscv32 ?= "b3879adf00e338e66e92431a434fa2549ac88b83"
+SRCREV_machine:qemux86 ?= "b3879adf00e338e66e92431a434fa2549ac88b83"
+SRCREV_machine:qemux86-64 ?= "b3879adf00e338e66e92431a434fa2549ac88b83"
+SRCREV_machine:qemumips64 ?= "ee418f38dbc9794b7976ad11fd74f5a3490c7c5e"
+SRCREV_machine ?= "b3879adf00e338e66e92431a434fa2549ac88b83"
+SRCREV_meta ?= "9e389e7f44a22bc637328f15e106f6d60631780e"
 
 # set your preferred provider of linux-yocto to 'linux-yocto-upstream', and you'll
 # get the <version>/base branch, which is pure upstream -stable, and the same
 # meta SRCREV as the linux-yocto-standard builds. Select your version using the
 # normal PREFERRED_VERSION settings.
 BBCLASSEXTEND = "devupstream:target"
-SRCREV_machine:class-devupstream ?= "c2cbfe5f51227dfe6ef7be013f0d56a32c040faa"
+SRCREV_machine:class-devupstream ?= "59b13c2b647e464dd85622c89d7f16c15d681e96"
 PN:class-devupstream = "linux-yocto-upstream"
 KBRANCH:class-devupstream = "v6.1/base"
 
@@ -43,7 +43,7 @@  SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;name=machine;branch=${KBRA
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-6.1;destsuffix=${KMETA};protocol=https"
 
 LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
-LINUX_VERSION ?= "6.1.51"
+LINUX_VERSION ?= "6.1.52"
 
 PV = "${LINUX_VERSION}+git${SRCPV}"