diff mbox series

[meta-arago,master/kirkstone,v5,4/4] ti-test: Add various tools

Message ID 20231009185336.9871-4-reatmon@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [meta-arago,master/kirkstone,v5,1/4] meta-arago-test: Collect all of the ti-test recipes into a new layer | expand

Commit Message

Ryan Eatmon Oct. 9, 2023, 6:53 p.m. UTC
Testing with poky shows that we were missing some needed utilities
that our internal tests were calling.

Signed-off-by: Ryan Eatmon <reatmon@ti.com>
---
v4: Added a lot more tools based on our upstream testing against our
    internal test scripts.

 .../recipes-core/packagegroups/ti-test.bb     | 37 ++++++++++++++++++-
 1 file changed, 35 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/meta-arago-test/recipes-core/packagegroups/ti-test.bb b/meta-arago-test/recipes-core/packagegroups/ti-test.bb
index 44f4f75d..cf720c03 100644
--- a/meta-arago-test/recipes-core/packagegroups/ti-test.bb
+++ b/meta-arago-test/recipes-core/packagegroups/ti-test.bb
@@ -6,24 +6,36 @@  PACKAGE_ARCH = "${MACHINE_ARCH}"
 inherit packagegroup
 
 TI_TEST_BASE = "\
+    alsa-utils \
     bc \
     bonnie++ \
     bridge-utils \
     cryptodev-tests \
     dma-heap-tests \
+    dosfstools \
+    ethtool \
     evtest \
     fio \
     git \
     hdparm \
+    i2c-tools \
     iozone3 \
+    iproute2-tc \
+    iproute2-devlink \
+    iperf3 \
+    kernel-modules \
     kernel-selftest \
     libdrm-tests \
     linuxptp \
     lmbench \
+    lsof \
     memtester \
     mstpd \
+    mtd-utils \
+    mtd-utils-ubifs \
     mtd-utils-ubifs-tests \
     nbench-byte \
+    netperf \
     openntpd \
     pcitest \
     perf \
@@ -36,6 +48,7 @@  TI_TEST_BASE = "\
     stream \
     stress \
     stress-ng \
+    tcpdump \
     v4l-utils \
     yavta \
 "
@@ -64,16 +77,22 @@  TI_TEST_TI_TOOLS = " \
 
 TI_TEST_TI_TOOLS:append:ti33x = " \
     omapconf \
+    pru-icss \
+    switch-config \
 "
 
 TI_TEST_TI_TOOLS:append:ti43x = " \
     omapconf \
+    pru-icss \
+    switch-config \
 "
 
 NOT_MAINLINE_MMIP_DEPS = "${@bb.utils.contains('MACHINE_FEATURES', 'mmip', 'omapdrmtest', '', d)}"
 
 TI_TEST_TI_TOOLS:append:omap-a15 = " \
     omapconf \
+    pru-icss \
+    switch-config \
     ${@oe.utils.conditional('ARAGO_BRAND', 'mainline', '', " \
         ti-ipc-test \
 	    ${NOT_MAINLINE_MMIP_DEPS} \
@@ -82,15 +101,29 @@  TI_TEST_TI_TOOLS:append:omap-a15 = " \
 
 TI_TEST_TI_TOOLS:append:k3 = " \
     k3conf \
+    switch-config \
+    ti-rtos-firmware \
+    ti-rpmsg-char \
+    ti-rpmsg-char-examples \
 "
 
-TI_TEST_TI_TOOLS:append:j721e = " \
-    ufs-utils \
+TI_TEST_TI_TOOLS:append:am62xx   = " \
+    pru-icss \
+"
+
+TI_TEST_TI_TOOLS:append:am64xx   = " \
+    pru-icss \
+"
+
+TI_TEST_TI_TOOLS:append:am65xx   = " \
+    pru-icss \
 "
 
 # Disable due to breakage
 #    viddec-test-app 
 TI_TEST_TI_TOOLS:append:j721e = " \
+    pru-icss \
+    ufs-utils \
     videnc-test-app \
 "