diff mbox series

[meta-gnome] gnome-control-center: Fix polkit gettext issue

Message ID 20231008030357.2199-1-f_l_k@t-online.de
State Under Review
Headers show
Series [meta-gnome] gnome-control-center: Fix polkit gettext issue | expand

Commit Message

Markus Volk Oct. 8, 2023, 3:03 a.m. UTC
polkit.its and polkit.loc are taken from host. This should be fine
as long as the host provides these files. At least on fedora 38
they are not installed by default and configure fails with:

| ../gnome-control-center-45.0/meson.build:205:6: ERROR: Command
`/home/flk/poky/build/tmp/work/corei7-64-poky-linux/gnome-control-center/45.0/recipe-sysroot-native/usr/bin/nativepython3 /home/flk/poky/build/tmp/work/corei7-64-poky-linux/gnome-control-center/45.0/gnome-control-center-45.0/build-aux/meson/find_xdg_file.py gettext/its/polkit.its` failed with status 1.
|
| A full log can be found at
/home/flk/poky/build/tmp/work/corei7-64-poky-linux/gnome-control-center/45.0/build/meson-logs/meson-log.txt
| ERROR: meson failed
| WARNING:
/home/flk/poky/build/tmp/work/corei7-64-poky-linux/gnome-control-center/45.0/temp/run.do_configure.6974:182 exit 1 from 'exit 1'

export XDG_DATA_DIRS to avoid this issue

https://gitlab.gnome.org/GNOME/gnome-control-center/-/blob/main/meson.build?ref_type=heads#L203
https://gitlab.gnome.org/GNOME/gnome-control-center/-/blob/main/build-aux/meson/find_xdg_file.py?ref_type=heads

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 .../gnome-control-center/gnome-control-center_45.0.bb           | 2 ++
 1 file changed, 2 insertions(+)
diff mbox series

Patch

diff --git a/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_45.0.bb b/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_45.0.bb
index 1122ee5ea..29c9f3c48 100644
--- a/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_45.0.bb
+++ b/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_45.0.bb
@@ -48,6 +48,8 @@  PACKAGECONFIG[wayland] = "-Dwayland=true, -Dwayland=false, wayland"
 
 EXTRA_OEMESON += "-Doe_sysroot=${STAGING_DIR_HOST}"
 
+export XDG_DATA_DIRS = "${STAGING_DATADIR}"
+
 USERADD_PACKAGES = "${PN}"
 USERADD_PARAM:${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/polkit-1 polkitd"