python: Fix python-nativesdk variable contamination issue

Submitted by Richard Purdie on July 12, 2012, 3:19 p.m.

Details

Message ID 1342106363.22262.12.camel@ted
State Accepted
Commit 5740696c81a9143504c1cb93e94c54add27896e4
Headers show

Commit Message

Richard Purdie July 12, 2012, 3:19 p.m.
Without this, python-nativesdk-crypt can depend on openssl which is incorrect.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---

Patch hide | download patch | download mbox

diff --git a/meta/recipes-devtools/python/python_2.7.3.bb b/meta/recipes-devtools/python/python_2.7.3.bb
index b06d7b7..b736cc2 100644
--- a/meta/recipes-devtools/python/python_2.7.3.bb
+++ b/meta/recipes-devtools/python/python_2.7.3.bb
@@ -147,6 +147,7 @@  require python-${PYTHON_MAJMIN}-manifest.inc
 RPROVIDES_${PN}-core = "${PN}"
 RRECOMMENDS_${PN}-core = "${PN}-readline"
 RRECOMMENDS_${PN}-crypt = "openssl"
+RRECOMMENDS_${PN}-crypt_virtclass-nativesdk = "openssl-nativesdk"
 
 # package libpython2
 PACKAGES =+ "lib${BPN}2${PKGSUFFIX}"