diff mbox series

gstreamer1.0-plugins-good: Provide Qt6 option for qmlgl

Message ID 20231004160911.3030063-1-cordlandwehr@kde.org
State New
Headers show
Series gstreamer1.0-plugins-good: Provide Qt6 option for qmlgl | expand

Commit Message

Andreas Cord-Landwehr Oct. 4, 2023, 4:09 p.m. UTC
Gstreamer release 1.22.0 introduced option for Qt6 API.

Signed-off-by: Andreas Cord-Landwehr <cordlandwehr@kde.org>
---
 .../gstreamer/gstreamer1.0-plugins-good_1.22.5.bb      | 10 ++++++++--
 1 file changed, 8 insertions(+), 2 deletions(-)

Comments

Khem Raj Oct. 4, 2023, 6:10 p.m. UTC | #1
On Wed, Oct 4, 2023 at 9:09 AM Andreas Cord-Landwehr
<cordlandwehr@kde.org> wrote:
>
> Gstreamer release 1.22.0 introduced option for Qt6 API.
>
> Signed-off-by: Andreas Cord-Landwehr <cordlandwehr@kde.org>
> ---
>  .../gstreamer/gstreamer1.0-plugins-good_1.22.5.bb      | 10 ++++++++--
>  1 file changed, 8 insertions(+), 2 deletions(-)
>
> diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb
> index 93f0e76ee9..ca1e1d6046 100644
> --- a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb
> +++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb
> @@ -35,7 +35,7 @@ X11DEPENDS = "virtual/libx11 libsm libxrender libxfixes libxdamage"
>  X11ENABLEOPTS = "-Dximagesrc=enabled -Dximagesrc-xshm=enabled -Dximagesrc-xfixes=enabled -Dximagesrc-xdamage=enabled"
>  X11DISABLEOPTS = "-Dximagesrc=disabled -Dximagesrc-xshm=disabled -Dximagesrc-xfixes=disabled -Dximagesrc-xdamage=disabled"
>
> -QT5WAYLANDDEPENDS = "${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
> +QTWAYLANDDEPENDS = "${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
>
>  PACKAGECONFIG[asm]        = "-Dasm=enabled,-Dasm=disabled,nasm-native"
>  PACKAGECONFIG[bz2]        = "-Dbz2=enabled,-Dbz2=disabled,bzip2"
> @@ -52,7 +52,8 @@ PACKAGECONFIG[libpng]     = "-Dpng=enabled,-Dpng=disabled,libpng"
>  PACKAGECONFIG[libv4l2]    = "-Dv4l2-libv4l2=enabled,-Dv4l2-libv4l2=disabled,v4l-utils"
>  PACKAGECONFIG[mpg123]     = "-Dmpg123=enabled,-Dmpg123=disabled,mpg123"
>  PACKAGECONFIG[pulseaudio] = "-Dpulse=enabled,-Dpulse=disabled,pulseaudio"
> -PACKAGECONFIG[qt5]        = "-Dqt5=enabled,-Dqt5=disabled,qtbase qtdeclarative qtbase-native ${QT5WAYLANDDEPENDS}"
> +PACKAGECONFIG[qt5]        = "-Dqt5=enabled,-Dqt5=disabled,qtbase qtdeclarative qtbase-native ${QTWAYLANDDEPENDS}"
> +PACKAGECONFIG[qt6]        = "-Dqt6=enabled,-Dqt6=disabled,qtbase qtdeclarative qtbase-native qttools-native ${QTWAYLANDDEPENDS}"
>  PACKAGECONFIG[soup2]      = "-Dsoup=enabled,,libsoup-2.4,,,soup3"
>  PACKAGECONFIG[soup3]      = "-Dsoup=enabled,,libsoup,,,soup2"
>  PACKAGECONFIG[speex]      = "-Dspeex=enabled,-Dspeex=disabled,speex"
> @@ -79,3 +80,8 @@ EXTRA_OEMESON += " \
>  "
>
>  FILES:${PN}-equalizer += "${datadir}/gstreamer-1.0/presets/*.prs"
> +
> +do_configure:prepend() {
> +    # provide path to qtwaylandscanner
> +    export PATH=${PATH}:${STAGING_DIR_NATIVE}/${libexecdir}

perhaps we should fix naitve qt6 to install qtwaylandscanner in native
bindir. Then we do not need this.

> +}
> --
> 2.39.2
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#188689): https://lists.openembedded.org/g/openembedded-core/message/188689
> Mute This Topic: https://lists.openembedded.org/mt/101758538/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Andreas Cord-Landwehr Oct. 4, 2023, 6:19 p.m. UTC | #2
On 04.10.23 20:10, Khem Raj wrote:
> On Wed, Oct 4, 2023 at 9:09 AM Andreas Cord-Landwehr
> <cordlandwehr@kde.org> wrote:
>>
>> Gstreamer release 1.22.0 introduced option for Qt6 API.
>>
>> Signed-off-by: Andreas Cord-Landwehr <cordlandwehr@kde.org>
>> ---
>>   .../gstreamer/gstreamer1.0-plugins-good_1.22.5.bb      | 10 ++++++++--
>>   1 file changed, 8 insertions(+), 2 deletions(-)
>>
>> diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb
>> index 93f0e76ee9..ca1e1d6046 100644
>> --- a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb
>> +++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb
>> @@ -35,7 +35,7 @@ X11DEPENDS = "virtual/libx11 libsm libxrender libxfixes libxdamage"
>>   X11ENABLEOPTS = "-Dximagesrc=enabled -Dximagesrc-xshm=enabled -Dximagesrc-xfixes=enabled -Dximagesrc-xdamage=enabled"
>>   X11DISABLEOPTS = "-Dximagesrc=disabled -Dximagesrc-xshm=disabled -Dximagesrc-xfixes=disabled -Dximagesrc-xdamage=disabled"
>>
>> -QT5WAYLANDDEPENDS = "${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
>> +QTWAYLANDDEPENDS = "${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
>>
>>   PACKAGECONFIG[asm]        = "-Dasm=enabled,-Dasm=disabled,nasm-native"
>>   PACKAGECONFIG[bz2]        = "-Dbz2=enabled,-Dbz2=disabled,bzip2"
>> @@ -52,7 +52,8 @@ PACKAGECONFIG[libpng]     = "-Dpng=enabled,-Dpng=disabled,libpng"
>>   PACKAGECONFIG[libv4l2]    = "-Dv4l2-libv4l2=enabled,-Dv4l2-libv4l2=disabled,v4l-utils"
>>   PACKAGECONFIG[mpg123]     = "-Dmpg123=enabled,-Dmpg123=disabled,mpg123"
>>   PACKAGECONFIG[pulseaudio] = "-Dpulse=enabled,-Dpulse=disabled,pulseaudio"
>> -PACKAGECONFIG[qt5]        = "-Dqt5=enabled,-Dqt5=disabled,qtbase qtdeclarative qtbase-native ${QT5WAYLANDDEPENDS}"
>> +PACKAGECONFIG[qt5]        = "-Dqt5=enabled,-Dqt5=disabled,qtbase qtdeclarative qtbase-native ${QTWAYLANDDEPENDS}"
>> +PACKAGECONFIG[qt6]        = "-Dqt6=enabled,-Dqt6=disabled,qtbase qtdeclarative qtbase-native qttools-native ${QTWAYLANDDEPENDS}"
>>   PACKAGECONFIG[soup2]      = "-Dsoup=enabled,,libsoup-2.4,,,soup3"
>>   PACKAGECONFIG[soup3]      = "-Dsoup=enabled,,libsoup,,,soup2"
>>   PACKAGECONFIG[speex]      = "-Dspeex=enabled,-Dspeex=disabled,speex"
>> @@ -79,3 +80,8 @@ EXTRA_OEMESON += " \
>>   "
>>
>>   FILES:${PN}-equalizer += "${datadir}/gstreamer-1.0/presets/*.prs"
>> +
>> +do_configure:prepend() {
>> +    # provide path to qtwaylandscanner
>> +    export PATH=${PATH}:${STAGING_DIR_NATIVE}/${libexecdir}
> 
> perhaps we should fix naitve qt6 to install qtwaylandscanner in native
> bindir. Then we do not need this.

Hi, I brought this up recently in a different discussion

https://bugreports.qt.io/browse/QTBUG-116998

My understanding is that the move was deliberate and the expectation is 
that everybody uses the CMake macros with internal path logic; however, 
that fails when not using CMake like here with Meson.

> 
>> +}
>> --
>> 2.39.2
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#188689): https://lists.openembedded.org/g/openembedded-core/message/188689
>> Mute This Topic: https://lists.openembedded.org/mt/101758538/1997914
>> Group Owner: openembedded-core+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
Richard Purdie Oct. 4, 2023, 6:42 p.m. UTC | #3
On Wed, 2023-10-04 at 20:19 +0200, Andreas Cord-Landwehr wrote:
> On 04.10.23 20:10, Khem Raj wrote:
> > On Wed, Oct 4, 2023 at 9:09 AM Andreas Cord-Landwehr
> > <cordlandwehr@kde.org> wrote:
> > > 
> > > Gstreamer release 1.22.0 introduced option for Qt6 API.
> > > 
> > > Signed-off-by: Andreas Cord-Landwehr <cordlandwehr@kde.org>
> > > ---
> > >   .../gstreamer/gstreamer1.0-plugins-good_1.22.5.bb      | 10 ++++++++--
> > >   1 file changed, 8 insertions(+), 2 deletions(-)
> > > 
> > > diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb
> > > index 93f0e76ee9..ca1e1d6046 100644
> > > --- a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb
> > > +++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb
> > > @@ -35,7 +35,7 @@ X11DEPENDS = "virtual/libx11 libsm libxrender libxfixes libxdamage"
> > >   X11ENABLEOPTS = "-Dximagesrc=enabled -Dximagesrc-xshm=enabled -Dximagesrc-xfixes=enabled -Dximagesrc-xdamage=enabled"
> > >   X11DISABLEOPTS = "-Dximagesrc=disabled -Dximagesrc-xshm=disabled -Dximagesrc-xfixes=disabled -Dximagesrc-xdamage=disabled"
> > > 
> > > -QT5WAYLANDDEPENDS = "${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
> > > +QTWAYLANDDEPENDS = "${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
> > > 
> > >   PACKAGECONFIG[asm]        = "-Dasm=enabled,-Dasm=disabled,nasm-native"
> > >   PACKAGECONFIG[bz2]        = "-Dbz2=enabled,-Dbz2=disabled,bzip2"
> > > @@ -52,7 +52,8 @@ PACKAGECONFIG[libpng]     = "-Dpng=enabled,-Dpng=disabled,libpng"
> > >   PACKAGECONFIG[libv4l2]    = "-Dv4l2-libv4l2=enabled,-Dv4l2-libv4l2=disabled,v4l-utils"
> > >   PACKAGECONFIG[mpg123]     = "-Dmpg123=enabled,-Dmpg123=disabled,mpg123"
> > >   PACKAGECONFIG[pulseaudio] = "-Dpulse=enabled,-Dpulse=disabled,pulseaudio"
> > > -PACKAGECONFIG[qt5]        = "-Dqt5=enabled,-Dqt5=disabled,qtbase qtdeclarative qtbase-native ${QT5WAYLANDDEPENDS}"
> > > +PACKAGECONFIG[qt5]        = "-Dqt5=enabled,-Dqt5=disabled,qtbase qtdeclarative qtbase-native ${QTWAYLANDDEPENDS}"
> > > +PACKAGECONFIG[qt6]        = "-Dqt6=enabled,-Dqt6=disabled,qtbase qtdeclarative qtbase-native qttools-native ${QTWAYLANDDEPENDS}"
> > >   PACKAGECONFIG[soup2]      = "-Dsoup=enabled,,libsoup-2.4,,,soup3"
> > >   PACKAGECONFIG[soup3]      = "-Dsoup=enabled,,libsoup,,,soup2"
> > >   PACKAGECONFIG[speex]      = "-Dspeex=enabled,-Dspeex=disabled,speex"
> > > @@ -79,3 +80,8 @@ EXTRA_OEMESON += " \
> > >   "
> > > 
> > >   FILES:${PN}-equalizer += "${datadir}/gstreamer-1.0/presets/*.prs"
> > > +
> > > +do_configure:prepend() {
> > > +    # provide path to qtwaylandscanner
> > > +    export PATH=${PATH}:${STAGING_DIR_NATIVE}/${libexecdir}
> > 
> > perhaps we should fix naitve qt6 to install qtwaylandscanner in native
> > bindir. Then we do not need this.
> 
> Hi, I brought this up recently in a different discussion
> 
> https://bugreports.qt.io/browse/QTBUG-116998
> 
> My understanding is that the move was deliberate and the expectation is 
> that everybody uses the CMake macros with internal path logic; however, 
> that fails when not using CMake like here with Meson.

There isn't anything stopping OE from symlinking it in it's recipe?

Cheers,

Richard
Andreas Cord-Landwehr Oct. 5, 2023, 7:22 p.m. UTC | #4
On 04.10.23 20:42, Richard Purdie wrote:
> On Wed, 2023-10-04 at 20:19 +0200, Andreas Cord-Landwehr wrote:
>> On 04.10.23 20:10, Khem Raj wrote:
>>> On Wed, Oct 4, 2023 at 9:09 AM Andreas Cord-Landwehr
>>> <cordlandwehr@kde.org> wrote:
>>>>
>>>> Gstreamer release 1.22.0 introduced option for Qt6 API.
>>>>
>>>> Signed-off-by: Andreas Cord-Landwehr <cordlandwehr@kde.org>
>>>> ---
>>>>    .../gstreamer/gstreamer1.0-plugins-good_1.22.5.bb      | 10 ++++++++--
>>>>    1 file changed, 8 insertions(+), 2 deletions(-)
>>>>
>>>> diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb
>>>> index 93f0e76ee9..ca1e1d6046 100644
>>>> --- a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb
>>>> +++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb
>>>> @@ -35,7 +35,7 @@ X11DEPENDS = "virtual/libx11 libsm libxrender libxfixes libxdamage"
>>>>    X11ENABLEOPTS = "-Dximagesrc=enabled -Dximagesrc-xshm=enabled -Dximagesrc-xfixes=enabled -Dximagesrc-xdamage=enabled"
>>>>    X11DISABLEOPTS = "-Dximagesrc=disabled -Dximagesrc-xshm=disabled -Dximagesrc-xfixes=disabled -Dximagesrc-xdamage=disabled"
>>>>
>>>> -QT5WAYLANDDEPENDS = "${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
>>>> +QTWAYLANDDEPENDS = "${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
>>>>
>>>>    PACKAGECONFIG[asm]        = "-Dasm=enabled,-Dasm=disabled,nasm-native"
>>>>    PACKAGECONFIG[bz2]        = "-Dbz2=enabled,-Dbz2=disabled,bzip2"
>>>> @@ -52,7 +52,8 @@ PACKAGECONFIG[libpng]     = "-Dpng=enabled,-Dpng=disabled,libpng"
>>>>    PACKAGECONFIG[libv4l2]    = "-Dv4l2-libv4l2=enabled,-Dv4l2-libv4l2=disabled,v4l-utils"
>>>>    PACKAGECONFIG[mpg123]     = "-Dmpg123=enabled,-Dmpg123=disabled,mpg123"
>>>>    PACKAGECONFIG[pulseaudio] = "-Dpulse=enabled,-Dpulse=disabled,pulseaudio"
>>>> -PACKAGECONFIG[qt5]        = "-Dqt5=enabled,-Dqt5=disabled,qtbase qtdeclarative qtbase-native ${QT5WAYLANDDEPENDS}"
>>>> +PACKAGECONFIG[qt5]        = "-Dqt5=enabled,-Dqt5=disabled,qtbase qtdeclarative qtbase-native ${QTWAYLANDDEPENDS}"
>>>> +PACKAGECONFIG[qt6]        = "-Dqt6=enabled,-Dqt6=disabled,qtbase qtdeclarative qtbase-native qttools-native ${QTWAYLANDDEPENDS}"
>>>>    PACKAGECONFIG[soup2]      = "-Dsoup=enabled,,libsoup-2.4,,,soup3"
>>>>    PACKAGECONFIG[soup3]      = "-Dsoup=enabled,,libsoup,,,soup2"
>>>>    PACKAGECONFIG[speex]      = "-Dspeex=enabled,-Dspeex=disabled,speex"
>>>> @@ -79,3 +80,8 @@ EXTRA_OEMESON += " \
>>>>    "
>>>>
>>>>    FILES:${PN}-equalizer += "${datadir}/gstreamer-1.0/presets/*.prs"
>>>> +
>>>> +do_configure:prepend() {
>>>> +    # provide path to qtwaylandscanner
>>>> +    export PATH=${PATH}:${STAGING_DIR_NATIVE}/${libexecdir}
>>>
>>> perhaps we should fix naitve qt6 to install qtwaylandscanner in native
>>> bindir. Then we do not need this.
>>
>> Hi, I brought this up recently in a different discussion
>>
>> https://bugreports.qt.io/browse/QTBUG-116998
>>
>> My understanding is that the move was deliberate and the expectation is
>> that everybody uses the CMake macros with internal path logic; however,
>> that fails when not using CMake like here with Meson.
> 
> There isn't anything stopping OE from symlinking it in it's recipe?
> 
> Cheers,
> 
> Richard

Hi Richard,

thanks for you answer! Since qtwayland is part of meta-qt6, do I get 
your comment correct that you suggest creating a symlink
/usr/bin/qtwaylandscanner -> /usr/libexec/qtwaylandscanner
for the gstreamer1.0-plugins-good recipe or do you have patching of 
qtwayland in mind?

Cheers,
Andreas
Richard Purdie Oct. 5, 2023, 7:27 p.m. UTC | #5
On Thu, 2023-10-05 at 21:22 +0200, Andreas Cord-Landwehr wrote:
> On 04.10.23 20:42, Richard Purdie wrote:
> > On Wed, 2023-10-04 at 20:19 +0200, Andreas Cord-Landwehr wrote:
> > > On 04.10.23 20:10, Khem Raj wrote:
> > > > On Wed, Oct 4, 2023 at 9:09 AM Andreas Cord-Landwehr
> > > > <cordlandwehr@kde.org> wrote:
> > > > > 
> > > > > Gstreamer release 1.22.0 introduced option for Qt6 API.
> > > > > 
> > > > > Signed-off-by: Andreas Cord-Landwehr <cordlandwehr@kde.org>
> > > > > ---
> > > > >    .../gstreamer/gstreamer1.0-plugins-good_1.22.5.bb      | 10 ++++++++--
> > > > >    1 file changed, 8 insertions(+), 2 deletions(-)
> > > > > 
> > > > > diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb
> > > > > index 93f0e76ee9..ca1e1d6046 100644
> > > > > --- a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb
> > > > > +++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb
> > > > > @@ -35,7 +35,7 @@ X11DEPENDS = "virtual/libx11 libsm libxrender libxfixes libxdamage"
> > > > >    X11ENABLEOPTS = "-Dximagesrc=enabled -Dximagesrc-xshm=enabled -Dximagesrc-xfixes=enabled -Dximagesrc-xdamage=enabled"
> > > > >    X11DISABLEOPTS = "-Dximagesrc=disabled -Dximagesrc-xshm=disabled -Dximagesrc-xfixes=disabled -Dximagesrc-xdamage=disabled"
> > > > > 
> > > > > -QT5WAYLANDDEPENDS = "${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
> > > > > +QTWAYLANDDEPENDS = "${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
> > > > > 
> > > > >    PACKAGECONFIG[asm]        = "-Dasm=enabled,-Dasm=disabled,nasm-native"
> > > > >    PACKAGECONFIG[bz2]        = "-Dbz2=enabled,-Dbz2=disabled,bzip2"
> > > > > @@ -52,7 +52,8 @@ PACKAGECONFIG[libpng]     = "-Dpng=enabled,-Dpng=disabled,libpng"
> > > > >    PACKAGECONFIG[libv4l2]    = "-Dv4l2-libv4l2=enabled,-Dv4l2-libv4l2=disabled,v4l-utils"
> > > > >    PACKAGECONFIG[mpg123]     = "-Dmpg123=enabled,-Dmpg123=disabled,mpg123"
> > > > >    PACKAGECONFIG[pulseaudio] = "-Dpulse=enabled,-Dpulse=disabled,pulseaudio"
> > > > > -PACKAGECONFIG[qt5]        = "-Dqt5=enabled,-Dqt5=disabled,qtbase qtdeclarative qtbase-native ${QT5WAYLANDDEPENDS}"
> > > > > +PACKAGECONFIG[qt5]        = "-Dqt5=enabled,-Dqt5=disabled,qtbase qtdeclarative qtbase-native ${QTWAYLANDDEPENDS}"
> > > > > +PACKAGECONFIG[qt6]        = "-Dqt6=enabled,-Dqt6=disabled,qtbase qtdeclarative qtbase-native qttools-native ${QTWAYLANDDEPENDS}"
> > > > >    PACKAGECONFIG[soup2]      = "-Dsoup=enabled,,libsoup-2.4,,,soup3"
> > > > >    PACKAGECONFIG[soup3]      = "-Dsoup=enabled,,libsoup,,,soup2"
> > > > >    PACKAGECONFIG[speex]      = "-Dspeex=enabled,-Dspeex=disabled,speex"
> > > > > @@ -79,3 +80,8 @@ EXTRA_OEMESON += " \
> > > > >    "
> > > > > 
> > > > >    FILES:${PN}-equalizer += "${datadir}/gstreamer-1.0/presets/*.prs"
> > > > > +
> > > > > +do_configure:prepend() {
> > > > > +    # provide path to qtwaylandscanner
> > > > > +    export PATH=${PATH}:${STAGING_DIR_NATIVE}/${libexecdir}
> > > > 
> > > > perhaps we should fix naitve qt6 to install qtwaylandscanner in native
> > > > bindir. Then we do not need this.
> > > 
> > > Hi, I brought this up recently in a different discussion
> > > 
> > > https://bugreports.qt.io/browse/QTBUG-116998
> > > 
> > > My understanding is that the move was deliberate and the expectation is
> > > that everybody uses the CMake macros with internal path logic; however,
> > > that fails when not using CMake like here with Meson.
> > 
> > There isn't anything stopping OE from symlinking it in it's recipe?
> > 
> > Cheers,
> > 
> > Richard
> 
> Hi Richard,
> 
> thanks for you answer! Since qtwayland is part of meta-qt6, do I get 
> your comment correct that you suggest creating a symlink
> /usr/bin/qtwaylandscanner -> /usr/libexec/qtwaylandscanner
> for the gstreamer1.0-plugins-good recipe or do you have patching of 
> qtwayland in mind?

I was suggesting you ask meta-qt6 about the idea of the symlink in
their recipe. I didn't know if meta-qt6 was being handled by qt.io or
not though. I may have misunderstood and it is the meta-qt6 people
saying gstreamer are doing it "wrong" in which case this is indeed more
tricky :(.

Cheers,

Richard
Khem Raj Oct. 5, 2023, 9:14 p.m. UTC | #6
On Thu, Oct 5, 2023 at 12:27 PM Richard Purdie
<richard.purdie@linuxfoundation.org> wrote:
>
> On Thu, 2023-10-05 at 21:22 +0200, Andreas Cord-Landwehr wrote:
> > On 04.10.23 20:42, Richard Purdie wrote:
> > > On Wed, 2023-10-04 at 20:19 +0200, Andreas Cord-Landwehr wrote:
> > > > On 04.10.23 20:10, Khem Raj wrote:
> > > > > On Wed, Oct 4, 2023 at 9:09 AM Andreas Cord-Landwehr
> > > > > <cordlandwehr@kde.org> wrote:
> > > > > >
> > > > > > Gstreamer release 1.22.0 introduced option for Qt6 API.
> > > > > >
> > > > > > Signed-off-by: Andreas Cord-Landwehr <cordlandwehr@kde.org>
> > > > > > ---
> > > > > >    .../gstreamer/gstreamer1.0-plugins-good_1.22.5.bb      | 10 ++++++++--
> > > > > >    1 file changed, 8 insertions(+), 2 deletions(-)
> > > > > >
> > > > > > diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb
> > > > > > index 93f0e76ee9..ca1e1d6046 100644
> > > > > > --- a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb
> > > > > > +++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb
> > > > > > @@ -35,7 +35,7 @@ X11DEPENDS = "virtual/libx11 libsm libxrender libxfixes libxdamage"
> > > > > >    X11ENABLEOPTS = "-Dximagesrc=enabled -Dximagesrc-xshm=enabled -Dximagesrc-xfixes=enabled -Dximagesrc-xdamage=enabled"
> > > > > >    X11DISABLEOPTS = "-Dximagesrc=disabled -Dximagesrc-xshm=disabled -Dximagesrc-xfixes=disabled -Dximagesrc-xdamage=disabled"
> > > > > >
> > > > > > -QT5WAYLANDDEPENDS = "${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
> > > > > > +QTWAYLANDDEPENDS = "${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
> > > > > >
> > > > > >    PACKAGECONFIG[asm]        = "-Dasm=enabled,-Dasm=disabled,nasm-native"
> > > > > >    PACKAGECONFIG[bz2]        = "-Dbz2=enabled,-Dbz2=disabled,bzip2"
> > > > > > @@ -52,7 +52,8 @@ PACKAGECONFIG[libpng]     = "-Dpng=enabled,-Dpng=disabled,libpng"
> > > > > >    PACKAGECONFIG[libv4l2]    = "-Dv4l2-libv4l2=enabled,-Dv4l2-libv4l2=disabled,v4l-utils"
> > > > > >    PACKAGECONFIG[mpg123]     = "-Dmpg123=enabled,-Dmpg123=disabled,mpg123"
> > > > > >    PACKAGECONFIG[pulseaudio] = "-Dpulse=enabled,-Dpulse=disabled,pulseaudio"
> > > > > > -PACKAGECONFIG[qt5]        = "-Dqt5=enabled,-Dqt5=disabled,qtbase qtdeclarative qtbase-native ${QT5WAYLANDDEPENDS}"
> > > > > > +PACKAGECONFIG[qt5]        = "-Dqt5=enabled,-Dqt5=disabled,qtbase qtdeclarative qtbase-native ${QTWAYLANDDEPENDS}"
> > > > > > +PACKAGECONFIG[qt6]        = "-Dqt6=enabled,-Dqt6=disabled,qtbase qtdeclarative qtbase-native qttools-native ${QTWAYLANDDEPENDS}"
> > > > > >    PACKAGECONFIG[soup2]      = "-Dsoup=enabled,,libsoup-2.4,,,soup3"
> > > > > >    PACKAGECONFIG[soup3]      = "-Dsoup=enabled,,libsoup,,,soup2"
> > > > > >    PACKAGECONFIG[speex]      = "-Dspeex=enabled,-Dspeex=disabled,speex"
> > > > > > @@ -79,3 +80,8 @@ EXTRA_OEMESON += " \
> > > > > >    "
> > > > > >
> > > > > >    FILES:${PN}-equalizer += "${datadir}/gstreamer-1.0/presets/*.prs"
> > > > > > +
> > > > > > +do_configure:prepend() {
> > > > > > +    # provide path to qtwaylandscanner
> > > > > > +    export PATH=${PATH}:${STAGING_DIR_NATIVE}/${libexecdir}
> > > > >
> > > > > perhaps we should fix naitve qt6 to install qtwaylandscanner in native
> > > > > bindir. Then we do not need this.
> > > >
> > > > Hi, I brought this up recently in a different discussion
> > > >
> > > > https://bugreports.qt.io/browse/QTBUG-116998
> > > >
> > > > My understanding is that the move was deliberate and the expectation is
> > > > that everybody uses the CMake macros with internal path logic; however,
> > > > that fails when not using CMake like here with Meson.
> > >
> > > There isn't anything stopping OE from symlinking it in it's recipe?
> > >
> > > Cheers,
> > >
> > > Richard
> >
> > Hi Richard,
> >
> > thanks for you answer! Since qtwayland is part of meta-qt6, do I get
> > your comment correct that you suggest creating a symlink
> > /usr/bin/qtwaylandscanner -> /usr/libexec/qtwaylandscanner
> > for the gstreamer1.0-plugins-good recipe or do you have patching of
> > qtwayland in mind?
>
> I was suggesting you ask meta-qt6 about the idea of the symlink in
> their recipe. I didn't know if meta-qt6 was being handled by qt.io or
> not though. I may have misunderstood and it is the meta-qt6 people
> saying gstreamer are doing it "wrong" in which case this is indeed more
> tricky :(.

yeah creating a symlink in meta-qt6 should be quick and easy solution.

>
> Cheers,
>
> Richard
Andreas Cord-Landwehr Oct. 9, 2023, 6:26 p.m. UTC | #7
On 05.10.23 23:14, Khem Raj wrote:
> On Thu, Oct 5, 2023 at 12:27 PM Richard Purdie
> <richard.purdie@linuxfoundation.org> wrote:
>>
>> On Thu, 2023-10-05 at 21:22 +0200, Andreas Cord-Landwehr wrote:
>>> On 04.10.23 20:42, Richard Purdie wrote:
>>>> On Wed, 2023-10-04 at 20:19 +0200, Andreas Cord-Landwehr wrote:
>>>>> On 04.10.23 20:10, Khem Raj wrote:
>>>>>> On Wed, Oct 4, 2023 at 9:09 AM Andreas Cord-Landwehr
>>>>>> <cordlandwehr@kde.org> wrote:
>>>>>>>
>>>>>>> Gstreamer release 1.22.0 introduced option for Qt6 API.
>>>>>>>
>>>>>>> Signed-off-by: Andreas Cord-Landwehr <cordlandwehr@kde.org>
>>>>>>> ---
>>>>>>>     .../gstreamer/gstreamer1.0-plugins-good_1.22.5.bb      | 10 ++++++++--
>>>>>>>     1 file changed, 8 insertions(+), 2 deletions(-)
>>>>>>>
>>>>>>> diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb
>>>>>>> index 93f0e76ee9..ca1e1d6046 100644
>>>>>>> --- a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb
>>>>>>> +++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb
>>>>>>> @@ -35,7 +35,7 @@ X11DEPENDS = "virtual/libx11 libsm libxrender libxfixes libxdamage"
>>>>>>>     X11ENABLEOPTS = "-Dximagesrc=enabled -Dximagesrc-xshm=enabled -Dximagesrc-xfixes=enabled -Dximagesrc-xdamage=enabled"
>>>>>>>     X11DISABLEOPTS = "-Dximagesrc=disabled -Dximagesrc-xshm=disabled -Dximagesrc-xfixes=disabled -Dximagesrc-xdamage=disabled"
>>>>>>>
>>>>>>> -QT5WAYLANDDEPENDS = "${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
>>>>>>> +QTWAYLANDDEPENDS = "${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
>>>>>>>
>>>>>>>     PACKAGECONFIG[asm]        = "-Dasm=enabled,-Dasm=disabled,nasm-native"
>>>>>>>     PACKAGECONFIG[bz2]        = "-Dbz2=enabled,-Dbz2=disabled,bzip2"
>>>>>>> @@ -52,7 +52,8 @@ PACKAGECONFIG[libpng]     = "-Dpng=enabled,-Dpng=disabled,libpng"
>>>>>>>     PACKAGECONFIG[libv4l2]    = "-Dv4l2-libv4l2=enabled,-Dv4l2-libv4l2=disabled,v4l-utils"
>>>>>>>     PACKAGECONFIG[mpg123]     = "-Dmpg123=enabled,-Dmpg123=disabled,mpg123"
>>>>>>>     PACKAGECONFIG[pulseaudio] = "-Dpulse=enabled,-Dpulse=disabled,pulseaudio"
>>>>>>> -PACKAGECONFIG[qt5]        = "-Dqt5=enabled,-Dqt5=disabled,qtbase qtdeclarative qtbase-native ${QT5WAYLANDDEPENDS}"
>>>>>>> +PACKAGECONFIG[qt5]        = "-Dqt5=enabled,-Dqt5=disabled,qtbase qtdeclarative qtbase-native ${QTWAYLANDDEPENDS}"
>>>>>>> +PACKAGECONFIG[qt6]        = "-Dqt6=enabled,-Dqt6=disabled,qtbase qtdeclarative qtbase-native qttools-native ${QTWAYLANDDEPENDS}"
>>>>>>>     PACKAGECONFIG[soup2]      = "-Dsoup=enabled,,libsoup-2.4,,,soup3"
>>>>>>>     PACKAGECONFIG[soup3]      = "-Dsoup=enabled,,libsoup,,,soup2"
>>>>>>>     PACKAGECONFIG[speex]      = "-Dspeex=enabled,-Dspeex=disabled,speex"
>>>>>>> @@ -79,3 +80,8 @@ EXTRA_OEMESON += " \
>>>>>>>     "
>>>>>>>
>>>>>>>     FILES:${PN}-equalizer += "${datadir}/gstreamer-1.0/presets/*.prs"
>>>>>>> +
>>>>>>> +do_configure:prepend() {
>>>>>>> +    # provide path to qtwaylandscanner
>>>>>>> +    export PATH=${PATH}:${STAGING_DIR_NATIVE}/${libexecdir}
>>>>>>
>>>>>> perhaps we should fix naitve qt6 to install qtwaylandscanner in native
>>>>>> bindir. Then we do not need this.
>>>>>
>>>>> Hi, I brought this up recently in a different discussion
>>>>>
>>>>> https://bugreports.qt.io/browse/QTBUG-116998
>>>>>
>>>>> My understanding is that the move was deliberate and the expectation is
>>>>> that everybody uses the CMake macros with internal path logic; however,
>>>>> that fails when not using CMake like here with Meson.
>>>>
>>>> There isn't anything stopping OE from symlinking it in it's recipe?
>>>>
>>>> Cheers,
>>>>
>>>> Richard
>>>
>>> Hi Richard,
>>>
>>> thanks for you answer! Since qtwayland is part of meta-qt6, do I get
>>> your comment correct that you suggest creating a symlink
>>> /usr/bin/qtwaylandscanner -> /usr/libexec/qtwaylandscanner
>>> for the gstreamer1.0-plugins-good recipe or do you have patching of
>>> qtwayland in mind?
>>
>> I was suggesting you ask meta-qt6 about the idea of the symlink in
>> their recipe. I didn't know if meta-qt6 was being handled by qt.io or
>> not though. I may have misunderstood and it is the meta-qt6 people
>> saying gstreamer are doing it "wrong" in which case this is indeed more
>> tricky :(.
> 
> yeah creating a symlink in meta-qt6 should be quick and easy solution.

Hi, a short update: I figured out that Meson actually has code to handle 
exactly this situation to detect Qt's tools in libexec. Not sure yet 
what is happening there and why the detection fails. By the way, this 
detection problem holds for further Qt tools (moc, lrelease, rcc...)

Currently looking into this.

Cheers,
Andreas
Sam Van Den Berge Jan. 9, 2024, 9:34 a.m. UTC | #8
On Mon, Oct  9, 2023 at 08:26 PM, Andreas Cord-Landwehr wrote:

>
> 
> On 05.10.23 23:14, Khem Raj wrote:
> > On Thu, Oct 5, 2023 at 12:27 PM Richard Purdie
> > <richard.purdie@linuxfoundation.org> wrote:
> >>
> >> On Thu, 2023-10-05 at 21:22 +0200, Andreas Cord-Landwehr wrote:
> >>> On 04.10.23 20:42, Richard Purdie wrote:
> >>>> On Wed, 2023-10-04 at 20:19 +0200, Andreas Cord-Landwehr wrote:
> >>>>> On 04.10.23 20:10, Khem Raj wrote:
> >>>>>> On Wed, Oct 4, 2023 at 9:09 AM Andreas Cord-Landwehr
> >>>>>> <cordlandwehr@kde.org> wrote:
> >>>>>>>
> >>>>>>> Gstreamer release 1.22.0 introduced option for Qt6 API.
> >>>>>>>
> >>>>>>> Signed-off-by: Andreas Cord-Landwehr <cordlandwehr@kde.org>
> >>>>>>> ---
> >>>>>>>     .../gstreamer/gstreamer1.0-plugins-good_1.22.5.bb      | 10
> ++++++++--
> >>>>>>>     1 file changed, 8 insertions(+), 2 deletions(-)
> >>>>>>>
> >>>>>>> diff --git
> a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb
> b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb
> >>>>>>> index 93f0e76ee9..ca1e1d6046 100644
> >>>>>>> ---
> a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb
> >>>>>>> +++
> b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb
> >>>>>>> @@ -35,7 +35,7 @@ X11DEPENDS = "virtual/libx11 libsm libxrender
> libxfixes libxdamage"
> >>>>>>>     X11ENABLEOPTS = "-Dximagesrc=enabled -Dximagesrc-xshm=enabled
> -Dximagesrc-xfixes=enabled -Dximagesrc-xdamage=enabled"
> >>>>>>>     X11DISABLEOPTS = "-Dximagesrc=disabled -Dximagesrc-xshm=disabled
> -Dximagesrc-xfixes=disabled -Dximagesrc-xdamage=disabled"
> >>>>>>>
> >>>>>>> -QT5WAYLANDDEPENDS = "${@bb.utils.contains("DISTRO_FEATURES",
> "wayland", "qtwayland", "", d)}"
> >>>>>>> +QTWAYLANDDEPENDS = "${@bb.utils.contains("DISTRO_FEATURES",
> "wayland", "qtwayland", "", d)}"
> >>>>>>>
> >>>>>>>     PACKAGECONFIG[asm]        =
> "-Dasm=enabled,-Dasm=disabled,nasm-native"
> >>>>>>>     PACKAGECONFIG[bz2]        = "-Dbz2=enabled,-Dbz2=disabled,bzip2"
> >>>>>>> @@ -52,7 +52,8 @@ PACKAGECONFIG[libpng]     =
> "-Dpng=enabled,-Dpng=disabled,libpng"
> >>>>>>>     PACKAGECONFIG[libv4l2]    =
> "-Dv4l2-libv4l2=enabled,-Dv4l2-libv4l2=disabled,v4l-utils"
> >>>>>>>     PACKAGECONFIG[mpg123]     =
> "-Dmpg123=enabled,-Dmpg123=disabled,mpg123"
> >>>>>>>     PACKAGECONFIG[pulseaudio] =
> "-Dpulse=enabled,-Dpulse=disabled,pulseaudio"
> >>>>>>> -PACKAGECONFIG[qt5]        = "-Dqt5=enabled,-Dqt5=disabled,qtbase
> qtdeclarative qtbase-native ${QT5WAYLANDDEPENDS}"
> >>>>>>> +PACKAGECONFIG[qt5]        = "-Dqt5=enabled,-Dqt5=disabled,qtbase
> qtdeclarative qtbase-native ${QTWAYLANDDEPENDS}"
> >>>>>>> +PACKAGECONFIG[qt6]        = "-Dqt6=enabled,-Dqt6=disabled,qtbase
> qtdeclarative qtbase-native qttools-native ${QTWAYLANDDEPENDS}"
> >>>>>>>     PACKAGECONFIG[soup2]      = "-Dsoup=enabled,,libsoup-2.4,,,soup3"
> >>>>>>>     PACKAGECONFIG[soup3]      = "-Dsoup=enabled,,libsoup,,,soup2"
> >>>>>>>     PACKAGECONFIG[speex]      =
> "-Dspeex=enabled,-Dspeex=disabled,speex"
> >>>>>>> @@ -79,3 +80,8 @@ EXTRA_OEMESON += " \
> >>>>>>>     "
> >>>>>>>
> >>>>>>>     FILES:${PN}-equalizer += "${datadir}/gstreamer-1.0/presets/*.prs"
> >>>>>>> +
> >>>>>>> +do_configure:prepend() {
> >>>>>>> +    # provide path to qtwaylandscanner
> >>>>>>> +    export PATH=${PATH}:${STAGING_DIR_NATIVE}/${libexecdir}
> >>>>>>
> >>>>>> perhaps we should fix naitve qt6 to install qtwaylandscanner in native
> >>>>>> bindir. Then we do not need this.
> >>>>>
> >>>>> Hi, I brought this up recently in a different discussion
> >>>>>
> >>>>> https://bugreports.qt.io/browse/QTBUG-116998
> >>>>>
> >>>>> My understanding is that the move was deliberate and the expectation is
> >>>>> that everybody uses the CMake macros with internal path logic; however,
> >>>>> that fails when not using CMake like here with Meson.
> >>>>
> >>>> There isn't anything stopping OE from symlinking it in it's recipe?
> >>>>
> >>>> Cheers,
> >>>>
> >>>> Richard
> >>>
> >>> Hi Richard,
> >>>
> >>> thanks for you answer! Since qtwayland is part of meta-qt6, do I get
> >>> your comment correct that you suggest creating a symlink
> >>> /usr/bin/qtwaylandscanner -> /usr/libexec/qtwaylandscanner
> >>> for the gstreamer1.0-plugins-good recipe or do you have patching of
> >>> qtwayland in mind?
> >>
> >> I was suggesting you ask meta-qt6 about the idea of the symlink in
> >> their recipe. I didn't know if meta-qt6 was being handled by qt.io or
> >> not though. I may have misunderstood and it is the meta-qt6 people
> >> saying gstreamer are doing it "wrong" in which case this is indeed more
> >> tricky :(.
> > 
> > yeah creating a symlink in meta-qt6 should be quick and easy solution.
> 
> Hi, a short update: I figured out that Meson actually has code to handle 
> exactly this situation to detect Qt's tools in libexec. Not sure yet 
> what is happening there and why the detection fails. By the way, this 
> detection problem holds for further Qt tools (moc, lrelease, rcc...)
> 
> Currently looking into this.

Andreas, did you eventually find anything or did you report this to meson project?

> 
> Cheers,
> Andreas
>
Sam Van Den Berge Jan. 9, 2024, 10:10 a.m. UTC | #9
> > Hi, a short update: I figured out that Meson actually has code to handle
> > exactly this situation to detect Qt's tools in libexec. Not sure yet
> > what is happening there and why the detection fails. By the way, this
> > detection problem holds for further Qt tools (moc, lrelease, rcc...)
> >
> > Currently looking into this.
>
> Andreas, did you eventually find anything or did you report this to meson project?

In the meantime I found this pull request in meson:
https://github.com/mesonbuild/meson/pull/12503
diff mbox series

Patch

diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb
index 93f0e76ee9..ca1e1d6046 100644
--- a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.bb
@@ -35,7 +35,7 @@  X11DEPENDS = "virtual/libx11 libsm libxrender libxfixes libxdamage"
 X11ENABLEOPTS = "-Dximagesrc=enabled -Dximagesrc-xshm=enabled -Dximagesrc-xfixes=enabled -Dximagesrc-xdamage=enabled"
 X11DISABLEOPTS = "-Dximagesrc=disabled -Dximagesrc-xshm=disabled -Dximagesrc-xfixes=disabled -Dximagesrc-xdamage=disabled"
 
-QT5WAYLANDDEPENDS = "${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
+QTWAYLANDDEPENDS = "${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
 
 PACKAGECONFIG[asm]        = "-Dasm=enabled,-Dasm=disabled,nasm-native"
 PACKAGECONFIG[bz2]        = "-Dbz2=enabled,-Dbz2=disabled,bzip2"
@@ -52,7 +52,8 @@  PACKAGECONFIG[libpng]     = "-Dpng=enabled,-Dpng=disabled,libpng"
 PACKAGECONFIG[libv4l2]    = "-Dv4l2-libv4l2=enabled,-Dv4l2-libv4l2=disabled,v4l-utils"
 PACKAGECONFIG[mpg123]     = "-Dmpg123=enabled,-Dmpg123=disabled,mpg123"
 PACKAGECONFIG[pulseaudio] = "-Dpulse=enabled,-Dpulse=disabled,pulseaudio"
-PACKAGECONFIG[qt5]        = "-Dqt5=enabled,-Dqt5=disabled,qtbase qtdeclarative qtbase-native ${QT5WAYLANDDEPENDS}"
+PACKAGECONFIG[qt5]        = "-Dqt5=enabled,-Dqt5=disabled,qtbase qtdeclarative qtbase-native ${QTWAYLANDDEPENDS}"
+PACKAGECONFIG[qt6]        = "-Dqt6=enabled,-Dqt6=disabled,qtbase qtdeclarative qtbase-native qttools-native ${QTWAYLANDDEPENDS}"
 PACKAGECONFIG[soup2]      = "-Dsoup=enabled,,libsoup-2.4,,,soup3"
 PACKAGECONFIG[soup3]      = "-Dsoup=enabled,,libsoup,,,soup2"
 PACKAGECONFIG[speex]      = "-Dspeex=enabled,-Dspeex=disabled,speex"
@@ -79,3 +80,8 @@  EXTRA_OEMESON += " \
 "
 
 FILES:${PN}-equalizer += "${datadir}/gstreamer-1.0/presets/*.prs"
+
+do_configure:prepend() {
+    # provide path to qtwaylandscanner
+    export PATH=${PATH}:${STAGING_DIR_NATIVE}/${libexecdir}
+}