diff mbox series

[meta-ti,master/kirkstone,1/2] ti-sci-fw: Deploy the fw binaries to the deploy directory

Message ID 20231004063430.703304-2-a-limaye@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series Deploy sysfw and dm binaries | expand

Commit Message

Limaye, Aniket Oct. 4, 2023, 6:34 a.m. UTC
Deploy the sysfw binaries to the DEPLOYDIR, to be picked up by the
tisdk-core-bundle... for the prebuilt binaries directory

Signed-off-by: Aniket Limaye <a-limaye@ti.com>
---
 meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb | 11 +++++++++++
 1 file changed, 11 insertions(+)
diff mbox series

Patch

diff --git a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
index ab9356b6..801c8768 100644
--- a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
+++ b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
@@ -1,5 +1,7 @@ 
 SUMMARY = "TI SYSFW/TIFS Firmware"
 
+inherit deploy
+
 require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
 
 COMPATIBLE_MACHINE = "k3r5"
@@ -23,3 +25,12 @@  do_install() {
 }
 
 FILES:${PN} = "${nonarch_base_libdir}/firmware"
+
+do_deploy() {
+	install -d ${DEPLOYDIR}/ti-sysfw
+	install -m 644 ${S}/ti-sysfw/ti-sci-firmware-* ${DEPLOYDIR}/ti-sysfw
+	install -m 644 ${S}/ti-sysfw/ti-fs-firmware-* ${DEPLOYDIR}/ti-sysfw
+	install -m 644 ${S}/ti-sysfw/ti-fs-stub-firmware-* ${DEPLOYDIR}/ti-sysfw
+}
+
+addtask deploy before do_build after do_compile