diff mbox series

[1/2] remove obsolete workaround (https://github.com/python/cpython/commit/33d95c6facdfda3c8c0feffa7a99184e4abc2f63)

Message ID 20231002102320.3692433-1-ross.burton@arm.com
State New
Headers show
Series [1/2] remove obsolete workaround (https://github.com/python/cpython/commit/33d95c6facdfda3c8c0feffa7a99184e4abc2f63) | expand

Commit Message

Ross Burton Oct. 2, 2023, 10:23 a.m. UTC
From: Ross Burton <ross.burton@arm.com>

---
 meta/recipes-devtools/python/python3-numpy_1.26.0.bb | 9 ---------
 1 file changed, 9 deletions(-)

Comments

Ross Burton Oct. 2, 2023, 11:02 a.m. UTC | #1
This was meant to have a better commit message, v2 coming shortly

Ross

> On 2 Oct 2023, at 11:23, Ross Burton via lists.openembedded.org <ross.burton=arm.com@lists.openembedded.org> wrote:
> 
> From: Ross Burton <ross.burton@arm.com>
> 
> ---
> meta/recipes-devtools/python/python3-numpy_1.26.0.bb | 9 ---------
> 1 file changed, 9 deletions(-)
> 
> diff --git a/meta/recipes-devtools/python/python3-numpy_1.26.0.bb b/meta/recipes-devtools/python/python3-numpy_1.26.0.bb
> index 4e1e34e8df3..3ae40a33fb4 100644
> --- a/meta/recipes-devtools/python/python3-numpy_1.26.0.bb
> +++ b/meta/recipes-devtools/python/python3-numpy_1.26.0.bb
> @@ -30,15 +30,6 @@ do_compile:prepend() {
>     export NPY_DISABLE_SVML=1
> }
> 
> -# Unfortunately the following pyc files are non-deterministc due to 'frozenset'
> -# being written without strict ordering, even with PYTHONHASHSEED = 0
> -# Upstream is discussing ways to solve the issue properly, until then let's
> -# just not install the problematic files.
> -# More info: http://benno.id.au/blog/2013/01/15/python-determinism
> -do_install:append() {
> - rm ${D}${PYTHON_SITEPACKAGES_DIR}/numpy/typing/tests/data/pass/__pycache__/literal.cpython*
> -}
> -
> FILES:${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a ${PYTHON_SITEPACKAGES_DIR}/numpy/random/lib/*.a"
> 
> # install what is needed for numpy.test()
> -- 
> 2.34.1
> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#188595): https://lists.openembedded.org/g/openembedded-core/message/188595
> Mute This Topic: https://lists.openembedded.org/mt/101708818/6875888
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [ross.burton@arm.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-numpy_1.26.0.bb b/meta/recipes-devtools/python/python3-numpy_1.26.0.bb
index 4e1e34e8df3..3ae40a33fb4 100644
--- a/meta/recipes-devtools/python/python3-numpy_1.26.0.bb
+++ b/meta/recipes-devtools/python/python3-numpy_1.26.0.bb
@@ -30,15 +30,6 @@  do_compile:prepend() {
     export NPY_DISABLE_SVML=1
 }
 
-# Unfortunately the following pyc files are non-deterministc due to 'frozenset'
-# being written without strict ordering, even with PYTHONHASHSEED = 0
-# Upstream is discussing ways to solve the issue properly, until then let's
-# just not install the problematic files.
-# More info: http://benno.id.au/blog/2013/01/15/python-determinism
-do_install:append() {
-	rm ${D}${PYTHON_SITEPACKAGES_DIR}/numpy/typing/tests/data/pass/__pycache__/literal.cpython*
-}
-
 FILES:${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a ${PYTHON_SITEPACKAGES_DIR}/numpy/random/lib/*.a"
 
 # install what is needed for numpy.test()