glibc: Fix i586/c3 support

Message ID 20211123165519.36922-1-richard.purdie@linuxfoundation.org
State Accepted, archived
Commit 26e4fed594daefb6923c50171360f925c4822683
Headers show
Series glibc: Fix i586/c3 support | expand

Commit Message

Richard Purdie Nov. 23, 2021, 4:55 p.m. UTC
CET can't be enabled on i586 or c3 for x86, adjust the configuration accordingly
to fix those builds.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
 meta/recipes-core/glibc/glibc_2.34.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Khem Raj Nov. 23, 2021, 5:13 p.m. UTC | #1
On 11/23/21 8:55 AM, Richard Purdie wrote:
> CET can't be enabled on i586 or c3 for x86, adjust the configuration accordingly
> to fix those builds.
> 
> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
> ---
>   meta/recipes-core/glibc/glibc_2.34.bb | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/meta/recipes-core/glibc/glibc_2.34.bb b/meta/recipes-core/glibc/glibc_2.34.bb
> index 72064772789..7efc1ec1ef7 100644
> --- a/meta/recipes-core/glibc/glibc_2.34.bb
> +++ b/meta/recipes-core/glibc/glibc_2.34.bb
> @@ -90,7 +90,7 @@ EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
>   
>   EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
>   
> -EXTRA_OECONF:append:x86 = " --enable-cet"
> +EXTRA_OECONF:append:x86 = " ${@bb.utils.contains_any('TUNE_FEATURES', 'i586 c3', '--disable-cet', '--enable-cet', d)}"

does this make glibc tune specific now ?

>   EXTRA_OECONF:append:x86-64 = " --enable-cet"
>   
>   PACKAGECONFIG ??= "nscd memory-tagging"
> 
> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#158611): https://lists.openembedded.org/g/openembedded-core/message/158611
> Mute This Topic: https://lists.openembedded.org/mt/87262863/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Richard Purdie Nov. 23, 2021, 5:47 p.m. UTC | #2
On Tue, 2021-11-23 at 09:13 -0800, Khem Raj wrote:
> 
> On 11/23/21 8:55 AM, Richard Purdie wrote:
> > CET can't be enabled on i586 or c3 for x86, adjust the configuration accordingly
> > to fix those builds.
> > 
> > Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
> > ---
> >   meta/recipes-core/glibc/glibc_2.34.bb | 2 +-
> >   1 file changed, 1 insertion(+), 1 deletion(-)
> > 
> > diff --git a/meta/recipes-core/glibc/glibc_2.34.bb b/meta/recipes-core/glibc/glibc_2.34.bb
> > index 72064772789..7efc1ec1ef7 100644
> > --- a/meta/recipes-core/glibc/glibc_2.34.bb
> > +++ b/meta/recipes-core/glibc/glibc_2.34.bb
> > @@ -90,7 +90,7 @@ EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
> >   
> >   EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
> >   
> > -EXTRA_OECONF:append:x86 = " --enable-cet"
> > +EXTRA_OECONF:append:x86 = " ${@bb.utils.contains_any('TUNE_FEATURES', 'i586 c3', '--disable-cet', '--enable-cet', d)}"
> 
> does this make glibc tune specific now ?

glibc is compiled so it is already tune specific :)

Cheers,

Richard

Patch

diff --git a/meta/recipes-core/glibc/glibc_2.34.bb b/meta/recipes-core/glibc/glibc_2.34.bb
index 72064772789..7efc1ec1ef7 100644
--- a/meta/recipes-core/glibc/glibc_2.34.bb
+++ b/meta/recipes-core/glibc/glibc_2.34.bb
@@ -90,7 +90,7 @@  EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
 
 EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
 
-EXTRA_OECONF:append:x86 = " --enable-cet"
+EXTRA_OECONF:append:x86 = " ${@bb.utils.contains_any('TUNE_FEATURES', 'i586 c3', '--disable-cet', '--enable-cet', d)}"
 EXTRA_OECONF:append:x86-64 = " --enable-cet"
 
 PACKAGECONFIG ??= "nscd memory-tagging"