[1/3] core-image-sato-sdk: allocate more memory when in qemu

Message ID 20220131135408.2857460-1-ross.burton@arm.com
State Accepted, archived
Commit 50ff1f018a670c963e1979dee76ebd696153b4c1
Headers show
Series [1/3] core-image-sato-sdk: allocate more memory when in qemu | expand

Commit Message

Ross Burton Jan. 31, 2022, 1:54 p.m. UTC
Compiling code is memory-intensive, especially kernel modules like the
SystemTap probes, so give the VM 768MB of RAM.  Using 1GB appears to
cause PCI error, interestingly.

Hopefully this solves the intermittent failures caused by OOMs during
the SystemTap test.

[ YOCTO #14673 ]

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta/recipes-sato/images/core-image-sato-sdk.bb | 3 +++
 1 file changed, 3 insertions(+)

Patch

diff --git a/meta/recipes-sato/images/core-image-sato-sdk.bb b/meta/recipes-sato/images/core-image-sato-sdk.bb
index b52de0def02..afab473b52c 100644
--- a/meta/recipes-sato/images/core-image-sato-sdk.bb
+++ b/meta/recipes-sato/images/core-image-sato-sdk.bb
@@ -10,3 +10,6 @@  IMAGE_FEATURES += "dev-pkgs tools-sdk \
 
 IMAGE_INSTALL += "kernel-devsrc"
 
+# Compiling stuff, specifically SystemTap probes, can require lots of memory
+# See https://bugzilla.yoctoproject.org/show_bug.cgi?id=14673
+QB_MEM = "-m 768"