[meta-python,1/2] python3-ansi2html: Upgrade 1.6.0 -> 1.7.0

Message ID 20220131113942.2417929-1-leon.anavi@konsulko.com
State New
Headers show
Series [meta-python,1/2] python3-ansi2html: Upgrade 1.6.0 -> 1.7.0 | expand

Commit Message

Leon Anavi Jan. 31, 2022, 11:39 a.m. UTC
Upgrade to release 1.7.0:

- Replace recommendation of using system packages with pip3
- Add truecolor support
- Generate documentation with Sphinx and use Read the Docs
- Adds support for OSC hyperlink sequences
- Add test coverage
- Replace pkg_resources with importlib.metadata
- Fix including of CHANGELOG.rst
- Update linting dependencies
- Upgrade the build process
- Add type hinting
- Update CI badges in readme
- Bump setuptools-scm version

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../python/python3-ansi2html_1.6.0.bb         | 13 ----------
 .../python/python3-ansi2html_1.7.0.bb         | 25 +++++++++++++++++++
 2 files changed, 25 insertions(+), 13 deletions(-)
 delete mode 100644 meta-python/recipes-devtools/python/python3-ansi2html_1.6.0.bb
 create mode 100644 meta-python/recipes-devtools/python/python3-ansi2html_1.7.0.bb

Patch

diff --git a/meta-python/recipes-devtools/python/python3-ansi2html_1.6.0.bb b/meta-python/recipes-devtools/python/python3-ansi2html_1.6.0.bb
deleted file mode 100644
index 0b6ba9ff7..000000000
--- a/meta-python/recipes-devtools/python/python3-ansi2html_1.6.0.bb
+++ /dev/null
@@ -1,13 +0,0 @@ 
-DESCRPTION = "ansi2html - Convert text with ANSI color codes to HTML or to LaTeX"
-HOMEPAGE = "https://github.com/ralphbean/ansi2html"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=3000208d539ec061b899bce1d9ce9404"
-LICENSE = "GPLv3"
-
-PYPI_PACKAGE = "ansi2html"
-
-SRC_URI[sha256sum] = "0f124ea7efcf3f24f1f9398e527e688c9ae6eab26b0b84e1299ef7f94d92c596"
-
-inherit pypi setuptools3
-
-DEPENDS += "${PYTHON_PN}-setuptools-scm-native ${PYTHON_PN}-toml-native"
-RDEPENDS:${PN} = "${PYTHON_PN}-six"
diff --git a/meta-python/recipes-devtools/python/python3-ansi2html_1.7.0.bb b/meta-python/recipes-devtools/python/python3-ansi2html_1.7.0.bb
new file mode 100644
index 000000000..df50bc7a8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ansi2html_1.7.0.bb
@@ -0,0 +1,25 @@ 
+DESCRPTION = "ansi2html - Convert text with ANSI color codes to HTML or to LaTeX"
+HOMEPAGE = "https://github.com/ralphbean/ansi2html"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3000208d539ec061b899bce1d9ce9404"
+LICENSE = "GPLv3"
+
+PYPI_PACKAGE = "ansi2html"
+
+SRC_URI[sha256sum] = "69316be8c68ac91c5582d397c2890e69c993cc7cda52062ac7e45fcb660d8edc"
+
+inherit pypi setuptools3
+
+DEPENDS += " \
+	${PYTHON_PN}-setuptools-scm-native \
+	${PYTHON_PN}-toml-native \
+"
+
+RDEPENDS:${PN} = " \
+	${PYTHON_PN}-six \
+	${PYTHON_PN}-compression \
+"
+
+do_compile:prepend() {
+	echo "from setuptools import setup" > ${S}/setup.py
+	echo "setup()" >> ${S}/setup.py
+}