diff mbox series

[meta-python] python3-pyhamcrest: Fix upstream check by specifying the UPSTREAM_CHECK_URI and UPSTREAM_CHECK_REGEX

Message ID 20230927033433.1607189-1-derek@asterius.io
State Under Review
Headers show
Series [meta-python] python3-pyhamcrest: Fix upstream check by specifying the UPSTREAM_CHECK_URI and UPSTREAM_CHECK_REGEX | expand

Commit Message

Derek Straka Sept. 27, 2023, 3:34 a.m. UTC
Signed-off-by: Derek Straka <derek@asterius.io>
---
 .../recipes-devtools/python/python3-pyhamcrest_2.0.4.bb        | 3 +++
 1 file changed, 3 insertions(+)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pyhamcrest_2.0.4.bb b/meta-python/recipes-devtools/python/python3-pyhamcrest_2.0.4.bb
index 888278af8..4ee84531e 100644
--- a/meta-python/recipes-devtools/python/python3-pyhamcrest_2.0.4.bb
+++ b/meta-python/recipes-devtools/python/python3-pyhamcrest_2.0.4.bb
@@ -9,6 +9,9 @@  inherit pypi python_setuptools_build_meta
 
 DEPENDS += "${PYTHON_PN}-hatch-vcs-native"
 
+UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/PyHamcrest/"
+UPSTREAM_CHECK_REGEX = "/PyHamcrest/(?P<pver>(\d+[\.\-_]*)+)"
+
 RDEPENDS:${PN} += " \
     ${PYTHON_PN}-six \
     ${PYTHON_PN}-numbers \