diff mbox series

[meta-python,1/6] Remove python3-xmltodict

Message ID 20230925114142.2508458-2-samantha.jalabert@syslinbit.com
State Under Review
Headers show
Series Remove recipes | expand

Commit Message

Samantha Jalabert Sept. 25, 2023, 11:41 a.m. UTC
From: Samantha Jalabert <samantha.jalabert@syslinbit.com>

python3-xmltodict recipe is moved to openembedded-core.

Signed-off-by: Marta Rybczynska <mrybczynska@syslinbit.com>
Signed-off-by: Samantha Jalabert <samantha.jalabert@syslinbit.com>
---
 .../python/python3-xmltodict/run-ptest        |  3 --
 .../python/python3-xmltodict_0.13.0.bb        | 29 -------------------
 2 files changed, 32 deletions(-)
 delete mode 100644 meta-python/recipes-devtools/python/python3-xmltodict/run-ptest
 delete mode 100644 meta-python/recipes-devtools/python/python3-xmltodict_0.13.0.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-xmltodict/run-ptest b/meta-python/recipes-devtools/python/python3-xmltodict/run-ptest
deleted file mode 100644
index 3385d68939..0000000000
--- a/meta-python/recipes-devtools/python/python3-xmltodict/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@ 
-#!/bin/sh
-
-pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
diff --git a/meta-python/recipes-devtools/python/python3-xmltodict_0.13.0.bb b/meta-python/recipes-devtools/python/python3-xmltodict_0.13.0.bb
deleted file mode 100644
index a1f3957adc..0000000000
--- a/meta-python/recipes-devtools/python/python3-xmltodict_0.13.0.bb
+++ /dev/null
@@ -1,29 +0,0 @@ 
-SUMMARY = "Makes working with XML feel like you are working with JSON"
-HOMEPAGE = "https://github.com/martinblech/xmltodict"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=01441d50dc74476db58a41ac10cb9fa2"
-
-SRC_URI[sha256sum] = "341595a488e3e01a85a9d8911d8912fd922ede5fecc4dce437eb4b6c8d037e56"
-
-PYPI_PACKAGE = "xmltodict"
-
-inherit pypi setuptools3 ptest
-
-SRC_URI += " \
-	file://run-ptest \
-"
-
-RDEPENDS:${PN} += " \
-	${PYTHON_PN}-core \
-	${PYTHON_PN}-xml \
-	${PYTHON_PN}-io \
-"
-
-RDEPENDS:${PN}-ptest += " \
-	${PYTHON_PN}-pytest \
-"
-
-do_install_ptest() {
-	install -d ${D}${PTEST_PATH}/tests
-	cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
-}