diff mbox series

[10/17] python3-rdflib: Copy recipe from meta-python

Message ID 20230922144628.2495839-11-samantha.jalabert@syslinbit.com
State Accepted, archived
Commit b8ee52ee86042a4e9b4cce46ac603fbd930cd5b4
Headers show
Series python3-spdx-tools implementation | expand

Commit Message

Samantha Jalabert Sept. 22, 2023, 2:46 p.m. UTC
From: Samantha Jalabert <samantha.jalabert@syslinbit.com>

commit: 7e565b5c0c09a9cd7c27eb24f8fb45a746469279

Signed-off-by: Marta Rybczynska <mrybczynska@syslinbit.com>
---
 .../python/python3-rdflib_7.0.0.bb            | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
 create mode 100644 meta/recipes-devtools/python/python3-rdflib_7.0.0.bb
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-rdflib_7.0.0.bb b/meta/recipes-devtools/python/python3-rdflib_7.0.0.bb
new file mode 100644
index 0000000000..952c210116
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-rdflib_7.0.0.bb
@@ -0,0 +1,19 @@ 
+SUMMARY = "RDFLib is a pure Python package for working with RDF"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=37d489c0cefe52a17e1d5007e196464a"
+
+SRC_URI[sha256sum] = "9995eb8569428059b8c1affd26b25eac510d64f5043d9ce8c84e0d0036e995ae"
+
+inherit pypi python_poetry_core
+
+RDEPENDS:${PN} += " \
+    ${PYTHON_PN}-isodate \
+    ${PYTHON_PN}-pyparsing \
+    ${PYTHON_PN}-logging \
+    ${PYTHON_PN}-numbers \
+    ${PYTHON_PN}-xml \
+    ${PYTHON_PN}-compression \
+    ${PYTHON_PN}-core \
+"
+
+BBCLASSEXTEND = "native nativesdk"