[meta-rockchip] trusted-firmware-a: Pin to use gcc for now

Message ID 20211210011458.1664766-1-raj.khem@gmail.com
State New
Headers show
Series [meta-rockchip] trusted-firmware-a: Pin to use gcc for now | expand

Commit Message

Khem Raj Dec. 10, 2021, 1:14 a.m. UTC
tf-a built with clang is bloated for rk3399 SOCs with 2.6+
it needs looking into, until then use gcc always to build it

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Cc: Jon Mason <jon.mason@arm.com>
Cc: Ross Burton <ross.burton@arm.com>
---
 .../trusted-firmware-a/trusted-firmware-a_%.bbappend       | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Trevor Woerner Dec. 10, 2021, 5:40 a.m. UTC | #1
On Thu 2021-12-09 @ 05:14:58 PM, Khem Raj wrote:
> tf-a built with clang is bloated for rk3399 SOCs with 2.6+
> it needs looking into, until then use gcc always to build it
> 
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> Cc: Jon Mason <jon.mason@arm.com>
> Cc: Ross Burton <ross.burton@arm.com>
> ---
>  .../trusted-firmware-a/trusted-firmware-a_%.bbappend       | 7 +++++++
>  1 file changed, 7 insertions(+)

Applied to meta-rockchip master. Thanks!

Patch

diff --git a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
index 074d0e0..513cea1 100644
--- a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
+++ b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
@@ -12,3 +12,10 @@  SRC_URI += "\
     file://0001-plat_macros.S-Use-compatible-.asciz-asm-directive.patch \
     file://0001-pmu-Do-not-mark-already-defined-functions-as-weak.patch \
 "
+
+
+# code bloats with clang and results in error below now
+# | aarch64-yoe-linux-musl-ld: region `PMUSRAM' overflowed by 3928 bytes
+# this needs fixing until then use gcc
+TOOLCHAIN:rk3399 = "gcc"
+