diff mbox series

[meta-python] python3-dynamic-dispatch: Correct the upstream regex check for version upgrades

Message ID 20230920191746.1344506-1-derek@asterius.io
State Under Review
Headers show
Series [meta-python] python3-dynamic-dispatch: Correct the upstream regex check for version upgrades | expand

Commit Message

Derek Straka Sept. 20, 2023, 7:17 p.m. UTC
Signed-off-by: Derek Straka <derek@asterius.io>
---
 .../recipes-devtools/python/python3-dynamic-dispatch_1.0.3.bb | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-dynamic-dispatch_1.0.3.bb b/meta-python/recipes-devtools/python/python3-dynamic-dispatch_1.0.3.bb
index 9e4a13cff..eeb013d4f 100644
--- a/meta-python/recipes-devtools/python/python3-dynamic-dispatch_1.0.3.bb
+++ b/meta-python/recipes-devtools/python/python3-dynamic-dispatch_1.0.3.bb
@@ -5,11 +5,13 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=ea70b07c354e36056bd35e17c9c3face"
 
 inherit pypi setuptools3
 
-SRC_URI[md5sum] = "6bd3cc24427de753eed0656e89d5302c"
 SRC_URI[sha256sum] = "fbc676aaedc8ec542056c21e5e206b8b62b8d11c3f3c5cfb32b273936da89604"
 
 PYPI_PACKAGE = "dynamic_dispatch"
 
+UPSTREAM_CHECK_URI = "https://pypi.org/project/dynamic-dispatch/"
+UPSTREAM_CHECK_REGEX = "/dynamic-dispatch/(?P<pver>(\d+[\.\-_]*)+)"
+
 DEPENDS += "python3-setuptools-scm-native"
 RDEPENDS:${PN} += "\
   python3-typeguard \