diff mbox series

[meta-python] python3-cantools: Update version 38.0.2 -> 39.2.0

Message ID 20230920183045.1320339-1-derek@asterius.io
State Under Review
Headers show
Series [meta-python] python3-cantools: Update version 38.0.2 -> 39.2.0 | expand

Commit Message

Derek Straka Sept. 20, 2023, 6:30 p.m. UTC
Update the inherit is use the poetry

Changelog
=========
What's Changed
Make cycle_time serialisation more consistent for DBC files by @mon in #592
User f-strings instead of str.format() by @zariiii9003 in #599
Add prog option to argparse for help messages by @jack-champagne in #600

NOTE: This is a major release change with the following API changes:
The initial attribute of Signal objects now always holds the initial signal value as a scaled quantity, unifying its semantics with that of Signal.minimum and Signal.maximum. Previously, initial used raw values for databases loaded from DBC files, while using scaled ones for databases loaded from ARXML. (The loaders for other file formats do not currently set the initial attribute.)
The machinery for storing decimal numbers without rounding errors (*.decimal attributes) has been removed. In its place small rounding errors in load-store-load cycles are now accepted. To remediate this, the resulting database objects can now be compared approximately using the Database.is_similar() method.

Signed-off-by: Derek Straka <derek@asterius.io>
---
 .../python/python3-cantools_38.0.2.bb         | 22 -------------------
 .../python/python3-cantools_39.2.0.bb         | 22 +++++++++++++++++++
 2 files changed, 22 insertions(+), 22 deletions(-)
 delete mode 100644 meta-python/recipes-devtools/python/python3-cantools_38.0.2.bb
 create mode 100644 meta-python/recipes-devtools/python/python3-cantools_39.2.0.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-cantools_38.0.2.bb b/meta-python/recipes-devtools/python/python3-cantools_38.0.2.bb
deleted file mode 100644
index 003573583..000000000
--- a/meta-python/recipes-devtools/python/python3-cantools_38.0.2.bb
+++ /dev/null
@@ -1,22 +0,0 @@ 
-DESCRIPTION = "CAN BUS tools in Python 3."
-HOMEPAGE = "https://github.com/eerimoq/cantools"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=d9aa4ec07de78abae21c490c9ffe61bd"
-
-SRC_URI[sha256sum] = "93bfe6f4bd652f369763ea9162b027a62f424a8400f2423d41137918ce68c68e"
-
-PYPI_PACKAGE = "cantools"
-
-inherit pypi setuptools3
-
-RDEPENDS:${PN} += "\
-	${PYTHON_PN}-can \
-	${PYTHON_PN}-bitstruct \
-	${PYTHON_PN}-core \
-	${PYTHON_PN}-textparser \
-	${PYTHON_PN}-typing-extensions \
-	${PYTHON_PN}-diskcache \
-        ${PYTHON_PN}-asyncio \
-"
-
-CLEANBROKEN = "1"
diff --git a/meta-python/recipes-devtools/python/python3-cantools_39.2.0.bb b/meta-python/recipes-devtools/python/python3-cantools_39.2.0.bb
new file mode 100644
index 000000000..a87aff144
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cantools_39.2.0.bb
@@ -0,0 +1,22 @@ 
+DESCRIPTION = "CAN BUS tools in Python 3."
+HOMEPAGE = "https://github.com/eerimoq/cantools"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d9aa4ec07de78abae21c490c9ffe61bd"
+
+SRC_URI[sha256sum] = "24045c5575217bb5331543e6a55cee822c37ad811dc4a08c75aa2eee3c6d529c"
+
+PYPI_PACKAGE = "cantools"
+
+inherit pypi python_poetry_core
+
+RDEPENDS:${PN} += "\
+    ${PYTHON_PN}-can \
+    ${PYTHON_PN}-bitstruct \
+    ${PYTHON_PN}-core \
+    ${PYTHON_PN}-textparser \
+    ${PYTHON_PN}-typing-extensions \
+    ${PYTHON_PN}-diskcache \
+    ${PYTHON_PN}-asyncio \
+"
+
+CLEANBROKEN = "1"