diff mbox series

[meta-python] python3-bleak: Update receipe 0.20.2 -> 0.21.1

Message ID 20230920163020.1237099-1-derek@asterius.io
State Under Review
Headers show
Series [meta-python] python3-bleak: Update receipe 0.20.2 -> 0.21.1 | expand

Commit Message

Derek Straka Sept. 20, 2023, 4:30 p.m. UTC
Removed a patch the no longer appears to be needed and dropped support for python 3.7

Changelog
=========
0.21.1 (2023-09-08)
Changed
Changed dbus-fast dependency to include v2.x. Fixes #1412.

0.21.0 (2023-09-02)
Added
Added bleak.uuids.normalize_uuid_16() function.
Added bleak.uuids.normalize_uuid_32() function.
Added advertisement_data() async iterator method to BleakScanner. Merged #1361.
Added type hints for kwargs on BleakScanner class methods.
Added support for Python 3.12.
Changed
Improved error messages when failing to get services in WinRT backend.
Improved error messages with enum values in WinRT backend. Fixes #1284.
Scanner backends modified to allow multiple advertisement callbacks. Merged #1367.
Changed default handling of the response argument in BleakClient.write_gatt_char. Fixes #909.
Bleak recipe now automatically installs bleak from GitHub release in Kivy example.
Changed BlueZManager methods to raise BleakError when device is not in BlueZ.
Optimized BlueZ backend device watchers and condition callbacks to avoid linear searches.
Changed type hint for buffer protocol to collections.abc.Buffer.
Fixed
Fixed handling all access denied errors when enumerating characteristics on Windows. Fixes #1291.
Added support for 32bit UUIDs. Fixes #1314.
Fixed typing for BaseBleakScanner detection callback.
Fixed possible crash in _stopped_handler() in WinRT backend. Fixes #1330.
Reduced expensive logging in the BlueZ backend. Merged #1376.
Fixed race condition with "InterfaceRemoved" when getting services in BlueZ backend.
Fixed missing permissions and requirements in android Kivy example. Fixes #1184.
Fixed WinRT backend sometimes hanging forever when a device goes out of range during connection. Fixes #1359.
Removed
Dropped support for Python 3.7.

Signed-off-by: Derek Straka <derek@asterius.io>
---
 ...001-fix-poetry-version-compatibility.patch | 23 -------------------
 ...leak_0.20.2.bb => python3-bleak_0.21.1.bb} |  6 +----
 2 files changed, 1 insertion(+), 28 deletions(-)
 delete mode 100644 meta-python/recipes-devtools/python/python3-bleak/0001-fix-poetry-version-compatibility.patch
 rename meta-python/recipes-devtools/python/{python3-bleak_0.20.2.bb => python3-bleak_0.21.1.bb} (70%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-bleak/0001-fix-poetry-version-compatibility.patch b/meta-python/recipes-devtools/python/python3-bleak/0001-fix-poetry-version-compatibility.patch
deleted file mode 100644
index 051ebbe67..000000000
--- a/meta-python/recipes-devtools/python/python3-bleak/0001-fix-poetry-version-compatibility.patch
+++ /dev/null
@@ -1,23 +0,0 @@ 
-Upstream-Status: Pending
-
---- a/pyproject.toml	2023-04-19 19:04:47.159474100 -0300
-+++ b/pyproject.toml	2023-05-04 08:08:12.289941765 -0300
-@@ -31,15 +31,15 @@
- bleak-winrt = { version = "^1.2.0", markers = "platform_system=='Windows'" }
- dbus-fast = { version = "^1.83.0", markers = "platform_system == 'Linux'" }
- 
--[tool.poetry.group.docs.dependencies]
-+#[tool.poetry.group.docs.dependencies]
- Sphinx = { version = "^5.1.1", python = ">=3.8" }
- sphinx-rtd-theme = "^1.0.0"
- 
--[tool.poetry.group.lint.dependencies]
-+#[tool.poetry.group.lint.dependencies]
- black = "^22.1.0"
- flake8 = { version = "^5.0.0", python = ">=3.8" }
- 
--[tool.poetry.group.test.dependencies]
-+#[tool.poetry.group.test.dependencies]
- asynctest = { version = "^0.13.0",  python = "<3.8" }
- pytest = "^7.0.0"
- pytest-asyncio = "^0.19.0"
diff --git a/meta-python/recipes-devtools/python/python3-bleak_0.20.2.bb b/meta-python/recipes-devtools/python/python3-bleak_0.21.1.bb
similarity index 70%
rename from meta-python/recipes-devtools/python/python3-bleak_0.20.2.bb
rename to meta-python/recipes-devtools/python/python3-bleak_0.21.1.bb
index 9b81efe40..da7bce415 100644
--- a/meta-python/recipes-devtools/python/python3-bleak_0.20.2.bb
+++ b/meta-python/recipes-devtools/python/python3-bleak_0.21.1.bb
@@ -3,11 +3,7 @@  HOMEPAGE = "https://github.com/hbldh/bleak"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=bcbc2069a86cba1b5e47253679f66ed7"
 
-SRC_URI:append = " \
-    file://0001-fix-poetry-version-compatibility.patch \
-"
-
-SRC_URI[sha256sum] = "6c92a47abe34e6dea8ffc5cea9457cbff6e1be966854839dbc25cddb36b79ee4"
+SRC_URI[sha256sum] = "ec4a1a2772fb315b992cbaa1153070c7e26968a52b0e2727035f443a1af5c18f"
 
 PYPI_PACKAGE = "bleak"