diff mbox series

[meta-oe,kirkstone] freeglut: add packageconfigs for x11, wayland, gles, and demos

Message ID 20230915010513.3425887-1-rs@ti.com
State New
Headers show
Series [meta-oe,kirkstone] freeglut: add packageconfigs for x11, wayland, gles, and demos | expand

Commit Message

Randolph Sapp Sept. 15, 2023, 1:05 a.m. UTC
From: Randolph Sapp <rs@ti.com>

Add the PACKAGECONFIG entries to build freeglut for wayland and x11,
which should conflict in this release, and add the ability to build a
GLES release.

Also split the demos their own config. The demos will conflict with the
gles flag as they still require desktop GL in this release. This is
essentially a loose backport of the following patch for this older
release:

a9212722c (freeglut: Add packageconfigs for x11/wayland/gles, 2023-01-10)

It does not change the current default behavior of compiling for x11
with demos.

Signed-off-by: Randolph Sapp <rs@ti.com>
---
 meta-oe/recipes-graphics/freeglut/freeglut_3.2.1.bb | 11 +++++++++--
 1 file changed, 9 insertions(+), 2 deletions(-)

Comments

akuster808 Sept. 19, 2023, 11:49 a.m. UTC | #1
On 9/14/23 9:05 PM, Randolph Sapp via lists.openembedded.org wrote:
> From: Randolph Sapp <rs@ti.com>
>
> Add the PACKAGECONFIG entries to build freeglut for wayland and x11,
> which should conflict in this release, and add the ability to build a
> GLES release.
>
> Also split the demos their own config. The demos will conflict with the
> gles flag as they still require desktop GL in this release. This is
> essentially a loose backport of the following patch for this older
> release:
>
> a9212722c (freeglut: Add packageconfigs for x11/wayland/gles, 2023-01-10)
>
> It does not change the current default behavior of compiling for x11
> with demos.
>
> Signed-off-by: Randolph Sapp <rs@ti.com>
> ---
>   meta-oe/recipes-graphics/freeglut/freeglut_3.2.1.bb | 11 +++++++++--
>   1 file changed, 9 insertions(+), 2 deletions(-)
>
> diff --git a/meta-oe/recipes-graphics/freeglut/freeglut_3.2.1.bb b/meta-oe/recipes-graphics/freeglut/freeglut_3.2.1.bb
> index 6ef9f74c70..a204f86a6f 100644
> --- a/meta-oe/recipes-graphics/freeglut/freeglut_3.2.1.bb
> +++ b/meta-oe/recipes-graphics/freeglut/freeglut_3.2.1.bb
> @@ -10,11 +10,18 @@ SRC_URI[sha256sum] = "d4000e02102acaf259998c870e25214739d1f16f67f99cb35e4f468413
>   inherit cmake features_check
>   
>   # depends on virtual/libx11, virtual/libgl
> -REQUIRED_DISTRO_FEATURES = "x11 opengl"
> +REQUIRED_DISTRO_FEATURES = "opengl"
> +
> +PACKAGECONFIG ?= "x11 demos"
> +
> +PACKAGECONFIG[x11] = ",,virtual/libx11 virtual/libgl libxi libglu,,,wayland"
> +PACKAGECONFIG[wayland] = "-DFREEGLUT_WAYLAND=ON,-DFREEGLUT_WAYLAND=OFF,wayland,,,x11"
> +PACKAGECONFIG[gles] = "-DFREEGLUT_GLES=ON,-DFREEGLUT_GLES=OFF,virtual/libgles1 virtual/libgles2 virtual/egl,,,demos"
> +PACKAGECONFIG[demos] = "-DFREEGLUT_BUILD_DEMOS=ON,-DFREEGLUT_BUILD_DEMOS=OFF"
>   
>   # Do not use -fno-common, check back when upgrading to new version it might not be needed
>   CFLAGS += "-fcommon"
>   
>   PROVIDES += "mesa-glut"
>   
> -DEPENDS = "virtual/libx11 libxmu libxi virtual/libgl libglu libxrandr"
> +DEPENDS = "libxkbcommon"
Is there any reason not to take this commit?  Master and Kirkstone would 
have different implementations for the same thing.

https://git.openembedded.org/meta-openembedded/commit/meta-oe/recipes-graphics/freeglut?h=master-next&id=a9212722c1b1a2ab29215651063ca94fb114c39b

- Armin
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#104881): https://lists.openembedded.org/g/openembedded-devel/message/104881
> Mute This Topic: https://lists.openembedded.org/mt/101371224/3616698
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [akuster808@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-oe/recipes-graphics/freeglut/freeglut_3.2.1.bb b/meta-oe/recipes-graphics/freeglut/freeglut_3.2.1.bb
index 6ef9f74c70..a204f86a6f 100644
--- a/meta-oe/recipes-graphics/freeglut/freeglut_3.2.1.bb
+++ b/meta-oe/recipes-graphics/freeglut/freeglut_3.2.1.bb
@@ -10,11 +10,18 @@  SRC_URI[sha256sum] = "d4000e02102acaf259998c870e25214739d1f16f67f99cb35e4f468413
 inherit cmake features_check
 
 # depends on virtual/libx11, virtual/libgl
-REQUIRED_DISTRO_FEATURES = "x11 opengl"
+REQUIRED_DISTRO_FEATURES = "opengl"
+
+PACKAGECONFIG ?= "x11 demos"
+
+PACKAGECONFIG[x11] = ",,virtual/libx11 virtual/libgl libxi libglu,,,wayland"
+PACKAGECONFIG[wayland] = "-DFREEGLUT_WAYLAND=ON,-DFREEGLUT_WAYLAND=OFF,wayland,,,x11"
+PACKAGECONFIG[gles] = "-DFREEGLUT_GLES=ON,-DFREEGLUT_GLES=OFF,virtual/libgles1 virtual/libgles2 virtual/egl,,,demos"
+PACKAGECONFIG[demos] = "-DFREEGLUT_BUILD_DEMOS=ON,-DFREEGLUT_BUILD_DEMOS=OFF"
 
 # Do not use -fno-common, check back when upgrading to new version it might not be needed
 CFLAGS += "-fcommon"
 
 PROVIDES += "mesa-glut"
 
-DEPENDS = "virtual/libx11 libxmu libxi virtual/libgl libglu libxrandr"
+DEPENDS = "libxkbcommon"