diff mbox series

[04/17] libcgroup: update 3.0.0 -> 3.1.0

Message ID 20230906165633.2382629-4-alex@linutronix.de
State Accepted, archived
Commit 833e8d6fa0b4bdb82baa3dbf0ebd77daaa11efe7
Headers show
Series [01/17] openssl: build and install manpages only if they are enabled | expand

Commit Message

Alexander Kanavin Sept. 6, 2023, 4:56 p.m. UTC
Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 ...pi-Use-GNU-strerror_r-when-available.patch | 55 -------------------
 ...{libcgroup_3.0.0.bb => libcgroup_3.1.0.bb} |  8 +--
 2 files changed, 4 insertions(+), 59 deletions(-)
 delete mode 100644 meta/recipes-core/libcgroup/libcgroup/0001-api-Use-GNU-strerror_r-when-available.patch
 rename meta/recipes-core/libcgroup/{libcgroup_3.0.0.bb => libcgroup_3.1.0.bb} (78%)
diff mbox series

Patch

diff --git a/meta/recipes-core/libcgroup/libcgroup/0001-api-Use-GNU-strerror_r-when-available.patch b/meta/recipes-core/libcgroup/libcgroup/0001-api-Use-GNU-strerror_r-when-available.patch
deleted file mode 100644
index 96321d29707..00000000000
--- a/meta/recipes-core/libcgroup/libcgroup/0001-api-Use-GNU-strerror_r-when-available.patch
+++ /dev/null
@@ -1,55 +0,0 @@ 
-From d190c0c548b3219b75e4c399aa89186e77bbe270 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Tue, 23 Aug 2022 20:03:09 -0700
-Subject: [PATCH] api: Use GNU strerror_r when available
-
-GNU strerror_r is only available in glibc, musl impelents the XSI
-version which is slightly different, therefore check if GNU version is
-available before using it, otherwise use the XSI compliant version.
-
-Upstream-Status: Submitted [https://github.com/libcgroup/libcgroup/pull/236]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- configure.ac | 5 +++++
- src/api.c    | 8 ++++++--
- 2 files changed, 11 insertions(+), 2 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index b68c655..831866d 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -183,6 +183,11 @@ AC_FUNC_REALLOC
- AC_FUNC_STAT
- AC_CHECK_FUNCS([getmntent hasmntopt memset mkdir rmdir strdup])
- 
-+orig_CFLAGS="$CFLAGS"
-+CFLAGS="$CFLAGS -D_GNU_SOURCE"
-+AC_FUNC_STRERROR_R
-+CFLAGS="$orig_CFLAGS"
-+
- AC_SEARCH_LIBS(
- 	[fts_open],
- 	[fts],
-diff --git a/src/api.c b/src/api.c
-index 5c6de11..06aa1d6 100644
---- a/src/api.c
-+++ b/src/api.c
-@@ -4571,9 +4571,13 @@ const char *cgroup_strerror(int code)
- {
- 	int idx = code % ECGROUPNOTCOMPILED;
- 
--	if (code == ECGOTHER)
-+	if (code == ECGOTHER) {
-+#ifdef STRERROR_R_CHAR_P
- 		return strerror_r(cgroup_get_last_errno(), errtext, MAXLEN);
--
-+#else
-+		return strerror_r(cgroup_get_last_errno(), errtext, sizeof (errtext)) ? "unknown error" : errtext;
-+#endif
-+	}
- 	if (idx >= sizeof(cgroup_strerror_codes)/sizeof(cgroup_strerror_codes[0]))
- 		return "Invalid error code";
- 
--- 
-2.37.2
-
diff --git a/meta/recipes-core/libcgroup/libcgroup_3.0.0.bb b/meta/recipes-core/libcgroup/libcgroup_3.1.0.bb
similarity index 78%
rename from meta/recipes-core/libcgroup/libcgroup_3.0.0.bb
rename to meta/recipes-core/libcgroup/libcgroup_3.1.0.bb
index 457b965481d..4b4f19e36fb 100644
--- a/meta/recipes-core/libcgroup/libcgroup_3.0.0.bb
+++ b/meta/recipes-core/libcgroup/libcgroup_3.1.0.bb
@@ -12,15 +12,15 @@  inherit autotools pkgconfig github-releases
 DEPENDS = "bison-native flex-native"
 DEPENDS:append:libc-musl = " fts"
 
-SRC_URI = "${GITHUB_BASE_URI}/download/v3.0/${BP}.tar.gz \
-           file://0001-api-Use-GNU-strerror_r-when-available.patch \
+SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/${BP}.tar.gz \
 "
 UPSTREAM_CHECK_URI = "https://github.com/libcgroup/libcgroup/tags"
 
-SRC_URI[sha256sum] = "8d284d896fca1c981b55850e92acd3ad9648a69227c028dda7ae3402af878edd"
+SRC_URI[sha256sum] = "976ec4b1e03c0498308cfd28f1b256b40858f636abc8d1f9db24f0a7ea9e1258"
 
-PACKAGECONFIG = "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}"
+PACKAGECONFIG = "${@bb.utils.filter('DISTRO_FEATURES', 'pam systemd', d)}"
 PACKAGECONFIG[pam] = "--enable-pam-module-dir=${base_libdir}/security --enable-pam=yes,--enable-pam=no,libpam"
+PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd"
 
 PACKAGES =+ "cgroups-pam-plugin"
 FILES:cgroups-pam-plugin = "${base_libdir}/security/pam_cgroup.so*"