diff mbox series

[meta-python] python3-pymodbus: upgrade 3.4.1 -> 3.5.0

Message ID 1693965427-14266-1-git-send-email-wangmy@fujitsu.com
State New
Headers show
Series [meta-python] python3-pymodbus: upgrade 3.4.1 -> 3.5.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Sept. 6, 2023, 1:57 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

License-Update:
 Remove Copyright from LICENSE: xdist loadscope (test is not split). (#1708)

Changelog:
============
 Async retry (#1752)
 test_client: Fix test_client_protocol_execute() (#1751)
 Use enums for constants (#1743)
 Local Echo Broadcast with Async Clients (#1744)
 Fix #1746 . Return missing result (#1748)
 Document nullmodem. (#1739)
 Add system health check to all tests. (#1736)
 Handle partial message in ReadDeviceInformationResponse (#1738)
 Broadcast with Handle Local Echo (#1737)
 transport_emulator, part II. (#1710)
 Added file AUTHORS, to list all Volunteers. (#1734)
 Fix #1702 and #1728 (#1733)
 Clear retry count when success. (#1732)
 RFC: Reduce parameters for REPL server classes (#1714)
 retries=1, solved. (#1731)
 Impoved the example "server_updating.py" (#1720)
 pylint 3.11 (#1730)
 Correct retry loop. (#1729)
 Fix faulty not check (#1725)
 bugfix local echo handling on sync clients (#1723)
 Updated copyright in LICENSE.
 Correct README pre-commit.
 Fix custom message parsing in RTU framer (#1716)
 Request tracer (#1715)
 pymodbus.server: allow strings for "-p" paramter (#1713)
 New nullmodem and transport. (#1696)
 xdist loadscope (test is not split). (#1708)
 Add client performance example. (#1707)

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{python3-pymodbus_3.4.1.bb => python3-pymodbus_3.5.0.bb}  | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-pymodbus_3.4.1.bb => python3-pymodbus_3.5.0.bb} (84%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pymodbus_3.4.1.bb b/meta-python/recipes-devtools/python/python3-pymodbus_3.5.0.bb
similarity index 84%
rename from meta-python/recipes-devtools/python/python3-pymodbus_3.4.1.bb
rename to meta-python/recipes-devtools/python/python3-pymodbus_3.5.0.bb
index ecc56781a3..1eb25afbaa 100644
--- a/meta-python/recipes-devtools/python/python3-pymodbus_3.4.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pymodbus_3.5.0.bb
@@ -1,10 +1,10 @@ 
 SUMMARY = "A fully featured modbus protocol stack in python"
 HOMEPAGE = "https://github.com/riptideio/pymodbus/"
 LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=430604f78bee72425da231d42eac9cee"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6a146397c35e3d0953758ce8803de347"
 DEPENDS += "python3-six-native"
 
-SRC_URI[sha256sum] = "2a95a311669f6734f94535332984474e4b4815de1500c74e6b94432a8bd9820a"
+SRC_URI[sha256sum] = "4c6fb9af3a6c5a5cba59e4c62812d911f1d5c02dc3aedaaec858990574bc6b4c"
 S = "${WORKDIR}/pymodbus-${PV}"
 
 inherit pypi setuptools3