diff mbox series

collectd: build with rrdcached plugin

Message ID 20230904101258.503-1-aikaterini.voulgari@softcom-int.com
State Under Review
Headers show
Series collectd: build with rrdcached plugin | expand

Commit Message

Aikaterini Voulgari Sept. 4, 2023, 10:12 a.m. UTC
From: Βούλγαρη Αικατερίνη <aikaterini.voulgari@softcom-int.com>

rrdcached package is provided by rrdtool recipe. The build dependency in PACKAGECONFIG is changed to rrdtool.
    The error was:
     Nothing PROVIDES 'rrdcached' but ../collectd_5.12.0.bb DEPENDS on or otherwise requires it). Close matches:
      rrdtool RPROVIDES rrdcached
    ERROR: Required build target 'collectd' has no buildable providers.
    Missing or unbuildable dependency chain was: ['collectd', 'rrdcached']

    With the patch, collectd builds with no errors and the final image I tested includes collectd with rrdcached plugin.
    Tested on custom image with collectd_5.12.0.

Signed-off-by: Βούλγαρη Αικατερίνη <aikaterini.voulgari@softcom-int.com>
---
 meta-oe/recipes-extended/collectd/collectd_5.12.0.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta-oe/recipes-extended/collectd/collectd_5.12.0.bb b/meta-oe/recipes-extended/collectd/collectd_5.12.0.bb
index 5dc64588d..479c12d6a 100644
--- a/meta-oe/recipes-extended/collectd/collectd_5.12.0.bb
+++ b/meta-oe/recipes-extended/collectd/collectd_5.12.0.bb
@@ -50,7 +50,7 @@  PACKAGECONFIG[libmnl] = "--with-libmnl,--without-libmnl,libmnl"
 PACKAGECONFIG[libatasmart] = "--with-libatasmart,--without-libatasmart,libatasmart"
 PACKAGECONFIG[ldap] = "--enable-openldap --with-libldap,--disable-openldap --without-libldap, openldap"
 PACKAGECONFIG[rrdtool] = "--enable-rrdtool,--disable-rrdtool,rrdtool"
-PACKAGECONFIG[rrdcached] = "--enable-rrdcached,--disable-rrdcached,rrdcached"
+PACKAGECONFIG[rrdcached] = "--enable-rrdcached,--disable-rrdcached,rrdtool"
 PACKAGECONFIG[python] = "--enable-python,--disable-python"
 
 EXTRA_OECONF = " \