[meta-oe,dunfell] CVE-2021-3466: polkit Local privilege escalation in pkexec due to incorrect handling of argument vector

Message ID 20220127001425.7392-1-jpuhlman@mvista.com
State New
Headers show
Series [meta-oe,dunfell] CVE-2021-3466: polkit Local privilege escalation in pkexec due to incorrect handling of argument vector | expand

Commit Message

Jeremy Puhlman Jan. 27, 2022, 12:14 a.m. UTC
Upstream-Status: Backport
CVE: CVE-2021-3466
Signed-off-by: Jeremy A. Puhlman <jpuhlman@mvista.com>
---
 .../polkit/files/CVE-2021-4034.patch          | 71 +++++++++++++++++++
 .../recipes-extended/polkit/polkit_0.116.bb   |  1 +
 2 files changed, 72 insertions(+)
 create mode 100644 meta-oe/recipes-extended/polkit/files/CVE-2021-4034.patch

Comments

Ranjitsinh Rathod Jan. 27, 2022, 6:27 a.m. UTC | #1
Seems like the subject line is wrongly saying CVE-2021-3466 CVE.


Thanks,

Best Regards,

Ranjitsinh Rathod
Technical Leader |  | KPIT Technologies Ltd.
Cellphone: +91-84606 92403
akuster808 Jan. 27, 2022, 3:30 p.m. UTC | #2
On 1/26/22 16:14, Jeremy Puhlman wrote:
> Upstream-Status: Backport
> CVE: CVE-2021-3466
> Signed-off-by: Jeremy A. Puhlman <jpuhlman@mvista.com>
> ---
>   .../polkit/files/CVE-2021-4034.patch          | 71 +++++++++++++++++++
>   .../recipes-extended/polkit/polkit_0.116.bb   |  1 +
>   2 files changed, 72 insertions(+)
>   create mode 100644 meta-oe/recipes-extended/polkit/files/CVE-2021-4034.patch
>
> diff --git a/meta-oe/recipes-extended/polkit/files/CVE-2021-4034.patch b/meta-oe/recipes-extended/polkit/files/CVE-2021-4034.patch
> new file mode 100644
> index 000000000..294ada961
> --- /dev/null
> +++ b/meta-oe/recipes-extended/polkit/files/CVE-2021-4034.patch
> @@ -0,0 +1,71 @@
> +From ed8b418f1341cf7fc576f6b17de5c6dd4017e034 Mon Sep 17 00:00:00 2001
> +From: "Jeremy A. Puhlman" <jpuhlman@mvista.com>
> +Date: Thu, 27 Jan 2022 00:01:27 +0000
> +Subject: [PATCH] CVE-2021-4034: Local privilege escalation in pkexec due to
> + incorrect handling of argument vector
> +
> +Upstream-Status: Backport https://gitlab.freedesktop.org/polkit/polkit/-/commit/a2bf5c9c83b6ae46cbd5c779d3055bff81ded683
The patch itself needs to contain this additional information. Please add:

CVE: CVE-2021-xxxx
Signed-off-by: Jeremy A. Puhlman <jpuhlman@mvista.com>

> +---
> + src/programs/pkcheck.c |  6 ++++++
> + src/programs/pkexec.c  | 21 ++++++++++++++++++++-
> + 2 files changed, 26 insertions(+), 1 deletion(-)
> +
> +diff --git a/src/programs/pkcheck.c b/src/programs/pkcheck.c
> +index f1bb4e1..aff4f60 100644
> +--- a/src/programs/pkcheck.c
> ++++ b/src/programs/pkcheck.c
> +@@ -363,6 +363,12 @@ main (int argc, char *argv[])
> +   local_agent_handle = NULL;
> +   ret = 126;
> +
> ++  if (argc < 1)
> ++    {
> ++      help();
> ++      exit(1);
> ++    }
> ++
> +   /* Disable remote file access from GIO. */
> +   setenv ("GIO_USE_VFS", "local", 1);
> +
> +diff --git a/src/programs/pkexec.c b/src/programs/pkexec.c
> +index 7698c5c..3ff4c58 100644
> +--- a/src/programs/pkexec.c
> ++++ b/src/programs/pkexec.c
> +@@ -488,6 +488,17 @@ main (int argc, char *argv[])
> +   pid_t pid_of_caller;
> +   gpointer local_agent_handle;
> +
> ++
> ++  /*
> ++   * If 'pkexec' is called wrong, just show help and bail out.
> ++   */
> ++  if (argc<1)
> ++    {
> ++      clearenv();
> ++      usage(argc, argv);
> ++      exit(1);
> ++    }
> ++
> +   ret = 127;
> +   authority = NULL;
> +   subject = NULL;
> +@@ -636,7 +647,15 @@ main (int argc, char *argv[])
> +           goto out;
> +         }
> +       g_free (path);
> +-      argv[n] = path = s;
> ++      path = s;
> ++
> ++      /* argc<2 and pkexec runs just shell, argv is guaranteed to be null-terminated.
> ++       * /-less shell shouldn't happen, but let's be defensive and don't write to null-termination
> ++       */
> ++      if (argv[n] != NULL)
> ++      {
> ++        argv[n] = path;
> ++      }
> +     }
> +   if (access (path, F_OK) != 0)
> +     {
> +--
> +2.26.2
> +
> diff --git a/meta-oe/recipes-extended/polkit/polkit_0.116.bb b/meta-oe/recipes-extended/polkit/polkit_0.116.bb
> index ad1973b13..77288b008 100644
> --- a/meta-oe/recipes-extended/polkit/polkit_0.116.bb
> +++ b/meta-oe/recipes-extended/polkit/polkit_0.116.bb
> @@ -25,6 +25,7 @@ PAM_SRC_URI = "file://polkit-1_pam.patch"
>   SRC_URI = "http://www.freedesktop.org/software/polkit/releases/polkit-${PV}.tar.gz \
>              ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)} \
>              file://0003-make-netgroup-support-optional.patch \
> +           file://CVE-2021-4034.patch \
>              "
>   SRC_URI[md5sum] = "4b37258583393e83069a0e2e89c0162a"
>   SRC_URI[sha256sum] = "88170c9e711e8db305a12fdb8234fac5706c61969b94e084d0f117d8ec5d34b1"
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#95110): https://lists.openembedded.org/g/openembedded-devel/message/95110
> Mute This Topic: https://lists.openembedded.org/mt/88710808/3616698
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [akuster808@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>

Patch

diff --git a/meta-oe/recipes-extended/polkit/files/CVE-2021-4034.patch b/meta-oe/recipes-extended/polkit/files/CVE-2021-4034.patch
new file mode 100644
index 000000000..294ada961
--- /dev/null
+++ b/meta-oe/recipes-extended/polkit/files/CVE-2021-4034.patch
@@ -0,0 +1,71 @@ 
+From ed8b418f1341cf7fc576f6b17de5c6dd4017e034 Mon Sep 17 00:00:00 2001
+From: "Jeremy A. Puhlman" <jpuhlman@mvista.com>
+Date: Thu, 27 Jan 2022 00:01:27 +0000
+Subject: [PATCH] CVE-2021-4034: Local privilege escalation in pkexec due to 
+ incorrect handling of argument vector
+
+Upstream-Status: Backport https://gitlab.freedesktop.org/polkit/polkit/-/commit/a2bf5c9c83b6ae46cbd5c779d3055bff81ded683
+---
+ src/programs/pkcheck.c |  6 ++++++
+ src/programs/pkexec.c  | 21 ++++++++++++++++++++-
+ 2 files changed, 26 insertions(+), 1 deletion(-)
+
+diff --git a/src/programs/pkcheck.c b/src/programs/pkcheck.c
+index f1bb4e1..aff4f60 100644
+--- a/src/programs/pkcheck.c
++++ b/src/programs/pkcheck.c
+@@ -363,6 +363,12 @@ main (int argc, char *argv[])
+   local_agent_handle = NULL;
+   ret = 126;
+ 
++  if (argc < 1)
++    {
++      help();
++      exit(1);
++    }
++
+   /* Disable remote file access from GIO. */
+   setenv ("GIO_USE_VFS", "local", 1);
+ 
+diff --git a/src/programs/pkexec.c b/src/programs/pkexec.c
+index 7698c5c..3ff4c58 100644
+--- a/src/programs/pkexec.c
++++ b/src/programs/pkexec.c
+@@ -488,6 +488,17 @@ main (int argc, char *argv[])
+   pid_t pid_of_caller;
+   gpointer local_agent_handle;
+ 
++
++  /*
++   * If 'pkexec' is called wrong, just show help and bail out.
++   */
++  if (argc<1)
++    {
++      clearenv();
++      usage(argc, argv);
++      exit(1);
++    }
++
+   ret = 127;
+   authority = NULL;
+   subject = NULL;
+@@ -636,7 +647,15 @@ main (int argc, char *argv[])
+           goto out;
+         }
+       g_free (path);
+-      argv[n] = path = s;
++      path = s;
++
++      /* argc<2 and pkexec runs just shell, argv is guaranteed to be null-terminated.
++       * /-less shell shouldn't happen, but let's be defensive and don't write to null-termination
++       */
++      if (argv[n] != NULL)
++      {
++        argv[n] = path;
++      }
+     }
+   if (access (path, F_OK) != 0)
+     {
+-- 
+2.26.2
+
diff --git a/meta-oe/recipes-extended/polkit/polkit_0.116.bb b/meta-oe/recipes-extended/polkit/polkit_0.116.bb
index ad1973b13..77288b008 100644
--- a/meta-oe/recipes-extended/polkit/polkit_0.116.bb
+++ b/meta-oe/recipes-extended/polkit/polkit_0.116.bb
@@ -25,6 +25,7 @@  PAM_SRC_URI = "file://polkit-1_pam.patch"
 SRC_URI = "http://www.freedesktop.org/software/polkit/releases/polkit-${PV}.tar.gz \
            ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)} \
            file://0003-make-netgroup-support-optional.patch \
+           file://CVE-2021-4034.patch \
            "
 SRC_URI[md5sum] = "4b37258583393e83069a0e2e89c0162a"
 SRC_URI[sha256sum] = "88170c9e711e8db305a12fdb8234fac5706c61969b94e084d0f117d8ec5d34b1"