diff mbox series

mc: upgrade 4.8.29 -> 4.8.30

Message ID 1693449412-28006-1-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit 9ba1f7042de6e430c687970657173740eec9ea7b
Headers show
Series mc: upgrade 4.8.29 -> 4.8.30 | expand

Commit Message

Mingyu Wang (Fujitsu) Aug. 31, 2023, 2:36 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

0001-mc-replace-perl-w-with-use-warnings.patch
removed since it's included in 4.8.30

Changelog:
==========
- Core
--------
    * Support PCRE2 as search engine (via ----with-search-engine=pcre2) (#4450)
    * Implement panelization buffers for both file panels (#4370)

- VFS
-------
    * tar: support extended headers (including long file names and sparse files) (#1952, #2201)
    * extfs helpers: replace "perl -w" with "use warnings" (MidnightCommander/mc#174)
    * extfs/patchfs: be more specific in error message (#4485)

- Editor
---------
    * Add syntax highlighting:
        - Jenkinsfiles (#4469)
        - B language (#4470)
    * Improve syntax highlighting:
        - ECMAScript (MidnightCommander/mc#172)
        - ECMAScript in TypeScript (MidnightCommander/mc#172)
        - use diff syntax highlighting for git commit messages (COMMIT_EDITMSG) (MidnightCommander/mc#85)

- Misc
--------
    * Code cleanup (#4426, #4438)
    * Filehighlight:
        - recognize vsix files as zip files (MidnightCommander/mc#171)
    * Skin updates:
        - julia256 (#4441, #4445)

- Fixes
----------
    * Usage of 'sed' in build system/makefiles is not portable (#4459, #4466)
    * Unportable '$<' in Makefiles (#4460)
    * FTBFS if ncurses used without --with-ncurses-includes= configure parameter (#4462)
    * Ncurses library is duplicated in MCLIBS (#4463, #4465)
    * FTBFS without ext2fs attributes support (#4464)
    * Wrong sort order after swapping panels (#4432)
    * Incorrect time delimiter in the copy/move progress window (#4437)
    * Incorrect redraw of overlapped file panels (#4408)
    * Subshell/Command line prompt is empty/missing (#3121)
    * Find file: relative ignore directory is applied to the start search directory (#4235)
    * Diff viewer: options are not applied on second run (#4486)
    * mc.ext.ini: 'Edit' command from 'Default' section is ignored (#4434)
    * mc.ext.ini: .md files are not recognized as Markdown ones by extension (#4444)
    * mcedit: off-by-one error in paragraph formatting (#4446)
    * ftp: incomplete file listing: block and character devices, pipes, sockets are missed (#4472)
    * Various typos in the source code (MidnightCommander/mc#177, MidnightCommander/mc#178)

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 ...-mc-replace-perl-w-with-use-warnings.patch | 127 ------------------
 .../mc/{mc_4.8.29.bb => mc_4.8.30.bb}         |   3 +-
 2 files changed, 1 insertion(+), 129 deletions(-)
 delete mode 100644 meta/recipes-extended/mc/files/0001-mc-replace-perl-w-with-use-warnings.patch
 rename meta/recipes-extended/mc/{mc_4.8.29.bb => mc_4.8.30.bb} (95%)
diff mbox series

Patch

diff --git a/meta/recipes-extended/mc/files/0001-mc-replace-perl-w-with-use-warnings.patch b/meta/recipes-extended/mc/files/0001-mc-replace-perl-w-with-use-warnings.patch
deleted file mode 100644
index 5ede82d342..0000000000
--- a/meta/recipes-extended/mc/files/0001-mc-replace-perl-w-with-use-warnings.patch
+++ /dev/null
@@ -1,127 +0,0 @@ 
-From 62c86b69106d0d702167ba1b963ea1c201cce5af Mon Sep 17 00:00:00 2001
-From: Robert Yang <liezhi.yang@windriver.com>
-Date: Thu, 6 Apr 2017 02:24:28 -0700
-Subject: [PATCH] mc: replace "perl -w" with "use warnings"
-
-The shebang's max length is usually 128 as defined in
-/usr/include/linux/binfmts.h:
-  #define BINPRM_BUF_SIZE 128
-
-There would be errors when @PERL@ is longer than 128, use
-'/usr/bin/env perl' can fix the problem, but '/usr/bin/env perl -w'
-doesn't work:
-
-/usr/bin/env: perl -w: No such file or directory
-
-So replace "perl -w" with "use warnings" to make it work.
-
-The man2hlp.in already has "use warnings;", so just remove '-w' is OK.
-
-Upstream-Status: Submitted [https://github.com/MidnightCommander/mc/pull/174]
-
-Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-
----
- src/man2hlp/man2hlp.in           | 2 +-
- src/vfs/extfs/helpers/a+.in      | 4 +++-
- src/vfs/extfs/helpers/mailfs.in  | 3 ++-
- src/vfs/extfs/helpers/patchfs.in | 3 ++-
- src/vfs/extfs/helpers/ulib.in    | 4 +++-
- src/vfs/extfs/helpers/uzip.in    | 3 ++-
- 6 files changed, 13 insertions(+), 6 deletions(-)
-
-diff --git a/src/man2hlp/man2hlp.in b/src/man2hlp/man2hlp.in
-index 08765d8..8aa7131 100644
---- a/src/man2hlp/man2hlp.in
-+++ b/src/man2hlp/man2hlp.in
-@@ -1,4 +1,4 @@
--#! @PERL_FOR_BUILD@ -w
-+#! @PERL_FOR_BUILD@
- #
- #  Man page to help file converter
- #  Copyright (C) 1994, 1995, 1998, 2000, 2001, 2002, 2003, 2004, 2005,
-diff --git a/src/vfs/extfs/helpers/a+.in b/src/vfs/extfs/helpers/a+.in
-index 579441c..fe446f4 100644
---- a/src/vfs/extfs/helpers/a+.in
-+++ b/src/vfs/extfs/helpers/a+.in
-@@ -1,4 +1,4 @@
--#! @PERL@ -w
-+#! @PERL@
- #
- # External filesystem for mc, using mtools
- # Written Ludek Brukner <lubr@barco.cz>, 1997
-@@ -9,6 +9,8 @@
- 
- # These mtools components must be in PATH for this to work
- 
-+use warnings;
-+
- sub quote {
-     $_ = shift(@_);
-     s/([^\w\/.+-])/\\$1/g;
-diff --git a/src/vfs/extfs/helpers/mailfs.in b/src/vfs/extfs/helpers/mailfs.in
-index 4bdd68b..5bb373b 100644
---- a/src/vfs/extfs/helpers/mailfs.in
-+++ b/src/vfs/extfs/helpers/mailfs.in
-@@ -1,6 +1,7 @@
--#! @PERL@ -w
-+#! @PERL@
- 
- use bytes;
-+use warnings;
- 
- # MC extfs for (possibly compressed) Berkeley style mailbox files
- # Peter Daum <gator@cs.tu-berlin.de> (Jan 1998, mc-4.1.24)
-diff --git a/src/vfs/extfs/helpers/patchfs.in b/src/vfs/extfs/helpers/patchfs.in
-index c20cd54..1f1e75b 100644
---- a/src/vfs/extfs/helpers/patchfs.in
-+++ b/src/vfs/extfs/helpers/patchfs.in
-@@ -1,4 +1,4 @@
--#! @PERL@ -w
-+#! @PERL@
- #
- # Written by Adam Byrtek <alpha@debian.org>, 2002
- # Rewritten by David Sterba <dave@jikos.cz>, 2009
-@@ -9,6 +9,7 @@
- 
- use bytes;
- use strict;
-+use warnings;
- use POSIX;
- use File::Temp 'tempfile';
- 
-diff --git a/src/vfs/extfs/helpers/ulib.in b/src/vfs/extfs/helpers/ulib.in
-index 418611f..82c7ccf 100644
---- a/src/vfs/extfs/helpers/ulib.in
-+++ b/src/vfs/extfs/helpers/ulib.in
-@@ -1,9 +1,11 @@
--#! @PERL@ -w
-+#! @PERL@
- #
- # VFS to manage the gputils archives.
- # Written by Molnár Károly (proton7@freemail.hu) 2012
- #
- 
-+use warnings;
-+
- my %month = ('jan' => '01', 'feb' => '02', 'mar' => '03',
-              'apr' => '04', 'may' => '05', 'jun' => '06',
-              'jul' => '07', 'aug' => '08', 'sep' => '09',
-diff --git a/src/vfs/extfs/helpers/uzip.in b/src/vfs/extfs/helpers/uzip.in
-index c468f3a..ceffb53 100644
---- a/src/vfs/extfs/helpers/uzip.in
-+++ b/src/vfs/extfs/helpers/uzip.in
-@@ -1,4 +1,4 @@
--#! @PERL@ -w
-+#! @PERL@
- #
- # zip file archive Virtual File System for Midnight Commander
- # Version 1.4.0 (2001-08-07).
-@@ -9,6 +9,7 @@
- use POSIX;
- use File::Basename;
- use strict;
-+use warnings;
- 
- #
- # Configuration options
diff --git a/meta/recipes-extended/mc/mc_4.8.29.bb b/meta/recipes-extended/mc/mc_4.8.30.bb
similarity index 95%
rename from meta/recipes-extended/mc/mc_4.8.29.bb
rename to meta/recipes-extended/mc/mc_4.8.30.bb
index e7f4aacc2e..258ac38e15 100644
--- a/meta/recipes-extended/mc/mc_4.8.29.bb
+++ b/meta/recipes-extended/mc/mc_4.8.30.bb
@@ -9,10 +9,9 @@  RDEPENDS:${PN} = "ncurses-terminfo-base"
 RRECOMMENDS:${PN} = "ncurses-terminfo"
 
 SRC_URI = "http://www.midnight-commander.org/downloads/${BPN}-${PV}.tar.bz2 \
-           file://0001-mc-replace-perl-w-with-use-warnings.patch \
            file://nomandate.patch \
            "
-SRC_URI[sha256sum] = "ba6b2d8752806ac23fe045c1b081eb66dcefa6159205c79f86c005dcaf9941c1"
+SRC_URI[sha256sum] = "38171f22f889e3030ec9055463d3ecd7843984ab24e6497d8294d1c441a7ddb4"
 
 inherit autotools gettext pkgconfig