diff mbox series

[1/2] Remove explicit SRCPV

Message ID 20230829162224.2459115-1-ross.burton@arm.com
State New
Headers show
Series [1/2] Remove explicit SRCPV | expand

Commit Message

Ross Burton Aug. 29, 2023, 4:22 p.m. UTC
From: Ross Burton <ross.burton@arm.com>

As of oe-core a8e7b0f, PV doesn't need to contain SRCPV explicitly as
base.bbclass will append it to PKGV if there is a + in the version. So,
remove the redundant assignments.

Also change the boot-wrapper-aarch64 PV to 0+git as it's possible that
some point they'll tag a release and we want to be able to upgrade to it.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 .../recipes-bsp/external-system/external-system_0.1.0.bb       | 3 ++-
 .../recipes-bsp/images/n1sdp-board-firmware_2022.06.22.bb      | 2 +-
 meta-arm-bsp/recipes-bsp/scp-firmware/scp-firmware-n1sdp.inc   | 2 +-
 .../trusted-firmware-a/trusted-firmware-a-n1sdp.inc            | 2 +-
 .../corstone1000-external-sys-tests_1.0.bb                     | 2 +-
 .../boot-wrapper-aarch64/boot-wrapper-aarch64_git.bb           | 2 +-
 meta-arm/recipes-devtools/gn/gn_git.bb                         | 2 +-
 .../recipes-security/trusted-services/trusted-services-src.inc | 2 +-
 8 files changed, 9 insertions(+), 8 deletions(-)

Comments

Jon Mason Aug. 30, 2023, 1:41 a.m. UTC | #1
On Tue, 29 Aug 2023 17:22:23 +0100, ross.burton@arm.com wrote:
> As of oe-core a8e7b0f, PV doesn't need to contain SRCPV explicitly as
> base.bbclass will append it to PKGV if there is a + in the version. So,
> remove the redundant assignments.
> 
> Also change the boot-wrapper-aarch64 PV to 0+git as it's possible that
> some point they'll tag a release and we want to be able to upgrade to it.
> 
> [...]

Applied, thanks!

[1/2] Remove explicit SRCPV
      commit: ff334d8f65b724dde7be7bc994fa961743522fc5
[2/2] arm-bsp/external-system: set PACKAGE_ARCH as this is machine-specific
      commit: 730806956a783f3562fb1742993355613fab3b80

Best regards,
diff mbox series

Patch

diff --git a/meta-arm-bsp/recipes-bsp/external-system/external-system_0.1.0.bb b/meta-arm-bsp/recipes-bsp/external-system/external-system_0.1.0.bb
index 8b09ab0d..e047d2a6 100644
--- a/meta-arm-bsp/recipes-bsp/external-system/external-system_0.1.0.bb
+++ b/meta-arm-bsp/recipes-bsp/external-system/external-system_0.1.0.bb
@@ -10,8 +10,9 @@  LIC_FILES_CHKSUM = "file://license.md;md5=e44b2531cd6ffe9dece394dbe988d9a0 \
 
 SRC_URI = "gitsm://git.gitlab.arm.com/arm-reference-solutions/corstone1000/external_system/rtx.git;protocol=https;branch=master \
            file://race.patch"
+
 SRCREV = "8c9dca74b104ff6c9722fb0738ba93dd3719c080"
-PV .= "+git${SRCPV}"
+PV .= "+git"
 
 COMPATIBLE_MACHINE = "(corstone1000)"
 
diff --git a/meta-arm-bsp/recipes-bsp/images/n1sdp-board-firmware_2022.06.22.bb b/meta-arm-bsp/recipes-bsp/images/n1sdp-board-firmware_2022.06.22.bb
index 6a27f02e..1b502e52 100644
--- a/meta-arm-bsp/recipes-bsp/images/n1sdp-board-firmware_2022.06.22.bb
+++ b/meta-arm-bsp/recipes-bsp/images/n1sdp-board-firmware_2022.06.22.bb
@@ -14,7 +14,7 @@  COMPATIBLE_MACHINE = "n1sdp"
 SRC_URI = "git://git.gitlab.arm.com/arm-reference-solutions/board-firmware.git;protocol=https;branch=n1sdp"
 
 SRCREV = "70ba494265eee76747faff38264860c19e214540"
-PV .= "+git${SRCPV}"
+PV .= "+git"
 
 S = "${WORKDIR}/git"
 
diff --git a/meta-arm-bsp/recipes-bsp/scp-firmware/scp-firmware-n1sdp.inc b/meta-arm-bsp/recipes-bsp/scp-firmware/scp-firmware-n1sdp.inc
index 482ea327..41d8f448 100644
--- a/meta-arm-bsp/recipes-bsp/scp-firmware/scp-firmware-n1sdp.inc
+++ b/meta-arm-bsp/recipes-bsp/scp-firmware/scp-firmware-n1sdp.inc
@@ -15,7 +15,7 @@  EXTRA_OECMAKE:append = " \
 "
 # scp-firmware version aligning to Arm Reference Solutions N1SDP-2023.06.22 Release
 SRCREV = "543ae8ca3c9e38da3058311118fa3ceef1da47f7"
-PV .= "+git${SRCPV}"
+PV .= "+git"
 
 do_install:append() {
    fiptool \
diff --git a/meta-arm-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a-n1sdp.inc b/meta-arm-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a-n1sdp.inc
index fdb12982..c2fa223c 100644
--- a/meta-arm-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a-n1sdp.inc
+++ b/meta-arm-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a-n1sdp.inc
@@ -2,7 +2,7 @@ 
 
 # Align with N1SDP-2023.06.22 Manifest
 SRCREV_tfa  = "31f60a968347497562b0129134928d7ac4767710"
-PV .= "+git${SRCPV}"
+PV .= "+git"
 
 COMPATIBLE_MACHINE = "n1sdp"
 TFA_PLATFORM       = "n1sdp"
diff --git a/meta-arm-bsp/recipes-test/corstone1000-external-sys-tests/corstone1000-external-sys-tests_1.0.bb b/meta-arm-bsp/recipes-test/corstone1000-external-sys-tests/corstone1000-external-sys-tests_1.0.bb
index 47434204..0fa01b58 100644
--- a/meta-arm-bsp/recipes-test/corstone1000-external-sys-tests/corstone1000-external-sys-tests_1.0.bb
+++ b/meta-arm-bsp/recipes-test/corstone1000-external-sys-tests/corstone1000-external-sys-tests_1.0.bb
@@ -6,7 +6,7 @@  LIC_FILES_CHKSUM = "file://license.md;md5=e44b2531cd6ffe9dece394dbe988d9a0"
 
 SRC_URI = "git://git.gitlab.arm.com/arm-reference-solutions/corstone1000/applications.git;protocol=https;branch=master"
 SRCREV = "2945cd92f7c6dbe4999ee72cd5cf1e2615eedba7"
-PV .= "+git${SRCPV}"
+PV .= "+git"
 
 COMPATIBLE_MACHINE = "corstone1000"
 
diff --git a/meta-arm/recipes-bsp/boot-wrapper-aarch64/boot-wrapper-aarch64_git.bb b/meta-arm/recipes-bsp/boot-wrapper-aarch64/boot-wrapper-aarch64_git.bb
index cb79069b..775f4064 100644
--- a/meta-arm/recipes-bsp/boot-wrapper-aarch64/boot-wrapper-aarch64_git.bb
+++ b/meta-arm/recipes-bsp/boot-wrapper-aarch64/boot-wrapper-aarch64_git.bb
@@ -9,7 +9,7 @@  SRCREV = "d3b1a15d18542b2086e72bfdc3fc43f454772a3b"
 # boot-wrapper doesn't make releases
 UPSTREAM_CHECK_COMMITS = "1"
 
-PV = "git${SRCPV}"
+PV = "0+git"
 
 S = "${WORKDIR}/git"
 
diff --git a/meta-arm/recipes-devtools/gn/gn_git.bb b/meta-arm/recipes-devtools/gn/gn_git.bb
index 4b021bbe..5a6f19db 100644
--- a/meta-arm/recipes-devtools/gn/gn_git.bb
+++ b/meta-arm/recipes-devtools/gn/gn_git.bb
@@ -7,7 +7,7 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=0fca02217a5d49a14dfe2d11837bb34d"
 SRC_URI = "git://gn.googlesource.com/gn;protocol=https;branch=main \
            file://0001-Replace-lstat64-stat64-functions-on-linux.patch"
 SRCREV = "4bd1a77e67958fb7f6739bd4542641646f264e5d"
-PV = "0+git${SRCPV}"
+PV = "0+git"
 
 S = "${WORKDIR}/git"
 B = "${WORKDIR}/build"
diff --git a/meta-arm/recipes-security/trusted-services/trusted-services-src.inc b/meta-arm/recipes-security/trusted-services/trusted-services-src.inc
index 002b038c..86eb5083 100644
--- a/meta-arm/recipes-security/trusted-services/trusted-services-src.inc
+++ b/meta-arm/recipes-security/trusted-services/trusted-services-src.inc
@@ -16,7 +16,7 @@  SRCREV_trusted-services = "08b3d39471f4914186bd23793dc920e83b0e3197"
 LIC_FILES_CHKSUM = "file://${S}/license.rst;md5=ea160bac7f690a069c608516b17997f4"
 
 S = "${WORKDIR}/git/trusted-services"
-PV ?= "0.0+git${SRCPV}"
+PV ?= "0.0+git"
 
 # DTC, tag "v1.6.1"
 SRC_URI += "git://github.com/dgibson/dtc;name=dtc;protocol=https;branch=main;destsuffix=git/dtc"